[regression] specifying -DMIR_PLATFORM to one platform causes cmake failure

Bug #1480932 reported by Kevin DuBois on 2015-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Low
Kevin DuBois
mir (Ubuntu)
Undecided
Unassigned

Bug Description

eg,
cmake -DCMAKE_TOOLCHAIN_FILE=../cmake/LinuxCrossCompile.cmake -DCMAKE_INSTALL_PREFIX=/home/phablet/mir .. -DMIR_ENABLE_TESTS=yes

gives:

Linking CXX executable ../../bin/mir_unit_tests.bin
/usr/lib/gcc-cross/arm-linux-gnueabihf/4.9/../../../../arm-linux-gnueabihf/bin/ld: cannot find -lmirsharedmesaservercommon-static
/usr/lib/gcc-cross/arm-linux-gnueabihf/4.9/../../../../arm-linux-gnueabihf/bin/ld: cannot find -lmirsharedmesaservercommon-static
collect2: error: ld returned 1 exit status

Related branches

Kevin DuBois (kdub) on 2015-08-03
Changed in mir:
status: New → In Progress
assignee: nobody → Kevin DuBois (kdub)
Changed in mir:
milestone: none → 0.16.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.16.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Minor regression. Origin seems to be the introduction of mesa-x11.

summary: - specifying -DMIR_PLATFORM to one platform causes cmake failure
+ [regression] specifying -DMIR_PLATFORM to one platform causes cmake
+ failure
tags: added: regression
Changed in mir:
milestone: 0.16.0 → 0.15.0
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers