Bootloop with system language Turkish on the Nexus 4

Bug #1398984 reported by Niklas Wenzel on 2014-12-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Michael Terry
0.8
Won't Fix
High
Unassigned
0.9
Won't Fix
High
Unassigned
mir (Ubuntu)
High
Unassigned
mir (Ubuntu RTM)
High
Unassigned

Bug Description

Lately, a member (Ümit) of the XDA Developers forum reported that his Nexus 4 always goes into a bootloop when he sets the system language to Turkish.
It doesn't matter whether he sets it in the system settings wizard which is shown on first boot or in the system settings application.
If he sets it in the system settings wizard, he won't get to see the OS after finishing the setup process, and if he changes the language in the system settings application, the phone will hang after a reboot.
In any case, he will see the spinning "circle of friends" logo but the Unity8 dash will never appear.

Here's the link to his first forum post regarding it issue. The discussion continues on the next few pages:
http://forum.xda-developers.com/nexus-4/general/rom-ubuntu-touch-14-10-utopic-unico-t2324683/post57093935#post57093935

He's running build #10 in the stable Ubuntu RTM channel.

Related branches

Niklas Wenzel (nikwen) on 2014-12-03
description: updated
Michael Terry (mterry) wrote :

The fact that this happens in Turkish makes me think it is due (somewhere) to a common problem with Turkish localization: the "Turkish i problem" [1].

Basically, tolower() or toupper() may not work like someone is expecting, because they take locale into account.

[1] http://haacked.com/archive/2012/07/05/turkish-i-problem-and-why-you-should-care.aspx/

Michael Terry (mterry) wrote :

I'm going to change this but to unity8, since that is what is failing to come up, not the system settings. I'm betting that the system settings/wizard are correctly setting Turkish locale, then unity8 can't deal with it.

affects: ubuntu-system-settings (Ubuntu) → unity8 (Ubuntu)
affects: ubuntu-system-settings (Ubuntu RTM) → unity8 (Ubuntu RTM)
Michael Terry (mterry) wrote :

This is from Mir's conversion of environment variables into program options. It takes MIR_SERVER_PROMPT_FILE from unity8's upstart job and converts it into "prompt-fIle" which causes the following error:

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::program_options::unknown_option> >'
  what(): unrecognised option 'prompt-fIle'

affects: unity8 (Ubuntu) → mir (Ubuntu)
affects: unity8 (Ubuntu RTM) → mir (Ubuntu RTM)
Michael Terry (mterry) on 2014-12-04
Changed in mir (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Changed in mir:
assignee: nobody → Michael Terry (mterry)
milestone: none → 0.10.0
status: New → In Progress
Changed in mir (Ubuntu):
assignee: Michael Terry (mterry) → nobody
status: In Progress → New
Changed in mir:
importance: Undecided → High
Changed in mir (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in mir (Ubuntu RTM):
importance: Undecided → High
status: New → Triaged
no longer affects: ubuntu-translations
Changed in mir:
status: In Progress → Fix Committed
Niklas Wenzel (nikwen) wrote :

I just wanted to pop in and say thank you for looking into it and fixing it. It's really appreciated. :)

Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package mir - 0.10.0+15.04.20150107.2-0ubuntu1

---------------
mir (0.10.0+15.04.20150107.2-0ubuntu1) vivid; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.10.0 (https://launchpad.net/mir/+milestone/0.10.0)
    - Enhancements:
      . Added support for Android HWC 1.3 devices.
      . Plumbing/preparation to support external displays on Android devices.
      . Reduced build dependencies.
      . Client API: Added version macros.
      . Began work on automatic driver probing, to intelligently choose the
        best driver for you.
      . Demo shell (mir_proving_server): Added desktop zoom feature using
        Super + mouse wheel.
      . Demo renamed: mir_demo_server_shell -> mir_proving_server
      . Other demo servers merged into -> mir_demo_server
      . Wider support for display buffer pixel formats in the mesa driver, for
        wider hardware support.
      . Performance: On mesa/desktop at least; only hold compositor buffers
        for the duration of the render, instead of the duration of the frame.
        Following this change the compositor report can now finally report
        render time instead of frame time.
      . Mir now starts reliably when a TV is connected by HDMI, and up to
        4K resolution (2160p) is known to work.
      . Plenty more enhancements logged in the bugs list below.
    - ABI summary: Servers need rebuilding, but clients do not;
      . Mirclient ABI unchanged at 8
      . Mircommon ABI unchanged at 3
      . Mirplatform ABI bumped to 5
      . Mirserver ABI bumped to 28
    - Bug fixes:
      . [regression] Mir servers (since 0.9) randomly crash in malloc due to
        heap corruption (LP: #1401488)
      . USC - mouse cursor on AMD graphics is drawing incorrectly
        (LP: #1391975)
      . Mir fails to start when a TV is connected by HDMI
        [std::exception::what: Invalid or inconsistent display configuration]
        (LP: #1395405)
      . Input/event driven clients may freeze indefinitely (LP: #1396006)
      . Mir server crashes with "std::exception::what: Failed to get front
        buffer object" when trying to fullscreen a surface (LP: #1398296)
      . Switching windows with a Trusted Prompt Session active loses the
        trusted prompt session (LP: #1355173)
      . CI test failure in multiple tests (LP: #1401364)
      . dh_install: usr/bin/mir_demo_server exists in debian/tmp but is not
        installed to anywhere (LP: #1401365)
      . [regression] demo-shell: Instead of moving surfaces they now fly
        off-screen (LP: #1403702)
      . [regression] Binaries are no longer runnable on other machines (or in
        other directories) (LP: #1406073)
      . [i865] unity-system-compositor fails to start: Failed to choose ARGB
        EGL config (LP: #1212753)
      . Mir's compositor holds buffers (blocking clients) for the duration of
        the frame, even when not necessary. (LP: #1264934)
      . Screen goes blank (black) briefly during display config changes which
        don't affect the display mode (LP: #1274359)
      . [enhancement] There should be a quit signal sent to sessions instead
        of killing them dir...

Read more...

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers