Ubuntu

minicom scripts never exit

Reported by Jesse Gilles on 2010-05-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
High
Chuck Short
minicom
Unknown
Unknown
minicom (Ubuntu)
Low
Chuck Short
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: minicom

Using Ubuntu 10.04 LTS 32-bit, minicom 2.4-1

If you run a script from within minicom while attached to a serial port, the script doesn't exit when finished. Minicom hangs indefinitely, until the user hits CTRL-C. Then the script exits and control is returned to minicom as normal. Also, any output from the commands executed by the script are only printed after the user presses CTRL-C. Adding an expiclit "exit 0" command to the script makes no difference.

This seems to be a new bug in minicom 2.4 -- I have had no problems running scripts with minicom 2.3 or older in previous Ubuntu releases.

description: updated
Chuck Short (zulcss) wrote :

Thanks, there seems to be a patch attached to that bug report, would you be able to test it?

chuck

Changed in minicom (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Jesse Gilles (jesse-gilles) wrote :

I tested the latest version from mercurial (which includes the patch) and it resolves the issue.

Changed in minicom (Ubuntu):
status: Confirmed → Fix Committed
Chuck Short (zulcss) wrote :

No its not.

Changed in minicom (Ubuntu):
status: Fix Committed → Triaged
Jesse Gilles (jesse-gilles) wrote :

OK, sorry -- I thought "Fix Committed" meant a fix had been committed to the upstream source.

Jesse Gilles (jesse-gilles) wrote :

On a related issue, I noticed the remote bug watcher for alioth.debian.org isn't working -- it looks like it is using the wrong URL.

Thierry Carrez (ttx) on 2010-06-02
Changed in server-papercuts:
importance: Undecided → High
milestone: none → maverick-alpha-2
status: New → Triaged
Chuck Short (zulcss) on 2010-06-03
Changed in minicom (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package minicom - 2.4-2ubuntu1

---------------
minicom (2.4-2ubuntu1) maverick; urgency=low

  * debian/patches/fix-hanging-minicom-scripts.diff: Backported fix
    from minicom mercurial tree. Fixes minicom hanging when running
    scripts. Who would have thunk it...people still use minicom.
    (LP: #585911)
 -- Chuck Short <email address hidden> Thu, 03 Jun 2010 09:34:29 -0400

Changed in minicom (Ubuntu):
status: Triaged → Fix Released
Thierry Carrez (ttx) on 2010-06-03
Changed in server-papercuts:
assignee: nobody → Chuck Short (zulcss)
status: Triaged → Fix Released
Jesse Gilles (jesse-gilles) wrote :

I suppose the chance of this fix being released for lucid is pretty low?

Thierry Carrez (ttx) wrote :

It makes sense to push it for lucid as well, yes, and I just nominated this.
That said, this is a community-supported package, so if someone could follow the SRU process to make it happen, that would be great :) It's about applying the same patch that Chuck applied to maverick.

See https://wiki.ubuntu.com/StableReleaseUpdates

Jesse Gilles (jesse-gilles) wrote :

I would certainly be willing to do this since I would like to see it fixed in lucid, but I don't have rights to upload a package to lucid-proposed (I'm not a package maintainer).

Thierry Carrez (ttx) wrote :

@Jesse: you can ask for sponsoring for the last part of the work. Steps 1 to 3, and the necessary debdiff, can be prepared without the upload rights. Once ready, just subscribe the ubuntu-sponsors team so that they upload your lucid-proposed package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in minicom (Ubuntu Lucid):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.