mimedefang: md-mx-ctrl reread does not work

Bug #1624394 reported by Richard Laager on 2016-09-16
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mimedefang (Ubuntu)
High
Unassigned
Xenial
High
Brian Murray

Bug Description

[Impact]

This is a regression.

While the main purpose of this is to "reread the filter rules", the biggest use by frequency is to reload the SpamAssassin rules. In our production deployment, this happens up to daily--every time their is a SpamAssassin rule update released.

Without the ability to use "reread", one must fall back on "restart". That's a disruptive operation that will result in mail being tempfailed for a short period of time.

If sysadmins have not noticed this regression, then rule changes are not getting applied properly, though normal slave turnover eventually brings them in.

[Test Case]

Steps to reproduce:
sudo md-mx-ctrl reread

Expected results:
Forced reread of filter rules

Actual results:
Cannot destroy and recreate a Perl interpreter safely on this platform. Filter rules will NOT be reread.

[Regression Potential]

The regression potential is small. The patch changes a ./configure test only. The only impact on the application code comes from the SAFE_EMBED_PERL #define being correctly enabled again, which it has been "forever".

[Other Info]

This patch has been accepted upstream:
http://lists.roaringpenguin.com/pipermail/mimedefang/2016-September/037862.html

I am running this change in production, as installed from our PPA:
https://launchpad.net/~wiktel/+archive/ubuntu/ppa

Richard Laager (rlaager) wrote :
description: updated
description: updated
Mathew Hodson (mhodson) on 2016-09-16
Changed in mimedefang (Ubuntu):
importance: Undecided → High
Richard Laager (rlaager) on 2016-09-16
description: updated
description: updated
Marcus Schopen (marcus-5) wrote :

I can confirm Richard's patch. I rebuilt a package and since then reread works very well. A good idea might be to place a script in /etc/mail/spamassassin/sa-update-hooks.d to automatically reread mimedefang after sa-update. I guess most users forget a reread after sa-update therefore new updates never catch until reboot or manual mimedefang restart.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mimedefang (Ubuntu):
status: New → Confirmed
Mathew Hodson (mhodson) on 2016-09-20
tags: added: patch
Daniel Holbach (dholbach) wrote :

I'm uploading this to yakkety first.

Can the patch be forward to upstream and Debian too?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mimedefang - 2.78-1ubuntu2

---------------
mimedefang (2.78-1ubuntu2) yakkety; urgency=medium

  * Use $PTHREAD_FLAG in the SAFE_EMBED_PERL test. This allows, at runtime,
    md-mx-ctrl reread (and /etc/init.d/mimedefang reread) to work. (LP:
    #1624394)

 -- Richard Laager <email address hidden> Thu, 15 Sep 2016 00:02:52 -0500

Changed in mimedefang (Ubuntu):
status: Confirmed → Fix Released
Richard Laager (rlaager) wrote :

The patch was already accepted upstream and a new release cut.

Mathew Hodson (mhodson) on 2016-10-06
description: updated
Changed in mimedefang (Ubuntu Xenial):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I've uploaded this to the SRU queue for review by the SRU team.

Changed in mimedefang (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)

Hello Richard, or anyone else affected,

Accepted mimedefang into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mimedefang/2.78-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mimedefang (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Richard Laager (rlaager) wrote :

I confirmed that 2.78-1ubuntu1.1 works correctly on Xenial.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mimedefang - 2.78-1ubuntu1.1

---------------
mimedefang (2.78-1ubuntu1.1) xenial; urgency=medium

  * Use $PTHREAD_FLAG in the SAFE_EMBED_PERL test. This allows, at runtime,
    md-mx-ctrl reread (and /etc/init.d/mimedefang reread) to work.
    (LP: #1624394)

 -- Richard Laager <email address hidden> Tue, 28 Feb 2017 09:51:31 -0800

Changed in mimedefang (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mimedefang has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers