Milkyplay doesn't have sound

Bug #1019517 reported by Mikko Översti on 2012-06-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
milkytracker (Ubuntu)
Undecided
Unassigned

Bug Description

Milkyplay doesn't play any file which are playable in milkytracker. At least I can't hear anything. Sound works in other programs just fine. For example:

$ milkyplayer milky.xm
- MilkyPlay -

Playing milky.xm (press ctrl+c to quit) ...
Title: milk in veins
SDL: Using audio driver: pulse
SDL: Buffer size = 2048 samples (requested 4096)
0/0

It seems to be playing, right? Can't hear anything. Running Lubuntu 12.04 on Asus Eee 1005HA.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: milkytracker 0.90.85+dfsg-2.1
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic i686
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Sat Jun 30 09:12:02 2012
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: milkytracker
UpgradeStatus: No upgrade log present (probably fresh install)

Mikko Översti (arvoitusmies) wrote :
description: updated
Sasa Paporovic (melchiaros) wrote :

Please attach an example file. This is goog style and whithout the workload to any developer is to high.

And please give a step by step description like pushing this button, choosing that, waiting for, and so on. Give a good algorithmic description, that is complete and can guide a beginner in milkytracker.

After that set the status of this report back to new.

Thank you

Changed in milkytracker (Ubuntu):
status: New → Incomplete
Mikko Översti (arvoitusmies) wrote :

1. Download the attachment (example song from official milkytracker website)
2. In lxterminal window type "milkyplay milky.xm" in the directory you downloaded the file
3. milkyplay doesn't produce any sound, but has some terminal textual output.

Changed in milkytracker (Ubuntu):
status: Incomplete → New
Sasa Paporovic (melchiaros) wrote :

I can confirm.

No sound with milkyplay on systems that have sound with other players.

The console output is:

~/Downloads$ milkyplay milky.xm
- MilkyPlay -

Playing milky.xm (press ctrl+c to quit) ...
Title: milk in veins
SDL: Using audio driver: pulse
SDL: Buffer size = 2048 samples (requested 4096)
0/0

Changed in milkytracker (Ubuntu):
status: New → Confirmed
Sasa Paporovic (melchiaros) wrote :

A upstream bugtracker do not exist.

Instead a email was send to

<email address hidden>

tags: added: amd64
Sasa Paporovic (melchiaros) wrote :
rpkrawczyk (rpkrawczyk) wrote :

Have you heard anything from upstream? I have exactly the same problem...

Sasa Paporovic (melchiaros) wrote :

No reaction from upstream.

rpkrawczyk (rpkrawczyk) wrote :

Some further information: if you press 'p' twice(!) then sometimes the songs starts to play but mostly you get a segfault. The milkyplayer.cpp code is actually from debian, is the error known there?

rpkrawczyk (rpkrawczyk) wrote :

Compiling without stripping gives me the following backtrace. As said in my last comment I pressed 'p' twice.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package milkytracker - 0.90.86+dfsg-1

---------------
milkytracker (0.90.86+dfsg-1) unstable; urgency=medium

  * New upstream version. (Closes: #777424)
    - Fixes bugs reported by Jindřich Makovička. (Closes: #628235)
  * Remove milkyplay. (Closes: #716566, #818742, LP: #1019517)
    - The code is Debian specific, unmaintained, and broken since 2012.

  * debian/control:
    - Set the Multimedia Team as the maintainer, and Gürkan as an uploader.
    - Add myself to the list of uploaders.
    - Bump standards to 3.9.8.
    - Add Vcs-* fields.
  * debian/copyright:
    - Rewrite in machine readable format.
  * debian/doc-base:
    - Register MilkyTracker manual with doc-base.
  * debian/install:
    - Use dh-exec to rename milkytracker icon.
    - Install icon into correct directory.
  * debian/menu:
    - Remove per TC decision. (See: #741573)
  * debian/patches:
    - Drop all original patches - applied upstream.
    - 01_add-alsalibs: Link against alsa to fix linker errors.
    - 02_debundle-rtmidi: Build against system rtmidi.
    - 03_debundle-zziplib: Build against system zziplib. The code which FTBFS
      using gcc-6 is no longer used after this patch. (Closes: #811897)
    - 04_use-lhasa: The shipped copy of lha is under a non-free license, so
      port the lha decompession code to use the free lhasa library.
  * debian/rules:
    - Switch to debhelper 9 and use dh.
    - Enable all hardening options.
    - Enable parallel build.
  * debian/watch:
    - Add a watch file.

 -- James Cowgill <email address hidden> Sat, 07 May 2016 13:27:37 +0100

Changed in milkytracker (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions