No boot Mikutter 3.5.9,14 on Ubuntu17.10

Bug #1733041 reported by kapper1224 on 2017-11-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mikutter (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Mikutter 17.10 package snd PPA 3.5.14+dfsg-1.
But no boot and error messages.
I will copy it.

Thank you.

~/mikutter$ mikutter
/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- cairo-gobject (LoadError)
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/vendor_ruby/pango.rb:19:in `<top (required)>'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/vendor_ruby/gtk2/base.rb:14:in `<top (required)>'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/vendor_ruby/gtk2.rb:11:in `<top (required)>'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/share/mikutter/core/plugin/gtk/gtk.rb:5:in `<top (required)>'
 from /usr/share/mikutter/core/miquire_plugin.rb:155:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:155:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:148:in `block in load'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:148:in `block in load'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:98:in `block in load_all'
 from /usr/share/mikutter/core/miquire_plugin.rb:38:in `block in each_spec'
 from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:36:in `each_spec'
 from /usr/share/mikutter/core/miquire_plugin.rb:96:in `load_all'
 from /usr/share/mikutter/core/boot/load_plugin.rb:10:in `<top (required)>'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
 from /usr/share/mikutter/core/miquire.rb:95:in `file_or_directory_require'
 from /usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
 from /usr/share/mikutter/core/miquire.rb:75:in `each'
 from /usr/share/mikutter/core/miquire.rb:75:in `miquire'
 from /usr/share/mikutter/core/miquire.rb:18:in `miquire'
 from /usr/share/mikutter/mikutter.rb:39:in `<main>'

kapper1224 (kapper1224-w) wrote :

I am update 「Ruby2.4」 on PPA、and 「sudo apt install glib2.0」now.
But no boot and this error messages now.

:~/mikutter$ mikutter
/usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- glib2.so (LoadError)
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/vendor_ruby/glib2.rb:129:in `rescue in <top (required)>'
 from /usr/lib/ruby/vendor_ruby/glib2.rb:125:in `<top (required)>'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/vendor_ruby/gtk2/base.rb:12:in `<top (required)>'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/vendor_ruby/gtk2.rb:11:in `<top (required)>'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/share/mikutter/core/plugin/gtk/gtk.rb:5:in `<top (required)>'
 from /usr/share/mikutter/core/miquire_plugin.rb:155:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:155:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:148:in `block in load'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:148:in `block in load'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:146:in `load'
 from /usr/share/mikutter/core/miquire_plugin.rb:98:in `block in load_all'
 from /usr/share/mikutter/core/miquire_plugin.rb:38:in `block in each_spec'
 from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:33:in `each'
 from /usr/share/mikutter/core/miquire_plugin.rb:36:in `each_spec'
 from /usr/share/mikutter/core/miquire_plugin.rb:96:in `load_all'
 from /usr/share/mikutter/core/boot/load_plugin.rb:10:in `<top (required)>'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
 from /usr/share/mikutter/core/miquire.rb:95:in `file_or_directory_require'
 from /usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
 from /usr/share/mikutter/core/miquire.rb:75:in `each'
 from /usr/share/mikutter/core/miquire.rb:75:in `miquire'
 from /usr/share/mikutter/core/miquire.rb:18:in `miquire'
 from /usr/share/mikutter/mikutter.rb:39:in `<main>'

kapper1224 (kapper1224-w) wrote :

I installed 「sudo apt install ruby-cairo-gobject」,
Mikutter is operated now.
This pacakges needs 「ruby-cairo-gobject」, I think it Ubuntu17.10 now.

Thank you!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mikutter (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers