Migrate Documents and Settings Stalled on 7.04 beta

Bug #95422 reported by JA Guy on 2007-03-24
6
Affects Status Importance Assigned to Milestone
migration-assistant (Ubuntu)
Undecided
Evan

Bug Description

Binary package hint: migration-assistant

System Spec
- Intel P4 2.8GHZ 512MB
- No Windows Partitions
- OpenSuse 10.2 Installed on hd0
- Existing 7.04 Herd 5 existing on hd1 but corrupted

Issue (Similar to some but different)
=============================
Not sure if this is a bug. but this stage of the installation takes for ever. I let it ran for over 1 hour and still nothings happened. Is this a bug or the detection process as you said is very slow.

I strongly recommend that this step be optional.

Thanks, and I am anxiously awaiting April 19th...

Evan (ev) wrote :

It sounds like the installer may have crashed in the background if it never got past the Migrate Documents and Settings page.

Could you run the installer again using the --debug option and attach /var/log/installer/debug and /var/log/syslog to this but report? Detailed instructions can be found here:
http://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

Thanks!

Changed in migration-assistant:
assignee: nobody → evand
status: Unconfirmed → Needs Info
JA Guy (ja-guy) wrote :

How do you run the installer with --debug option? From the booted LiveCD or from the LiveCD boot menu?

JA Guy (ja-guy) wrote :

/var/log/installer/debug

Evan (ev) wrote :

From the booted LiveCD environment, go to Applications->Accessories->Terminal. In the terminal window type, `ubiquity --debug`.

JA Guy (ja-guy) wrote :

Attaching /var/log/installer/debug

JA Guy (ja-guy) wrote :

Adding /var/log/syslog

Hezekiah Carty (hez) wrote :

I'm having the same issue. The install log is attached, I will attach the syslog next...

Sony Vaio VGN-S260 laptop
Pentium-M 1.7ghz
ATI 9200m 32mb video
512mb RAM
Dapper is installed on hda2 (/root) and hda3 (/home)
I am attempting to install Feisty Beta fully on hda1, with the Dapper root mounted as /media/RealRoot and home as /media/RealHome

Hezekiah Carty (hez) wrote :

Here is the syslog associated with the above installation attempt

Steve Dodd (anarchetic) wrote :

I'm having similar problems to those reported above, using the Feisty beta desktop CD. The system I'm trying to install on has two Win2K installs on hda1 and hda4, and an edgy install on hda3. The migration assistant seems to be crashing dealing with one of the Win2K partitions (see attached logs); hiding the NTFS partitions by zeroing the first few blocks (merely changing the type didn't work) allowed me to get past this point; the edgy partition seems to have been processed ok.

Incidentally, I think this worked OK with the Herd 5 CD.

Syslog and debug attached.

Steve Dodd (anarchetic) wrote :

Here's the syslog.

Evan (ev) on 2007-03-25
Changed in migration-assistant:
status: Needs Info → In Progress
Steve Dodd (anarchetic) wrote :

Actually, looking at this in more detail, all the logs here (and in #94878) apart from mine show a problem reading xxx/users for an ext2/3 partition, whereas mine is a problem reading <user>/items for an NTFS (Win2K) partition.

The appearance to the user is the same (install hung in m-a), though, and the traceback is very similar. If there are likely to be many different problems that cause this sort of failure, perhaps these exceptions should be caught and the user informed that there was problem? They could then choose to skip migration which would at least allow the install to proceed. Maybe even offer to call apport to report the problem?

Evan (ev) wrote :

JA Guy or Hezekiah Carty, could you possibly edit /usr/lib/ubiquity/migration-assistant/ma-ask on the live CD (sudo gedit /usr/lib/ubiquity/migration-assitant/ma-ask) and put `set -x` on the second line, then run the installer again until it crashes and attach /var/log/syslog to this bug report? If you cannot do this, don't worry about it, I'll try to proceed without that information.

Thanks!

Steve Dodd (anarchetic) wrote :

Hi Evan,

I've been poking into this a bit more; I tried running ma-search-items by hand:

root@ubuntu:/usr/lib/ubiquity/migration-assistant# ./ma-search-items --ostype="windowsxp" --user="Administrator" --path="/mnt/migrationassistant/"
Pointed to a location other than C:, exiting.

The Win2K partition it's trying to probe is /dev/hda1, but for historical reasons thinks its drive letter is E:, so I guess registry references to profile locations will use that drive letter. I imagine this is a fairly uncommon case, but perhaps it should at least fail gracefully (and allow the install to continue) for the feisty release?

Steve

JA Guy (ja-guy) wrote :

/var/log/syslog after adding the line "set -x" to ma-ask

Colin Watson (cjwatson) wrote :

migration-assistant (0.4.3) feisty; urgency=low

  * Possible fix for ostype not getting set in the -ask and -apply
    scripts. Also added some temporary debugging information.
    (LP: #93197)
  * If the /home partition device doesn't exist under the same name in
    the running kernel, fail gracefully and continue to the next OS.
    (LP: #94878)
  * Added more logging and crash partial recovery.
  * Gracefully fail and continue on items where a non C: drive letter
    comes into play. (LP: #95422)
  * Don't import Windows default bookmarks. Import, but don't set
    "Bliss" as the default wallpaper.

 -- Evan Dandrea <email address hidden> Tue, 27 Mar 2007 03:44:25 -0400

Changed in migration-assistant:
status: In Progress → Fix Released
bzimage (yaohuihuang) wrote :

I got my solution:
boot into X from the install CD, edit file /usr/lib/ubiquity/migration-assistant/ma-ask,
put a new line at header position:
exit 10
then run install icon on desktop, it will fail on the step, continue anyway.
It works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers