The installation froze at step 6 - Migrate Documents and Settings.

Bug #94878 reported by karsibali on 2007-03-22
8
Affects Status Importance Assigned to Milestone
migration-assistant (Ubuntu)
Undecided
Evan

Bug Description

The installation of the Ubuntu 7.04 froze at 6th step. The installation program starts to scan the file system to search for accounts to import documents and settings. But it cannot find anything and freeze. There are two other linux installations on two different partitions. There is also another partition with Windows XP. You cannot move forward. You can only cancel.

ProblemType: Bug
Date: Thu Mar 22 19:24:53 2007
DistroRelease: Ubuntu 7.04
Uname: Linux ubuntu 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux

Evan (ev) wrote :

This sounds like a bug that was fixed already, but can you please run the installer again using the --debug option and attach /var/log/syslog and /var/log/installer/debug to this bug report? Helpful instructions can be found here: https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

I'd prefer you use a daily image to test this, but if that's not possible, the one you have will suffice. The latest daily live CD can be found here:
http://cdimage.ubuntu.com/daily-live/current/

Thanks!

Changed in migration-assistant:
assignee: nobody → evand
status: Unconfirmed → Needs Info
Wizo (carlo-luzi) wrote :

I'm on a VAIO VGN-FS215M and I've the same problem.

I'm runnig the beta desktop live-cd of Ubuntu 7.04.

As asked, I've attached the log files.

Wizo (carlo-luzi) wrote :
Steve Dodd (anarchetic) wrote :

This looks like a dupe of bug #95422?

Evan (ev) wrote :

On second inspection, after reading your comment, this does indeed appear to be slightly different, though the two bugs could still end up being caused by the same problem.

Could you add `set -x` to the second line of /usr/lib/ubiquity/migration-assistant/ma-ask on the live CD, run the installer until it crashes, and attach /var/log/syslog? I'm having a hard time figuring out exactly why it's trying to mount /dev/sda6. If you cannot, I will try to proceed without that information.

Thanks!

Wizo (carlo-luzi) wrote :

For clarity, I briefly explain my partition scheme:
/dev/sda1 WinXP
/dev/sda3 Test Partition (Festy Fawn beta installer target)
/dev/sda5 Dapper boot
/dev/sda6 Dapper home
/dev/sda7 Dapper root
/dev/sda8 swap

I've attached syslog with 'set -x'.

Is there a way to disable the "Migrate Documents and Settings" feature for install festy and make further test?

Pedro M. V. Martins (pmvm-hqfl) wrote :

I tried to install Kubuntu 7.04 herd 5, but I had the same problem. The installer crashes when it tries to import Windows users.

I think the installer should ask if I want to import these data, as well ask if I want to import users in existing Linux partitions. So, if the installer crashes when trying to import something, I can try another installation without importing anything.

One import thing I must say: "My Documents" and "Favorites" folders aren't in usual places (inside "Documents and Settings"), so that may be the problem. If possible, the importing tool should read the registry to find where these folders are.

Evan (ev) wrote :

Wizo,
Yes, pass --no-migration-assistant to the installer (`ubiquity --no-migration-assistant`).

Pedro,
The bug you are describing was fixed after Herd 5. You should, if possible, try a more recent release, such as the Beta. The installer does give you the option to avoid importing the data, however, it does not give you the option to avoid detecting if there's data available to import, which is where the installer is currently crashing for this bug report.

I am aware that "My Documents" and "Favorites" are named differently in different localizations and migration-assistant accounts for this by reading the appropriate registry keys.

Changed in migration-assistant:
status: Needs Info → In Progress
Evan (ev) wrote :

From a cursory glance of Wizo's new syslog file (thanks, by the way), this bug appears to be caused by systems with separate /home partitions that are not using UUIDs for the device name in /etc/fstab and are using the old-style IDE device naming scheme (/dev/hda). So in the case of Ubuntu, this would be Dapper with manual partitioning.

If my assumption is correct, a fix will be forthcoming.

Wizo (carlo-luzi) wrote :

I can confirm that I did manual partitioning of my drive.

Thanks for the patience.

Colin Watson (cjwatson) wrote :

migration-assistant (0.4.3) feisty; urgency=low

  * Possible fix for ostype not getting set in the -ask and -apply
    scripts. Also added some temporary debugging information.
    (LP: #93197)
  * If the /home partition device doesn't exist under the same name in
    the running kernel, fail gracefully and continue to the next OS.
    (LP: #94878)
  * Added more logging and crash partial recovery.
  * Gracefully fail and continue on items where a non C: drive letter
    comes into play. (LP: #95422)
  * Don't import Windows default bookmarks. Import, but don't set
    "Bliss" as the default wallpaper.

 -- Evan Dandrea <email address hidden> Tue, 27 Mar 2007 03:44:25 -0400

Changed in migration-assistant:
status: In Progress → Fix Released

Evan, I tried the beta and it was ok. Thanks.

Tried the Beta x86 CD today and had the same problem. Again, Dapper with manual partitioning.

Evan (ev) wrote :

StanimirDjevelekov,

Can you either try a daily live CD build or run `sudo apt-get update; sudo apt-get install ubiquity`? This will ensure the bug you are seeing has not already been fixed. Then could you please run `ubiquity -d` in a console to put the installer in debug mode and then post the /var/log/installer/debug and /var/log/syslog files to a new bug report?

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers