Ubiquity quits when starting migration-assistant

Bug #930676 reported by Pjotr12345 on 2012-02-11
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
migration-assistant (Ubuntu)
High
Evan

Bug Description

When installing Ubuntu 12.04 Precise Pangolin (or 11.10 Oneiric Ocelot) with the Desktop CD, installation is aborted when starting migration-assistant.

This may have something to do with EFI, because the Ubuntu Desktop CD fails to show a normal boot screen as well (just a very basic option screen). The only way that I can succesfully complete an install, is by means of the Alternate CD.

I have attached a tarball with the following files:
- syslog
- hardware list
- screenshots

Pjotr12345 (computertip) wrote :
tags: added: ubiquity-2.9.16
Pjotr12345 (computertip) wrote :

See this related bug report about migration-assistant:
https://bugs.launchpad.net/ubuntu/+source/migration-assistant/+bug/930754

Colin Watson (cjwatson) wrote :
Download full text (3.3 KiB)

The boot part isn't an error; that's expected on EFI. I suspect it's unrelated.

In syslog, we have:

Feb 11 18:20:32 ubuntu ubiquity: /usr/lib/ubiquity/migration-assistant/ma-ask: 32: /usr/lib/ubiquity/migration-assistant/ma-ask: : Permission denied
Feb 11 18:20:32 ubiquity: last message repeated 2 times
Feb 11 18:20:32 ubuntu migration-assistant: info: setting ostype from: '/dev/sda1:Windows 7 (loader):Windows:chain'
Feb 11 18:20:32 ubuntu migration-assistant: info: got ostype of: 'windowsxp', mountpoint is: '/mnt/migrationassistant'
Feb 11 18:20:32 ubuntu ntfs-3g[13313]: Version 2011.10.9AR.1 external FUSE 28
Feb 11 18:20:32 ubuntu ntfs-3g[13313]: Mounted /dev/sda1 (Read-Write, label "", NTFS 3.1)
Feb 11 18:20:32 ubuntu ntfs-3g[13313]: Cmdline options: rw,umask=0022,nls=utf8
Feb 11 18:20:32 ubuntu ntfs-3g[13313]: Mount options: rw,nls=utf8,allow_other,nonempty,relatime,fsname=/dev/sda1,blkdev,blksize=4096,default_permissions
Feb 11 18:20:32 ubuntu ntfs-3g[13313]: Global ownership and permissions enforced, configuration type 7
Error: Could not find the path /mnt/migrationassistant/WINDOWS/system32/config/software
Error: Could not find the path /mnt/migrationassistant/WINNT/system32/config/software
Fatal: Could not find the SOFTWARE registry hive at /mnt/migrationassistant/WINNT/system32/config/software.
Feb 11 18:20:32 ubuntu ntfs-3g[13313]: Unmounting /dev/sda1 ()
Feb 11 18:20:33 ubuntu migration-assistant: info: setting ostype from: '/dev/sda4:unknown Linux distribution:Linux:linux'
Feb 11 18:20:33 ubuntu migration-assistant: info: got ostype of: 'linux', mountpoint is: '/mnt/migrationassistant'
Feb 11 18:20:33 ubuntu kernel: [ 121.584939] ufs was compiled with read-only support, can't be mounted as read-write
Feb 11 18:20:33 ubuntu ubiquity: mount: wrong fs type, bad option, bad superblock on /dev/sda4,
Feb 11 18:20:33 ubuntu ubiquity: missing codepage or helper program, or other error
Feb 11 18:20:33 ubuntu ubiquity: In some cases useful info is found in syslog - try
Feb 11 18:20:33 ubuntu ubiquity: dmesg | tail or so
Feb 11 18:20:33 ubuntu ubiquity:
Feb 11 18:20:33 ubuntu migration-assistant: error: Failed to mount /dev/sda4
Feb 11 18:20:33 ubuntu ubiquity[3587]: debconffilter_done: ubi-migrationassistant (current: ubi-migrationassistant)

And earlier in the log:

Feb 11 18:18:49 ubuntu kernel: [ 4.607400] sda4: <bsd:bad subpartition - ignored
Feb 11 18:18:49 ubuntu kernel: [ 4.607402] bad subpartition - ignored
Feb 11 18:18:49 ubuntu kernel: [ 4.607412] bad subpartition - ignored
Feb 11 18:18:49 ubuntu kernel: [ 4.607412] bad subpartition - ignored
Feb 11 18:18:49 ubuntu kernel: [ 4.607413] >

So the system is definitely badly confused about what sda4 is; but what I'm not sure from this log is which partitions you selected to import things from - Windows or Linux? If you could supply that information then that would be helpful.

Evan, one thing that definitely should be fixed is a syntax error on line 32 of ma-ask, which has been there since natty:

- if [ "$target" = "$location" ] || "$home" = "$location" ]; then
+ if [ "$target" = "$location" ] || [ "$home" = "$location" ]; then

I'm...

Read more...

affects: ubiquity (Ubuntu) → migration-assistant (Ubuntu)
Changed in migration-assistant (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Pjotr12345 (computertip) wrote :

I didn't select anything for migration yet; migration-assistant quits *before* offering me migration options....

But I think I may have found the cause for the failure: on my multi-boot laptop, sda4 is a FreeBSD partition (there's PC-BSD on it), with FreeBSD format. Apparently migration-assistant can't cope with that?

There is still one unexplained ubiquity bug left, though: the Desktop CD doesn't offer a normal boot screen. See the attached screenshot. This is quite unrelated to migration-assistant, of course.

Pjotr12345 (computertip) wrote :

The sda4 partition with PC-BSD on it, has a UFS file system. Linux can't cope with UFS, so that's probably the reason why migration-assistant stumbles and crashes (and takes Ubiquity down as well).

A fix would probably have to make migration-assistant simply *ignore and skip* file systems that it can't recognize, when it starts scanning the hard drive.

P.S. Please disregard my remark about the boot screen of the CD; I overlooked your answer to that particular issue.

Changed in migration-assistant (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package migration-assistant - 0.6.11

---------------
migration-assistant (0.6.11) precise; urgency=low

  * Fix a syntax error (LP: #930676). Thanks Colin Watson.
 -- Evan Dandrea <email address hidden> Wed, 21 Mar 2012 21:44:35 +0000

Changed in migration-assistant (Ubuntu):
status: Confirmed → Fix Released
summary: - Ubiquity quits when starting migration-assistent
+ Ubiquity quits when starting migration-assistant
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers