Needs gconf to gsettings updates

Bug #800760 reported by Sebastien Bacher on 2011-06-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
migration-assistant (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Stéphane Graber
Oneiric
Medium
Stéphane Graber
user-setup (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

GNOME is migrating from gconf to gsettings, in consequence unity needs to play catchup on some of those changes.
You can see http://developer.gnome.org/gio/stable/ch28.html for how to migrate code from gconf to gsettings

Related branches

Sebastien Bacher (seb128) wrote :

So looking at the current sources those are some notes

* bin/ubiquity-dm

you should lock down gsettings keys as well there

* d-i/source/migration-assistant/evolution-import.c doesn't need migrating, evolution 3.0 still use gconf, the gsettings migration might happen for 3.2 but it's not sure, I will update the bug if it becomes likely

* d-i/source/migration-assistant/windows-import.c

the current oneiric version is using gconf but git is using gsettings so that will likely need work before oneiric

* d-i/source/user-setup/user-setup-apply

libgksu is still using gconf by that might change before oneiric

* scripts/plugininstall.py:

not sure what the key used there do but you should check if there is an equivalent still

* ubiquity/components/apt_setup.py

the proxy values are in gsettings, org.gnome.system.proxy.http nowadays

* ubiquity/frontend/gtk_ui.py

the indicator-session keys will migrate to gsettings in oneiric

nautilus migrated to gsettings and the automount feature move to gnome-settings-daemon, you want to tweak the gsettings in
org.gnome.nautilus.desktop and org.gnome.settings-daemon.plugins.automount

you should lock down gsettings keys as well there

* ubiquity/misc.py
the keyboard layouts are in desktop.gnome.periphericals.keyboard.kbd layouts

Changed in ubiquity (Ubuntu Oneiric):
importance: Undecided → High
Evan (ev) on 2011-06-22
Changed in ubiquity (Ubuntu Oneiric):
assignee: nobody → Evan Dandrea (ev)
importance: High → Medium
milestone: none → oneiric-alpha-3
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

not sure how the migration assistant work but if you do gconf database dumps you might want to copy the gsettings config dir as well, I will check with upstream what is the recommended way to do that but it might as easy as simply copying .config/dconf/user, the file is a mmap though and I'm not sure if it's arch independant

tags: added: gnome3-gsettings
Changed in ubiquity (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Martin Pitt (pitti) on 2011-08-31
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Dave Walker (davewalker) on 2011-09-23
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Changed in ubiquity (Ubuntu Oneiric):
assignee: Evan Dandrea (ev) → Stéphane Graber (stgraber)
Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.8.2

---------------
ubiquity (2.8.2) oneiric; urgency=low

  [ Colin Watson ]
  * Preserve ordering of disks returned by partman-auto rather than
    shuffling them based on dictionary ordering (LP: #770711). This uses
    collections.OrderedDict, which requires Python >= 2.7.
  * Run only those parts of oem-config-prepare that require root access as
    root; in particular displaying confirmation dialogs is now done as the
    calling user, which avoids KDE confusion (LP: #856418).
  * Go back to killing update-apt-cache's process group, but this time make
    sure that it's in a separate process group and make more of an effort to
    ensure that it terminates (LP: #743359).
  * Update translations from Launchpad.

  [ Stéphane Graber ]
  * Make ubiquity also update gsettings (LP: #800760)
    - Add a new gsettings module similar to the gconftool one
    - Update ubiquity-dm for gconf to gsettings migration
    - Get PROXY configuration from gsettings
    - Update gtk_ui to set/restore gsettings values
  * Update copy_network_config to work with Network Manager now storing
    everything system wide.
 -- Stephane Graber <email address hidden> Mon, 03 Oct 2011 17:31:46 -0400

Changed in ubiquity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in migration-assistant (Ubuntu Oneiric):
status: New → Confirmed
Changed in migration-assistant (Ubuntu):
status: New → Confirmed
Changed in user-setup (Ubuntu Oneiric):
status: New → Confirmed
Changed in user-setup (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in user-setup (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in migration-assistant (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers