[Hardy] Please synch midisport-firmware with Debian

Bug #213498 reported by Conrad Knauer
2
Affects Status Importance Assigned to Milestone
midisport-firmware (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: midisport-firmware

As per https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-April/003806.html (via my inbox)

---
Date: Mon, 7 Apr 2008 08:22:48 -0400
From: Forest Bond <forest (st) alittletooquiet (dot) net>
To: <email address hidden>
Subject: midisport-firmware; please replace Ubuntu package with package from Debian

Hi,

I am not sure who this request should go to.

I am the maintainer of the Ubuntu package midisport-firmware. This package has
never worked correctly OOTB, due to changes in udev/usbfs. This will again be
the case in Hardy.

I am no longer in possession of my midisport device, which has made testing
difficult for me. Further, I'm quite busy with other things, and have neglected
to keep this package up-to-date with the udev/usbfs changes that seem to occur
once every 3-6 months, and without obvious notification for a package maintainer
like myself.

Debian now has a midisport-firmware package that should be used instead. The
potential for regression is zero, since this was already broken in Gutsy.

Please drop the Ubuntu package and sync from Debian. It would be really great
if this could be done for Hardy. I would hate to see yet another Ubuntu release
with broken support for these devices.

Thanks,
Forest
---

Revision history for this message
Scott Kitterman (kitterman) wrote :

We can't actually sync to to different tarballs, but the changes from Debian have been merged into Ubuntu now.

midisport-firmware (1.2+dsfg1-0ubuntu4) hardy; urgency=low

  * Merge w/ debian:
    - Drop debian/po/ directory. Firmware now included.
    - Drop debian/README.Debian
    - Drop debian/{config,postinst,preinst,postrm, templates}
    - Update debian/control
    - Update debian/dirs
    - Drop debian/install
    - Add debian/menu
    - Update udev rules. (LP: #193891)
    - Fix watch file
    - Update debian/rules
    - Update Makefile.in to put firmware outside /lib.

  * In the even there is a new version this package can
    be synced. It hasn't been synced now because our version
    number (1.2+dsfg1) is greater than upstream's (1.2). Adding
    an epoch now would make this a worse situation.

 -- Mario Limonciello < <email address hidden>> Mon, 07 Apr 2008 09:22:06 -0500

Changed in midisport-firmware:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers