no firmware upload because of broken udev-rule

Bug #193891 reported by Mat Lehmann
14
Affects Status Importance Assigned to Milestone
midisport-firmware (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: midisport-firmware

I am using Ubuntu 7.10 and midisport-firmware version 1.2+dsfg1-0ubuntu1 together with a Midisport 2x2.

When I plugged in the Midisport, nothing happened - no firmware was loaded unto the device.

After I investigated this, I found that though the udev-rule in /etc/udev/rules.d/85-midisport-firmware.rules match, the upload script is not successful. This is, because the udev-event contains a wrong (?) device-path (/proc/bus/usb/... when in fact it should be /dev/bus/usb/...). My workaround is, to append "-D %N" to the RUN-command, so my rule reads as follows:

 ACTION=="add", SUBSYSTEM=="usb_device", ATTRS{idVendor}=="0763", ATTRS{idProduct}=="1001", RUN+="/sbin/fxload -s /lib/firmware/maudio/MidiSportLoader.ihx -I /lib/firmware/maudio/MidiSport2x2.ihx -D %N"

According to the udev man-page, the placeholder %N stands for a temporary device-node, which allows access to the device before it is finally linked in /dev.

This works for me.

Revision history for this message
Andy Owen (the-new-andy) wrote :

I can confirm that this bug exists, and "-D %N" fixes it.

Revision history for this message
Andy Owen (the-new-andy) wrote :

But this is also quite similar to the stuff being discussed in:

https://bugs.launchpad.net/baltix/+bug/27833

(like this comment: https://bugs.launchpad.net/baltix/+bug/27833/comments/10 )

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package midisport-firmware - 1.2+dsfg1-0ubuntu4

---------------
midisport-firmware (1.2+dsfg1-0ubuntu4) hardy; urgency=low

  * Merge w/ debian:
    - Drop debian/po/ directory. Firmware now included.
    - Drop debian/README.Debian
    - Drop debian/{config,postinst,preinst,postrm, templates}
    - Update debian/control
    - Update debian/dirs
    - Drop debian/install
    - Add debian/menu
    - Update udev rules. (LP: #193891)
    - Fix watch file
    - Update debian/rules
    - Update Makefile.in to put firmware outside /lib.

  * In the even there is a new version this package can
    be synced. It hasn't been synced now because our version
    number (1.2+dsfg1) is greater than upstream's (1.2). Adding
    an epoch now would make this a worse situation.

 -- Mario Limonciello <email address hidden> Mon, 07 Apr 2008 09:22:06 -0500

Changed in midisport-firmware:
status: New → Fix Released
Revision history for this message
FreqRush (peter-geirnaert) wrote :

I had to do this to get mine working again:

sudo gedit /etc/udev/rules.d/42-midisport-firmware.rules

then change this line:
# MidiSport 2x2
ACTION=="add", SUBSYSTEM=="usb", DEVPATH=="/*.0", ENV{PRODUCT}=="763/1001/*", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSport2x2.ihx"

into

# MidiSport 2x2
ACTION=="add", SUBSYSTEM=="usb", DEVPATH=="/*.*", ENV{PRODUCT}=="763/1001/*", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSport2x2.ihx -D %N"

so I had to change the DEVPATH=="/*.0" to "/*.*" and also add the -D %N part.
now it works.

Hope it helps ..

Revision history for this message
FreqRush (peter-geirnaert) wrote :

btw, I'm using UbuntuStudio 8.04 atm.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers