mhwaveedit: can't handle files with spaces

Bug #187552 reported by Peter Cordes on 2008-01-31
8
Affects Status Importance Assigned to Milestone
mhwaveedit (Ubuntu)
Low
Murat Gunes

Bug Description

Binary package hint: mhwaveedit

/usr/bin/mhwaveedit uses an unquoted $@, so the shell word-splits the args.
The correct way to pass on args in a wrapper script is "$@", not just $@.

Peter Cordes (peter-cordes) wrote :

also, the wrapper should use exec. i.e.
exec /usr/lib/mhwaveedit/mhwaveedit.real "$@"

Murat Gunes (mgunes) wrote :

Thanks for your report; confirming.

Changed in mhwaveedit:
status: New → Confirmed
Murat Gunes (mgunes) wrote :

Taking this one.

Changed in mhwaveedit:
assignee: nobody → mgunes
status: Confirmed → In Progress
Murat Gunes (mgunes) wrote :

debdiff attached. This is my first; please be gentle.

Changed in mhwaveedit:
assignee: mgunes → nobody
status: In Progress → Confirmed
Murat Gunes (mgunes) wrote :

The above debdiff is invalid; please ignore. Will re-upload.

Changed in mhwaveedit:
assignee: nobody → mgunes
status: Confirmed → In Progress
Murat Gunes (mgunes) wrote :

This one should do it.

Changed in mhwaveedit:
assignee: mgunes → nobody
status: In Progress → Confirmed
Murat Gunes (mgunes) wrote :

Updated debdiff attached; only addition is (LP: #187552) in changelog entry.

Changed in mhwaveedit:
assignee: nobody → rainct
importance: Undecided → Low
Siegfried Gevatter (rainct) wrote :

Your debdiff is okay, good work :), but on a fast look it seems that this package is in a pretty bad state. For instance, it has no manpage (althought all commands should have one), the .desktop file is incomplete and it has some other issues.

It would be great if you could address some of those issues.

Murat Gunes (mgunes) wrote :

Sure, I'm putting those on my to do list. Thanks for the review and heads up.

Siegfried Gevatter (rainct) wrote :

Cool, please subscribe u-u-s again once a new debdiff with some more of this stuff is ready :).

Changed in mhwaveedit:
assignee: rainct → mgunes
Murat Gunes (mgunes) wrote :

Is this because this fix is not significant enough for an update? BTW; u-u-s is still subscribed.

Siegfried Gevatter (rainct) wrote :

No, if mhwaveedit had just the issue described in this bug and no other problems I'd upload it, but as it has more problems, it's always good to get as much fixes as possible with each upload.

Magnus Hjorth (magnus-hjorth) wrote :

The shell script in the Debian/Ubuntu package is unnecessary since mhWaveEdit 1.4.14, because now a default value for LADSPA_PATH is compiled in.

If you add significant things to the package such as man pages, please consider sending them for inclusion upstream.

Best regards, /Magnus

Alessio Treglia (quadrispro) wrote :

This will be fixed in the next Debian release 1.4.18-2

Changed in mhwaveedit (Ubuntu):
status: Confirmed → Triaged
Alessio Treglia (quadrispro) wrote :

 mhwaveedit (1.4.19-1) unstable; urgency=low

   * New upstream release:
     - Fixed bug causing cursor to freeze near end-of-file
     - Fixes for appearance in dark themes
     - Build system fixes
   * Drop the wrapper, it seems unnecessary since 1.4.14 (LP: #187552).
   * Remove /usr/lib/mhwaveedit path since the wrapper was the only file
     under that.
   * Add .gitignore file.
   * Try to fix FTBFS on kfreebsd architectures.
   * Bump Standards.
   * Update debian/copyright file.

 -- Alessio Treglia <email address hidden> Fri, 09 Jul 2010 12:26:41 +0200

Changed in mhwaveedit (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers