Sync mga-vid 2.6.32-1(universe) from debian unstable(main)

Bug #596190 reported by Bhavani Shankar on 2010-06-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mga-vid (Ubuntu)
Wishlist
Unassigned

Bug Description

Debian changes:

 mga-vid (2.6.32-1) unstable; urgency=low

   * New upstream snapshot, tested with kernel 2.6.32
     - Closes: #520758
     - Works with newer kernels. Closes: #548402
     - Works wit newer mplayer. Closes: #532523
   * Remove name="%k" from udev rules. fixes: #555486
   * Version the gpl in copyright file. gplv2.
   * Add misc:Depends to source package
   * Bump standards.
   * Use debian address. finally ;)

 -- Sune Vuorela <email address hidden> Tue, 18 May 2010 15:27:11 +0200

Related branches

Bhavani Shankar (bhavi) wrote :
Changed in mga-vid (Ubuntu):
status: New → Confirmed
Fabrice Coutadeur (fabricesp) wrote :

Hi,

I don't think that these changes are required anymore, as the migration path goes through Lucid, and udev and debhelper are already at upper version there, so I think we can safely sync the package.
what do you think?

Thanks,
Fabrice

Changed in mga-vid (Ubuntu):
status: Confirmed → Incomplete
Bhavani Shankar (bhavi) wrote :

okay fabrice

I ll test the debian source and get back soon :)

Regards

Bhavani Shankar (bhavi) wrote :

oops I ve my own doubts fabrice

there is a version mismatch between debian and ubuntu udev (< 141-1) and in order to get the ubuntu one(since its a versioned dep) we bump debhelper build depend so it cant be synced I think

Your thoughts?

Regards

Changed in mga-vid (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Bhavani Shankar (bhavi) wrote :

Bump fabrice!

Regards

Fabrice Coutadeur (fabricesp) wrote :

Hi,

I think that this breaks has been added in jaunty, because during jaunty development cycle, udev changed from version 124 to 136 and the break was added to force upgrade of udev during intrepid -> jaunty upgrade or jaunty -> jaunty one.

And about, debhelper, it seems that version prior to 7.0.17ubuntu2 didn't installs udev rules in /lib/udev/rules.d:
debhelper (7.0.17ubuntu2) jaunty; urgency=low

  * dh_installudev: Default priority is now 40 by default, and the target
    directory is now /lib/udev/rules.d. Remove files from /etc/udev/rules.d
    unless they are user modified; if modified and of default priority,
    take care to rename.

In lucid, udev is version 151 and debhelper is 7.4.15, so I really think that the diff can be dropped.

Fabrice

Bhavani Shankar (bhavi) wrote :

okay fabrice thanks!

Retitling

Regards

Changed in mga-vid (Ubuntu):
status: In Progress → New
assignee: Bhavani Shankar (bhavi) → nobody
summary: - Please merge mga-vid 2.6.32-1(universe) from debian unstable(main)
+ Please sync mga-vid 2.6.32-1(universe) from debian unstable(main)
Stefano Rivera (stefanor) wrote :

Sync request ACK'd

tags: added: sync
Changed in mga-vid (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
status: New → In Progress
summary: - Please sync mga-vid 2.6.32-1(universe) from debian unstable(main)
+ Sync mga-vid 2.6.32-1(universe) from debian unstable(main)
Changed in mga-vid (Ubuntu):
assignee: Stefano Rivera (stefanor) → nobody
importance: Undecided → Wishlist
status: In Progress → Confirmed
Changed in mga-vid (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mga-vid - 2.6.32-1

---------------
mga-vid (2.6.32-1) unstable; urgency=low

  * New upstream snapshot, tested with kernel 2.6.32
    - Closes: #520758
    - Works with newer kernels. Closes: #548402
    - Works wit newer mplayer. Closes: #532523
  * Remove name="%k" from udev rules. fixes: #555486
  * Version the gpl in copyright file. gplv2.
  * Add misc:Depends to source package
  * Bump standards.
  * Use debian address. finally ;)
 -- Bhavani Shankar <email address hidden> Tue, 18 May 2010 15:27:11 +0200

Changed in mga-vid (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers