Finish the implementation of the locally integrated menubars

Bug #931245 reported by Sam Spilsbury on 2012-02-13
114
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
Ubuntu theme
Undecided
Sam Spilsbury
Unity
Fix Released
High
Marco Trevisan (Treviño)
metacity (Ubuntu)
Undecided
Unassigned
ubuntu-mono (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

Related branches

Changed in compiz-core:
status: New → In Progress
Changed in light-themes:
status: New → In Progress
Changed in unity:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in metacity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in light-themes:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.2
Changed in unity:
milestone: none → 5.4.0
Tim Penhey (thumper) on 2012-02-13
Changed in unity:
milestone: 5.4.0 → 5.6.0
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in metacity (Ubuntu):
status: New → Confirmed
affects: metacity → metacity (Ubuntu)
Changed in metacity (Ubuntu):
status: New → In Progress
Eduard Gotwig (gotwig) wrote :

I dont like that.

Omer Akram (om26er) wrote :

>> I dont like that.

Its optional, well have you seen it in action btw?

Eduard Gotwig (gotwig) wrote :

I saw that image on omgubuntu.. I dont like the idea.

Eduard Gotwig (gotwig) wrote :

How you know, its going to be optional, and who would use it, btw?

Omer Akram (om26er) wrote :

>> How you know, its going to be optional

"I know things" ;-)

>> and who would use it, btw?

people who don't like global menus? people with really big screens who find it hard to go all the way to the top

Eduard Gotwig (gotwig) wrote :

I realy hope it's going to be optional.

We will see :-) .

And please, dont remove other functionality like that ( see the story about the "hide" functionality for the unity launcher)

Tom rooze.sen (tomrooze-sen) wrote :

Unity , Gnome shell 3 > I dont like that.
I like cinnamon of Xfce.

Ingo Gerth (igerth) wrote :

Please remember this is not a forum, so this is not the place to share your opinion. Stay on topic.

Changed in compiz-core:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Paul Sladen (sladen) wrote :

This will likely need a suitable pair of indicator icon(s) adding to "ubuntu-mono-{dark,light}".

Attaching the ubuntu-mono-dark asset, it should go into:
 - /usr/share/icons/ubuntu-mono-dark/22x22/status/indicator-appmenu-menu-panel.png

We need designers to do also the version for the ubuntu-mono-light theme.

Attaching the ubuntu-mono-dark asset, it should go into:
 - /usr/share/icons/ubuntu-mono-dark/22x22/status/indicator-appmenu-menu-panel.png

We need designers to do also the version for the ubuntu-mono-light theme.

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

Redrawn as aligned SVG on the same 22-pixel grid so that it has a hope of being maintainable.

Paul Sladen (sladen) wrote :

Committed; I would prefer to be able to test it first, but I haven't been able to get LIM working from the PPA yet (ppa:unity-team/lim/ubuntu).

Paul Sladen (sladen) wrote :

 The key to testing (pardon the pun) is:

  gsettings set com.canonical.indicator.appmenu menu-mode locally-integrated

the assets work in both themes per-se, though the code probably needs a bit more work to cope with some of the edge cases.

Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3036

Changed in compiz-core:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Changed in compiz-core:
status: Fix Committed → Fix Released
Danillo (danillo) wrote :

Hey, I've been testing LIM with the Unity Team ppa, and I'm sorry, I know it's too early to tell how LIM is going to evolve, but I got a suggestion.

In the design list John Lea said that, in order to avoid creating problems with moving windows by dragging their titles, LIM would only show when the left mouse button is released, but that solution makes LIM's behavior inconsistent with the behavior of the rest of panel items and of the global menu. In addition, some people were complaining that LIM could take an extra click (which is a false impression, but anyway...). And I was also wondering if the only change to the decorations will be the addition of the menu icon to the left of the window title, which sounds too subtle, it could be not very clear to newbies.

I created a mockup suggesting an app button. It's in attached. With an app button we could access a menu item with a single left click - holding the left mouse button, moving it to the menu item we want and releasing the button. This would make LIM's behavior more consistent with the rest of Unity itens, allow accessing menu itens with a single click, increase discoverability, and zero out any chance of interfering with the movement of windows.

manny (estelar57) wrote :

@Danillo

your mockup is very similar to the oxygen-appmenu (which was the inspiration for LIM)

http://www.webupd8.org/2011/11/oxygen-appmenu-replace-menu-with.html

It needs to be clear that the "area is clickable" just like in the kde counterpart (or like firefox or opera do it.).

Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Danillo (danillo) wrote :

Yeah, I think that's the best approach. And it doesn't necessarily need to look like a button, it could look like an indicator. This way we would have even more consistency with the panel. All it would need is to separate the application name from the window title.

Here goes the same mockup but with LIM as an indicator instead of a button.

Pedro Bessa (pedbessa) wrote :

my solution -> ellipse.png is attached
best solution -> https://launchpadlibrarian.net/97878037/LIM%20button.png

Tell Marco Trevisan: "If the LIM button at https://launchpadlibrarian.net/97878037/LIM%20button.png appears in Precise Pangolin, you can safely say it's a main feature like Ubuntu HUD, because you saw the global menu bug report heat. Your patch was near the LIM button, so you have 80% of the code for the LIM button already done. We weren't expecting you to have that, so we said that the LIM button won't be in 12.04. Keep the global menu bug report heat in mind. Keep the end of april which is the precise pangolin release date in mind. Please, implement the LIM button ASAP!"

Changed in unity:
milestone: 5.10.0 → none
Daniel van Vugt (vanvugt) wrote :

Code removed in lp:compiz-core at revision 3077

Changed in compiz-core:
status: Fix Released → Triaged
milestone: 0.9.7.2 → none
Pedro Bessa (pedbessa) wrote :

updated!

ellipse*s* make click area*s* bigger

the shiny new highlight shows why the click area is bigger

Pedro Bessa (pedbessa) wrote :

ellipses make click areas bigger
now with ellipse highlight
now with mouse pointer
the highlight is on hover

Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → High
status: New → Triaged
Omer Akram (om26er) on 2012-07-09
no longer affects: compiz-core
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.41

---------------
ubuntu-mono (0.0.41) quantal; urgency=low

  [ Paul Sladen ]
  * indicator-appmenu-menu-panel: add for LIM
    (Locally Integrated Menu) support (LP: #931245)
  * FTBFS: comment out the background-rebuilding for the moment

  [ Michael Terry ]
  * debian/control: Switch to imagemagick5 instead of 4
 -- Michael Terry <email address hidden> Tue, 17 Jul 2012 11:37:52 -0400

Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2012-08-03
Changed in unity:
status: In Progress → Confirmed
Esokrates (esokrarkose) wrote :

Are there any plans to make this ready for 13.04 raring?
What is missing? I see lots of code requests pending, what is wrong with them?

James Lewis (james-fsck) wrote :

Really hoping to have this in soon. Global menu is a good idea on a 1366x768 laptop, or when fullscreen... but on a 30" screen I have to cross 2 other applications to reach the menu for the application I'm using!

Changed in metacity (Ubuntu):
status: In Progress → Won't Fix
assignee: Sam Spilsbury (smspillaz) → nobody
affects: light-themes → ubuntu-themes
Adolfo Jayme (fitojb) on 2014-02-16
Changed in ubuntu-themes:
status: In Progress → Confirmed
Changed in compiz:
status: Triaged → Won't Fix
Changed in ubuntu-themes:
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Committed
milestone: none → 7.2.0
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers