Windows have grey traces in Ubiquity

Bug #924909 reported by Francesco Ruvolo on 2012-02-01
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Medium
Unassigned
openbox (Ubuntu)
Undecided
Unassigned
xfwm4 (Ubuntu)
Medium
Unassigned

Bug Description

I'm testing Xubuntu amd64 Precise alpha2 in live mode.
When I get the screen to choose if I want to try it without any change or to install it, the background is black. Moving the window, it became grey "following the window".
Sorry for this very bad report, I hope it's understandable.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: casper 1.302
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CasperVersion: 1.302
Date: Wed Feb 1 14:47:54 2012
LiveMediaBuild: Xubuntu 12.04 "Precise Pangolin" - Alpha amd64 (20120201)
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.casper.conf: 2012-02-01T15:42:30

Francesco Ruvolo (ruvolof) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/924909

Charlie Kravetz (charlie-tca) wrote :

Please clarify this report. The background when the cd stops is black is not a bug. That is the color used in the Xubuntu installer for the background. Since we want to differentiate between Ubuntu and Xubuntu installs, making the background black was the simplest color to use.

Changed in casper (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

I confirm this with Xubuntu Desktop i386 and amd64.

On the screen 'Try or Install Ubuntu' if the user moves the window, the background doesn't repaint and the window leaves a trail.

Changed in casper (Ubuntu):
importance: Low → Medium
status: Incomplete → Confirmed
affects: casper (Ubuntu) → ubiquity (Ubuntu)
Francesco Ruvolo (ruvolof) wrote :

I made a video to show what actually happens:

http://youtu.be/WBxql1EwbPw

The video is two minutes long, but actually only the last 30 seconds are relevant.

Jean-Baptiste Lallement (jibel) wrote :

same problem with the slideshow during a wubi installation

summary: - black screen in background while choosing to try or install
+ try ubuntu mode moving window leaves tracers

Still present on beta 1.
Now, at least, we have xubuntu wallpaper as background instead of a black screen.

Pasi Lallinaho (knome) wrote :
summary: - try ubuntu mode moving window leaves tracers
+ Windows have grey traces in Ubiquity
Sergio Zanchetta (primes2h) wrote :

Confirmed using Beta 2 build 20120323

Colin Watson (cjwatson) wrote :

Isn't this a window manager bug rather than a ubiquity bug? (Or, I suppose, a bug in how ubiquity-dm is starting the window manager ...)

Francesco Ruvolo (ruvolof) wrote :

It works just fineafter ubiquity screen. So, I don't think it's a windows manager bug.

Sergio Zanchetta (primes2h) wrote :

I get a similar behaviour testing Ubuntu i386 using live usb. The issue doesn't appear on ubiquity window but under a notification one during desktop loading.

1) In Ubiquity, select the language and click on Try Ubuntu.
2) During desktop loading there is just the background on the screen.
3) Then a notification window appears and it shows the issue. (see screenshot)

Do you think it could be the same bug or it's better I open another bug report?

Lars Noodén (larsnooden) wrote :

This attachment shows what the artifacts look like on the screen. They are still present in the 20 Apr ISO images.

Simon Steinbeiß (ochosi) wrote :

I have to agree with cjwatson on this one, this looks like a classical window-manager compositing problem to me. Although I would emphasize what you wrote in brackets, it's most likely a problem of how ubiquity-dm starts the window-manager...

Maybe we can work around this by starting xfwm4 without compositing for ubiquity-dm?

Pasi Lallinaho (knome) wrote :

Agreed on Colin and Simon on this one. I can also confirm that this happens only in the Ubiquity installer if I don't "try Xubuntu" first, so looks even more like a startup problem.

tags: added: quantal
Brian Murray (brian-murray) wrote :

There should probably be a task for whatever window manager lubuntu uses or provides this:

            elif osextras.find_on_path('openbox-lubuntu'):
                wm_cmd = ['openbox-lubuntu']

I'd guess openbox but I'm not 100% certain.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
affects: ubiquity (Ubuntu) → metacity (Ubuntu)
Francesco Ruvolo (ruvolof) wrote :

Still there in Quantal Alpha 2.

Simon Steinbeiß (ochosi) wrote :

I just tested a patch that is now in a branch, switching off the compositor of Xfwm4 in ubiquity-dm.
(See attached screenshot from a live-session of Xubuntu Quantal in VirtualBox.)

Julien Lavergne (gilir) wrote :

Adding openbox for Lubuntu. But I can't reproduce it on a VM, and the solution Simon mentioned can't be apply to openbox since there is no compositor enable for it.

Francesco Ruvolo (ruvolof) wrote :

Fixed for me on Xubuntu Quantal Final.

Changed in openbox (Ubuntu):
status: New → Fix Released

According to comment #20, the problem has been fixed in Xubuntu 12.10. Therefore, it should be fixed in newer releases of Xubuntu too. Can anyone confirm this?

Changed in xfwm4 (Ubuntu):
status: Confirmed → Incomplete
Changed in xfwm4 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers