Ubuntu

metacity crashed with SIGABRT in raise()

Reported by C de-Avillez on 2011-06-14
This bug affects 333 people
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
High
Chris Coulson
Oneiric
High
Chris Coulson

Bug Description

Binary package hint: metacity

Always happen on logging in.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: metacity 1:2.34.0-0ubuntu1 [modified: usr/share/doc/metacity/changelog.Debian.gz]
ProcVersionSignature: Ubuntu 3.0-0.1-generic 3.0.0-rc2
Uname: Linux 3.0-0-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
Date: Tue Jun 14 02:52:59 2011
ExecutablePath: /usr/bin/metacity
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228)
ProcCmdline: metacity
ProcCwd: /var/lib/gdm
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/false
 PATH=(custom, no user)
Signal: 6
SourcePackage: metacity
StacktraceTop:
 raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 abort () at abort.c:92
 ?? ()
 ?? ()
 _XError (dpy=0x1bc6850, rep=<value optimized out>) at ../../src/XlibInt.c:1583
Title: metacity crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to oneiric on 2011-05-31 (13 days ago)
UserGroups:

C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :
tags: removed: need-amd64-retrace
visibility: private → public
Jean-Baptiste Lallement (jibel) wrote :

Reproduced. Setting to triaged/high and targeting to Oneiric

Changed in metacity (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in metacity (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

I tried this on the current daily in kvm. What I see is that the first time I start a session, it crashes almost immediately, and dmesg and apport report a segfault of lightdm (which tears down the user session as well). But when I restart lightdm, and log in again (ubuntu 2d), it works. Is that what you are seeing, or do you have different symptoms?

I also tried "metacity --replace" locally, and it doesn't crash. Jean-Baptiste, how did you reproduce this?

Thanks!

C de-Avillez (hggdh2) wrote :

@Martin: you are correct -- it happens on _first_ login; but I do not see LightDM segfaulting (I do see other LightDM sigsegv's, but they happened minutes to hours after logging in). In my case (both LightDM and GDM) the login completes successfully.

I did not try 'metacity --replace': I am running compiz...

I just marked bug 792999 a duplicate of this bug, after comparing https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/792999/comments/5 there to https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/797078/+attachment/2168109/+files/metacity.gdb here.

"Apport retracing service" had previously marked bug 792999 as a duplicate of private bug 793981. So private bug 793981 is probably the same as this bug, too. Maybe someone here with access to private bug 793981 could check (and if appropriate, mark it as such).

tags: added: desktop-priority
Daniel Sandman (almehdi) wrote :

I am using Gnome-shell and GDM. This also happening to me but and i am not using LightDM. I get errors when logging in to Gnome-classic but it doesn't crash. Also as long as i do not touch the activities button gnome-shell works.

tags: added: bugpattern-needed
Moussouni Mehdi (mmoussouni47) wrote :

for me, only append when I launch gns3 and when I try to re-launch metacity, I obtain this:

mmoussouni@VAL1-ubuntu:~$ metacity
Avertissement du gestionnaire de fenêtres : La fenêtre 0x3e00005 (GNS3) positionne un indice MWM indiquant qu'elle n'est pas redimensionnable, mais positionne une taille minimale de 16383 x 16383 et une taille maximale de 2147483647 x 2147483647 ; ceci n'a pas beaucoup de sens.
Avertissement du gestionnaire de fenêtres : La fenêtre 0x3e00005 (GNS3) positionne un indice MWM indiquant qu'elle n'est pas redimensionnable, mais positionne une taille minimale de 16383 x 16383 et une taille maximale de 2147483647 x 2147483647 ; ceci n'a pas beaucoup de sens.
Anomalie dans le gestionnaire de fenêtres : Unexpected X error: BadAlloc (insufficient resources for operation) serial 3165 error_code 11 request_code 53 minor_code 0)
Abandon (core dumped)

tags: removed: bugpattern-needed
Rrrrube (rrrrube) wrote :

I experienced this when launching XChat tonight though I'm not sure if that was just coincidence. I'm running Oneiric with all the updates available from this morning.

Kenny Strawn (kenny-strawn) wrote :

This bug happens to be similar to Bug 823386 in Compiz (both crashed using the same signal in the same function, though the Compiz issue happens to be caused by trying to attempt the workaround to Bug 685552...)

Kenny Strawn (kenny-strawn) wrote :

Also confirmed crash when running GNOME Shell (It seems as though Metacity is trying to start with Mutter running...)

Dmitry Shachnev (mitya57) wrote :

For me, metacity crashed when starting this PyQt script (which draws a window with a toolbar and a textedit).

tags: added: rls-mgr-o-tracking
Dmitry Shachnev (mitya57) wrote :

Simplified test case.

Luiz Santos (luiz-santos) wrote :

The same happened to me twice.

I had a crash in metacity but when the crash report was generated it
found a crash in akonadi. What's with this??

On 09/11/2011 10:14 AM, Luiz Santos wrote:
> The same happened to me twice.
>

The same happened to me every time I start using my pc after a shutdown.

Jason (themacster) wrote :

Had a compiz crash in 3D unity so tried in 2D. When I launch Calibre or FBReader, Metacity crashes just as Compiz does in 3D

Dmitry Shachnev (mitya57) wrote :

@Jason: for crashes with Qt4 apps, see also bug 805303.

Changed in metacity (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

I ran this with --sync and also ran it through xtrace, which shows we are trying to delete a property on an already destroyed window, and this was introduced with the fix for bug 696864.

Uploading a fix in a few moments...

Changed in metacity (Ubuntu Oneiric):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.34.1-1ubuntu4

---------------
metacity (1:2.34.1-1ubuntu4) oneiric; urgency=low

  * Fix LP: #797078 - metacity crashed with SIGABRT due to unhandled X error.
    Update previous patch to trap errors when accessing properties whilst
    handling an UnmapNotify event, just in case the window has already
    been destroyed
    - update debian/patches/16-capture-before-unmap.patch
 -- Chris Coulson <email address hidden> Fri, 16 Sep 2011 21:21:58 +0100

Changed in metacity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Dmitry Shachnev (mitya57) wrote :

I previously reported bug 844849, which was marked as a duplicate of this one.

Now there are at least 4 identical bugs: bug 846621, private bug 848808, bug 849781, bug 855603. Maybe it's a separate issue or this one was not fixed properly?

Just updated, but it still affects my computer. Maybe the fix is not in standard repositories (I use spanish one)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers