metacity assert failure: metacity:ERROR:core/prefs.c:2482:meta_prefs_get_workspace_name: assertion failed: (workspace_names[i] != NULL)

Bug #583847 reported by jalitr on 2010-05-21
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Metacity
Fix Released
Critical
metacity (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: metacity

When upgrading to metacity-1.2.30.1-0ubuntu1, the new package installs without error but metacity does not run when you start X because it cannot find workspace names using gconf. To trigger this bug, create more than 16 workspaces before upgrading. The problem is that the metacity schema in /usr/share/gconf/schemas/metacity.schemas only has slots for 16 workspace names, but metacity lets you have up to 36 workspaces. The workaround is to manually edit the metacity.schemas file and add slots 17 - 36 under the key for /schemas/apps/metacity/workspace_names/name then run "gconf-schemas --register-all".

Related branches

Matej Svetlík (matej-svetlik) wrote :

this also happens in clean install ...
1) add workspace switcher
2) add e.g. 20 workspaces - everything works like expected
3) restart
4) no metacity after login (no error message or something; just windows without borders)
5) "metacity --replace" gives same error as above

tags: added: metacity
Changed in metacity:
status: Unknown → New
Changed in metacity:
status: New → In Progress
Changed in metacity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in metacity:
importance: Unknown → Critical
Changed in metacity:
status: In Progress → Fix Released
JanBrinkmann (jbrinkmann) wrote :

This one is still true for 10.10 amd64 . I just borked my workstation by adding "too much" workspaces (20).

JanBrinkmann (jbrinkmann) wrote :

Hi. Since this quite annoying bug was fixed upstream I decided to apply the patch to the package. Is it possible to get this into Natty? It's a quite annoying bug which can be triggered quite easily. Once broken it's probably not that easy for inexperienced users to fix their systems.

Chris Coulson (chrisccoulson) wrote :

Thanks, will sponsor this!

Changed in metacity (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in metacity (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.30.3-0ubuntu6

---------------
metacity (1:2.30.3-0ubuntu6) natty; urgency=low

  * debian/patches/19_initialise_all_workspace_names.patch
    Added patch from upstream. (Closes LP: #583847)
 -- Jan Brinkmann <email address hidden> Sun, 06 Mar 2011 12:54:45 +0000

Changed in metacity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.