Alt-tabbing to an app with a modal dialog open doesn't move it up in the alt-tab order.

Bug #57028 reported by Adam Buchbinder on 2006-08-20
4
Affects Status Importance Assigned to Milestone
Metacity
Confirmed
Medium
metacity (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

The Alt-tab order for apps reorders when you tab to a window. (Say the order is 1, 2, 3, with 1 being on top. If you alt-tab to window 3, then the order will be 3, 1, 2.) This does not happen when one of these windows has a modal dialog open.

To replicate:

1. Open gedit, and some other windows. (Nautilus windows will do, as long as there's more than one.)
2. Type some nonsense into the gedit window. Hit CTRL-Q to pop up the "Save the changes?" dialog.
3. Alt-tab to one or more of the other open windows. Then alt-tab back to gedit.
4. At this point, gedit should be at the top of the alt-tab list, but it is not. It cannot, as long as it has a modal dialog open, move up in the list, only down.

I am using metacity 1:2.14.3-0ubuntu2 on Ubuntu Dapper.

This may be related to 16755, but appears to be different in some ways: in that bug, the window could not be brought to the front at all; in this, the window is brought to the front; the issue is with the alt-tab list.

Changed in metacity:
importance: Untriaged → Low
Changed in metacity:
status: Unknown → Rejected
Sebastien Bacher (seb128) wrote :

Thank you for the bug and the upstream pointer

Changed in metacity:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Changed in metacity:
status: Rejected → Confirmed
sam tygier (samtygier) wrote :

This and bug #16755 both link to the same upstream bug. it seems that they are different issues but being handeled together upstream.

Changed in metacity (Ubuntu):
status: Confirmed → Triaged
Changed in metacity:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.