terminal is closing while under another window

Bug #554221 reported by Nicolas Repentin on 2010-04-02
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
New
High
metacity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-terminal

In ubuntu 9.10 or 10.04 beta, when a terminal is under another window, closing this window close the terminal.
It append all times and give no crash report.

you can see an example on video here : http://www.shivaserv.fr/download/ubuntu/bug.ogv

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-terminal 2.29.6-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Apr 2 22:34:39 2010
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1546): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-terminal:1861): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed
 (gnome-terminal:1908): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed
 (gnome-terminal:1953): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed

Davide Lasagna (lasagnadavide) wrote :

Hi Nicolas,
Thanks for taking the time to report this bug and for helping to make Ubuntu better.

However i can't reproduce this bug on my Lucid Lynx, so if you're still encountering this bug you may provide a more complete description of the steps to reproduce it. Does it happen with every kind of window? Only firefox? Is it reproducible?

Cheers
Davide

Hi,

It happend with any application, not just firefox. You just have to open a terminal, and maximized it. After, you open another application, maximized it and take it over the terminal. When you close it, it closed the terminal under.

Sorry, for me it happend all the time :s

how can I help you to correct this bug ?

Pedro Villavicencio (pedro) wrote :

can't reproduce here either, could you run an xterm and execute gnome-terminal from there and see if you get any message after closing it? I'm not sure if it's crashing or not. Please paste the output to the report, thanks in advance.

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Zod (zod-zod) wrote :

I can confirm that, however it doesn't happen for me every time, Sometimes it happens sometimes not.

I upgraded to Lucid from karmic to see if the problem persists, and it's still here.

Sometimes dragging a window with the titlebar makes the terminal somewhere below it resize to normal size and dragged instead of the original window.

I'll try to find a sure way to reproduce...

Zod (zod-zod) wrote :

I was able to reproduce it.

Open any application (I tried with firefox and gedit)

Open a terminal and maximize it by double clicking on the title bar. (It doesn't happen if I maximize with the maximize icon)

Switch to the other application and hit close. The terminal closes.

Even better: all title bar actions affect the terminal not the window in the foreground (minimize, drag by title bar, etc...)

I use Lucid with the human theme, but happens with ambience too with the icons on the left side.
I thought it was somehow fglrx related, but same with the radeon driver.
I tested it with desktop effects turned off.

I'll do a clean Lucid install later today and check if it's still there.

Exact. I try your method, it works, it's only when the terminal is maximized with the title bar.

Davide Lasagna (lasagnadavide) wrote :

Zod, I cannot reproduce the bug with your procedure. Can you try to create a new user, login with it and try again?

Davide Lasagna (lasagnadavide) wrote :

Also, try getting some debug information as Pedro suggested at comment #4.

Zod (zod-zod) wrote :

Hi Davide,

If I start the terminal from xterm, nothing happens. Gnome-terminal immediately goes to the background, and on close nothing is printed.

I've just installed a clean Lucid for x64.
I can't reproduce the bug here.

I'll give it a go on a clean 32 bit install too.

Pedro Villavicencio (pedro) wrote :

Could also somebody getting the issue attach the ~/.xsession-errors file to the report? as well with the info requested on comment #4 , thank you all.

Zod (zod-zod) wrote :

Hi! Ok, I have a a clean and fully upgraded 64 bit lucid install. I use fglrx, and I haven't been able to reproduce the bug, but today I switched off desktop effects and the problem came back.

Same way to reproduce: start terminal -> maximize with double click on titlebar -> switch to another window and click the close icon.

But I can add one more clue: after maximization if I switch to another application and click anything in the titlebar it'll pass through to the terminal. But only once. I have to minimize and maximize again and than the first click on the titlebar will pass through to the terminal again.

This doesn't happen with visual effects normal.

Errors in .xsession-errors:

With visual effects normal and none too.
At the start of the first terminal instance:

(gnome-terminal:2752): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed

No more after starting more terminals.

Some news for resolving this bug ?

Rudolf (rk-com) wrote :

I can confirm this problem:
1. it occured with 9.10 and after upgrade to 10.04 it's still there
2. with visual effects "normal", the problem is gone and with visual effects "none" it happens again.

Using 10.04 32bit (german), fglrx, gnome-terminal and any other program (gedit, firefox).
The "Gtk-CRITICAL" message mentioned above appears after starting gnome-terminal with any visual effects.

But here's an interesting fact:

- set visual effects "normal"
- start gnome-terminal, maximize the window (double-click on titlebar)
- start gedit, maximize the window (if not maximized already)
- set visual effects to "none"
- switch to gnome-terminal
- switch to gedit
- click window-close icon of gedit window

result: gedit window closed, gnome-terminal still there (tested 4 times, worked 4 times)

Seems as if the window "keeps" something from visual effects settings!?

Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME Thanks in advance!

Changed in gnome-terminal (Ubuntu):
status: Incomplete → Confirmed
Rudolf (rk-com) wrote :

@Pedro Villavicencio - thanks for the hint !
https://bugzilla.gnome.org/show_bug.cgi?id=620970

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-terminal:
status: Unknown → New
Changed in gnome-terminal:
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

upstream said this is a metacity issue, reassigning. thanks.

Changed in gnome-terminal:
status: Invalid → Unknown
affects: gnome-terminal (Ubuntu) → metacity (Ubuntu)
Changed in gnome-terminal:
status: Unknown → New

where is the progress about this bug ? still present and very irritating.

Marc Gariépy (mgariepy) wrote :

It happen to me with terminator closing behind another applications ex: evolution

Changed in gnome-terminal:
importance: Unknown → High

reproducable in ubuntu 10.10 beta as well

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.