Add menu metacity the choice of the positioning buttons

Bug #542772 reported by steveacab on 2010-03-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: metacity

This is NOT request for re-order the metacity buttons, but add in the metacity menu the options like:

*Button on left : gconftool-2 --set /apps/metacity/general/button_layout --type string "close,maximize,minimize:menu"
*Button on right : gconftool-2 --set /apps/metacity/general/button_layout --type string "menu:minimize,maximize,close"

This idea is to simplify the repositioning, anyone who wants it, metacity buttons in easy and fast way for all.

There are some example:

http://img265.imageshack.us/img265/5359/schermatar.png
http://img684.imageshack.us/img684/9718/schermata1t.png
http://img684.imageshack.us/img684/4976/schermata2ry.png

#Please, not flame, this is an request for ALL, for people like me like the buttons to the left and for those who want them at right Bug #532633

summary: - Add menu metacity the choice of positioning buttons
+ Add menu metacity the choice of the positioning buttons
steveacab (antonio.chiurazzi) wrote :

I wont add than option is just avaiable. I just migrate the button on left and on right with pressing alt+F11 and alt+F12.

In /apps/metacity/global_keybindings modify : "run_command_1" and insert <Alt>F12
In /apps/metacity/global_keybindings modify : "run_command_2" and insert <Alt>F11

In /apps/metacity/keybinding_command modify: "command_1" and insert : gconftool-2 --set /apps/metacity/general/button_layout --type string "menu:minimize,maximize,close"

In /apps/metacity/keybinding_command modify: "command_2" and insert : gconftool-2 --set /apps/metacity/general/button_layout --type string "close,maximize,minimize:menu"

Is not visible in metacity menu but work perfectly.

The bug is only to implement this strings and this voices in metacity menu.

Mitch Towner (kermiac) wrote :

If I understand correctly, this has been suggested in bug #532633. I understand that you may not have seen it due to the amount of comments in that bug report.

Please check if the following is what you are proposing:
http://bazaar.launchpad.net/~alexeftimie/+junk/gcc/revision/134
http://launchpadlibrarian.net/40647960/window_controls_position_gui.png

If this is what you are suggesting, this bug should be filed against "gnome-control-center" & this bzr branch should be linked to this bug report as it will most like become lost in bug #532633.

Changed in metacity (Ubuntu):
status: New → Incomplete
affects: metacity (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
steveacab (antonio.chiurazzi) wrote :

even if that idea is very good mine is a different proposal

I dont mean to modify the control-center.

If fix metacity menu for look the added commands in /apps/metacity/global_keybindings this bug is solved and fix the bug of metacity menu and enough to implement 2 string and 2 keybinding option for choise the side of metacity button and solved this bug.

steveacab (antonio.chiurazzi) wrote :

Open new related bug for solved this.

Bug #543125

Mitch Towner (kermiac) wrote :

As I misinterpreted what you were asking, I will make this a dupe of the new bug you have opened so that this info isn't lost.

Please disregard comment #2 - sorry for the confusion & bugmail noise.

affects: gnome-control-center (Ubuntu) → metacity (Ubuntu)
Changed in metacity (Ubuntu):
importance: Wishlist → Undecided
status: Incomplete → New
steveacab (antonio.chiurazzi) wrote :

This isnt an duplicate of Bug #543125

The bug Bug #543125 is because metacity dont show added keybindings and this is for show by default the keybindings for switch the metacity button on the left and on the right in metacity menu.

Matthew Paul Thomas (mpt) wrote :

Can you explain what you mean by "Metacity menu"? Do you mean the menu you get when you right-click on a title bar?

steveacab (antonio.chiurazzi) wrote :

alt+space sorry

Changed in metacity (Ubuntu):
importance: Undecided → Wishlist
Vish (vish) wrote :

This has now be fixed , users/themers can set the option individually in the theme [in the index.theme file] as:
ButtonLayout=menu:maximize,minimize,close

This is a new option that has been added.

and also, when they select the new theme , they can choose to /not/ use the button layout if they want. A prompt asks for confirmation before switching layout.

Changed in metacity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers