Ubuntu

[Lucid] Window controls are on the left side after update

Reported by Alvaro Kuolas on 2010-03-07
500
This bug affects 119 people
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Jason McMullan

Bug Description

Binary package hint: metacity

After update Metacity window controls appear on the Left side instead of the right side.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 80e323949b5d778368b39459217fd9fd
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Sat Mar 6 22:10:49 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100217)
Package: metacity 1:2.28.1-0ubuntu5
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: metacity
Uname: Linux 2.6.32-15-generic i686

Alvaro Kuolas (kuolas) wrote :
Alvaro Kuolas (kuolas) wrote :

It happens with Compiz enabled too. So, it's not only Metacity.

Alvaro Kuolas (kuolas) wrote :

I have updated this systems everyday from Lucid-current (25-02-2010) to this date.

Arnaud Jeansen (ajeans) wrote :

This is a design choice by the artwork team for Lucid. This blog explains how to tweak the window controls back to the right:
http://blog.daviey.com/blogroll/anything-but-the-buttons.html

This is not a bug as this is a deliberate choice by the design team.

Changed in metacity (Ubuntu):
status: New → Invalid
Alvaro Kuolas (kuolas) on 2010-03-07
summary: - [Lucid] Metacity window controls are on the left side after update
+ [Lucid] Window controls are on the left side after update

How could I configure it like it used to be?

On Sun, 2010-03-07 at 00:38 +0000, Arnaud Jeansen wrote:
> This is a design choice by the artwork team for Lucid. This blog explains how to tweak the window controls back to the right:
> http://blog.daviey.com/blogroll/anything-but-the-buttons.html
>
> This is not a bug as this is a deliberate choice by the design team.
>
> ** Changed in: metacity (Ubuntu)
> Status: New => Invalid
>

showgun (showgun) wrote :

this definitely does not feel right and I did switch back the controls to the right
otherwise it was something I hated might be good for the lefty..??

Alvaro Kuolas (kuolas) wrote :

I've read the link above... and they are testing. Let it be, I don't think this could be on the final version.

Definitely, this needs an easy option for configuring in the System>Preferences>Appearance, it could be good as an option.

Martin-Éric Racine (q-funk) wrote :

Personally, I vote against this change in behavior. It is utterly disruptive.

AFarris01 (afarris01) wrote :

I do not believe that this is issue is invalid... I feel that it is a usability bug, and should be corrected before the final release.

szczym (szczym) wrote :

Controls on right are wrong, just plain wrong. The bug is valid and confirmed in my opinion.

Changed in metacity (Ubuntu):
status: Invalid → Confirmed
Kayra Akman (ckakman) wrote :

Controls should be on the right, and Minimize button should be the left most on of the three.

I really wonder what guideline the UI designers were following. If there is nothing left to do but play around with these buttons, then some config GUI should be provided so that it can be easy to mess up the order if anyone wants to but not to fix it.

Not my blog, but a good article on the matter:

http://yokozar.org/blog/archives/194

Ubuntu Brainstorm Idea #23899
Move the min, max, close buttons back to the right in 10.04
http://brainstorm.ubuntu.com/idea/23899/

tags: added: button close maximize minimize position window
CptAJ (antonioetayo) wrote :

While this is indeed not a software bug but a design choice, it is so wrong that I'm inclined to think it might constitute a bug in the design guidelines themselves.

There is no exceptional advantage that justifies this change. It seems nothing but whimsical and fails to take into account serious usability issues such as muscle memory and misclicks; more thoroughly outlined in Yokozar's article.

Such a drastic UI change should be backed up by facts that objectively define a clear advantage that outweighs the inevitable user reception obstacles.

On a side note, I think that the "its a choice, not a bug" responses are childish and harmful to the healthy dialogue these report systems are designed to nurture. We all know its not really a bug, but its an issue that demands discussion and dismissing it on such a technicality is seriously immature. Grow up and stop avoiding the issue.

Edman274 (dudeman-site) wrote :

Not what I said, but sums it up nicely:
http://yokozar.org/blog/archives/194

"• Because the window title isn’t centered, the window controls being placed directly in front of it put it in a weird indented position
• The “slightly off left” location is inconsistent with Nautilus, Firefox, Thunderbird, Pidgin, Empathy, and every other tabbed program we have, which have close buttons for their tabs on the right.
• The left position is inconsistent with Windows, previous versions of Ubuntu, and even OSX – users have to relearn decades of muscle memory.
• Users who interact with both Windows and Ubuntu machines (or migrate from Windows) will have a much harder time than they did before.
• The buttons are too close to the file and edit menus, making catastrophic misclicks much more likely. Closing something on accident should be as rare as possible.
• Even without misclicking, a user will have to take more time to use the window control and avoid a misclick. This is an example of Fitt’s Law.
• The close position is also inconsistent with the power button in upper right. Currently, “close it down” is something you can always do from the upper right anywhere in the system: within a tab, within a window, and even for the whole computer. The new window controls break that entirely.
• The new position leaves a lot of empty, wasted space in the upper right of most windows. While strictly speaking the amount of unused space is the same, it looks much worse when it’s all clustered together. When the controls are on the right, the extra space can function as a buffer for the potentially destructive window controls.
• Similarly, the upper left of most windows now becomes much more crowded, creating a rather unpleasing contrast to the relatively empty upper right.
• In previous Ubuntus you could close windows on the left if you really wanted, by expanding the small circle menu that’s now gone entirely. File->Quit is also an option, which is now very close to the close box.
• Gnome upstream has them on the right, causing consistency and developmental problems when we deviate. This is particularly jarring with the adoption of future projects like Gnome shell and Gnome 3, which will change again how we interact with window controls.
• The current implementation breaks themes not designed for the new button order (which is currently every theme we ship, so even changing the theme back doesn’t help)
• A day before User Interface freeze of a long term support release is the worst possible time to suddenly spring this on everyone without explanation.
• It is very difficult to change them back as we don’t have any UI tool for doing this (the current method is manually editing gconf keys)
• The new position doesn’t actually do anything beneficial."

This is a serious usability flaw, the only OS in the world I know of that actually works this way is Mac OS X, the rest of the world are used to the "old" way.

No free desktops provide this by default, no other distributions provide this by default for that matter, so I can say that it hurts interoperablilty and alienates a whole lot of users in the process, without any benefit.

MichaelSwengel (truesongtech) wrote :

This was a foolish choice by the design team.

And, as you can see, users do not like this change: http://brainstorm.ubuntu.com/idea/23899/

It may not be technically a bug, but it's as serious as one.

More people want it on the right by default than at the left, change it back! doing this hours before the interface freeze is ridiculous! Anything but the buttons! Release Mangers please fix!

lnxwalt (lnxwalt) wrote :

This is a mistake, guys. Seriously. Stop, turn around, and head in the opposite direction.

Mike MacCana (lovekudu) wrote :

The blog post regarding the change mentions the change is a test only. When did testing finish? What were the results of the testing? Were they successful or unsuccessful? Why were they so?

Alvaro Kuolas (kuolas) wrote :

I think that bug #532633 it's related but not a duplicate. Bug #532633 wants to revert the order of the buttons when this bug is for the buttons place, not it's order. Anyway, they should fix both problems by RC, they are critical usability BUGs.

Alvaro Kuolas (kuolas) wrote :

This bug is not in the light-theme nor Metacity... it's in the configuration made by Ubuntu developers.

MichaelSwengel (truesongtech) wrote :

For those who want to move the buttons back to where they should be, here's a workaround.

http://ubuntuforums.org/showthread.php?p=8963718

This needs to be changed before 10.04 is released.

theres no need to change the buttons to the left until 10.10. For God's sake - it's an LTS release, not an experimental joke.

MichaelSwengel (truesongtech) wrote :

There is NEVER a need to change something like this by default. Ugh.

Let the user put the buttons there if he so chooses. Otherwise....no.

> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/533566/+subscribe
>

I agree that controls should by default be placed where it used to be.
On the other hand, after a second thought,i would like to have the choice to
place controls wherever i like.
Personally i place the task bar at the bottom side of the screen (KDE-like)
so it would be more convenient for me
to have the controls at the low-left side of the window, in short distance
from main menu's and browser's buttons.

James Lewis (james-fsck) wrote :

The ability to move the controls to the left may be desirable, but I now can't see a way to access the window controls that were previously on the left.... Eg. "Always on top"... etc.

The current situation is a usability bug, even if it is deliberate, since these additional controls are now unaccessible... ideally it should be configurable by the theme, but it should not be left as it is because some of the window controls are now inaccessible.

BobPendleton (bob-pendleton) wrote :
Download full text (5.3 KiB)

There is a bug somewhere. I used the gconf-editor tweak to fix the bug on two machines that were running alpha 3. I just installed beta1 on my laptop and learned, the hard way, the the gconf-tweak has been disabled. Changing the metacity setting no longer moves the buttons to the right.

If this is not a bug because it is a design decision then it is time to debug the designer by replacing him/her/them. They are, to but blunt, incompetent and arrogant beyond the meaning of the word arrogant. I have seen this kind of disregard for the pain of other humans only in the history of mass scam artists and spammers. I am serious, this is, for me, a deal killer. If this is left in, I and many people like me will simply switch to another, any other distribution.

I have read comments from Shuttleworth on this is intended to "free up" the right hand side of the window title bar to make room for space for "future" "enhancements". So this disregard for all of comes directly from the top. Not sure what to do about that. His comments also tell us the he not only has no interest in fixing the problem. He plans to make it worse, much worse, by putting something in the right hand corner. If what he puts there is any kind of a control it will be hit and triggered constantly by everyone who use Ubuntu.

Why do I say pain? In my case I must use Windows machines everyday. OTOH, I have been using an X based desktop since X11R3. I have been using a desktop with the window buttons on the right since the late '1980s? So long ago it is hard to remember :-) Every time I try to use Lucid on my laptop my eyes go wonky trying to find the window buttons. It takes me several seconds to find the new buttons. It wastes my time, and it causes me physical pain from the eyestrain of having to search carefully for the buttons. Yeah, if I've been using X since the 1980s I must be old by now.

Here is the punchline, the kicker, the deal breaker....

I installed Lucid Alpha 3 on a test machine and freaked when the windows came up without any buttons. On closer inspection I found them on the wrong side. I quickly found out how to correct the problem using gconf-editor. I thought, ok that was easy I can live with that. I put Lucid Alpha 3 on my desktop and I've been using it happily with that little tweak with gconf-editor and a few clicks of the mouse to get rid of that unreadable new theme. Ok, so I waited until beta 1 came out and waited a few days for it to stabilize and I installed it on my laptop. (I really love Ubuntu on a laptop.) I also updated my test machine and desktop to beta 1.

After rebooting I went in to gconf-editor and changed the buttons back to the right. The first two times I did that on my other two machines the buttons moved instantly. But, on a fully updated install of beta 1 the buttons did not move. The buttons are still on the right on the machines I installed with alpha 3. But, on the machine I installed with beta 1 the buttons did not move. I have checked and the changes to show up in gconf-editor. But, the buttons are still on the left. They have not moved. I have check the settings three times now and even rebooted between checking and the buttons ar...

Read more...

@BobPendleton - there is no decision to prevent people from rearranging
window controls. I suspect you've either tripped over a bug, or
something else unexpected has occurred.

tokenwizard (tokenwizard) wrote :

See this: http://ubuntu-tweak.com/

Latest Version has an option to move the controls back to the right.

Another option is:

gconftool-2 --set "/apps/metacity/general/button_layout" --type string "menu:maximize,minimize,close"

On Tue, Mar 23, 2010 at 3:43 AM, Mark Shuttleworth <email address hidden> wrote:
> *** This bug is a duplicate of bug 532633 ***
>    https://bugs.launchpad.net/bugs/532633
>
>
> @BobPendleton - there is no decision to prevent people from rearranging
> window controls. I suspect you've either tripped over a bug, or
> something else unexpected has occurred.

Yep, the problem disappeared after an update the next day.

Bob Pendleton

>
> --
> [Lucid] Window controls are on the left side after update
> https://bugs.launchpad.net/bugs/533566
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “metacity” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: metacity
>
> After update Metacity window controls appear on the Left side instead of the right side.
>
> ProblemType: Bug
> Architecture: i386
> CheckboxSubmission: 80e323949b5d778368b39459217fd9fd
> CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
> Date: Sat Mar  6 22:10:49 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100217)
> Package: metacity 1:2.28.1-0ubuntu5
> ProcEnviron:
>  LANG=en_US.utf8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
> SourcePackage: metacity
> Uname: Linux 2.6.32-15-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/533566/+subscribe
>

--
+-----------------------------------------------------------
+ Bob Pendleton: writer and programmer
+ email: <email address hidden>
+ web: www.TheGrumpyProgrammer.com

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers