metacity assert failure: metacity:ERROR:core/bell.c:211:bell_flash_window_frame: assertion failed: (window->frame != NULL)

Bug #467972 reported by Umang Varma on 2009-11-01
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Metacity
Fix Released
Medium
metacity (Ubuntu)
Medium
Ubuntu Desktop Bugs
Nominated for Karmic by Mark Stosberg
Nominated for Lucid by Mark Stosberg

Bug Description

Binary package hint: metacity

I don't know what happened. It just crashed. I was using Chrome when it happened and I just upgraded to Karmic today.

ProblemType: Crash
Architecture: i386
AssertionMessage: metacity:ERROR:core/bell.c:211:bell_flash_window_frame: assertion failed: (window->frame != NULL)
Date: Sun Nov 1 11:45:57 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/metacity
Package: metacity 1:2.28.0-0ubuntu1
ProcCmdline: metacity
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Signal: 6
SourcePackage: metacity
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 g_assertion_message () from /lib/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/libglib-2.0.so.0
Title: metacity assert failure: metacity:ERROR:core/bell.c:211:bell_flash_window_frame: assertion failed: (window->frame != NULL)
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev powerdev sambashare scanner tape video
XsessionErrors:
 (gnome-settings-daemon:3172): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:3192): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:3195): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:3206): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
 (chrome:3337): Gdk-WARNING **: XID collision, trouble ahead

Umang Varma (umang) wrote :
Konrad Voelkel (konradvoelkel) wrote :

Exactly the same for me. Seems to be related to Google Chrome & entering somethin in forms (it happens only when I'm editing my blog posts).

LGB [Gábor Lénárt] (lgb) wrote :

The same for me! I'm using chromium, not chrome, but the problem is very similar, I can see that assert message in .xsession-errors too. It happens almost every day once or more. I'm using Ubuntu 9.10 on 32 bit.

I think bug 434389 is quite similar to this one, though.

metacity:
  Installed: 1:2.28.0-0ubuntu1
  Candidate: 1:2.28.0-0ubuntu1
  Version table:
 *** 1:2.28.0-0ubuntu1 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
chromium-browser:
  Installed: 4.0.246.0~svn20091112r31785-0ubuntu1~ucd1
  Candidate: 4.0.246.0~svn20091112r31785-0ubuntu1~ucd1
  Version table:
 *** 4.0.246.0~svn20091112r31785-0ubuntu1~ucd1 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status

LGB [Gábor Lénárt] (lgb) wrote :

Maybe the problem, that Chromium (and also Chrome) does not have window border/decoration (by window manager) by default? :)

Changed in metacity (Ubuntu):
status: New → Confirmed
LGB [Gábor Lénárt] (lgb) wrote :

http://code.google.com/p/chromium/issues/detail?id=27654

"chrome:3337): Gdk-WARNING **: XID collision, trouble ahead"

However I don't know it's chromium or metacity bug then, metacity shouldn't crash by a client though, at least imho.

derat (dan-launchpad-erat) wrote :

I attached a patch to fix this in metacity at https://bugzilla.gnome.org/show_bug.cgi?id=601907 .

derat (dan-launchpad-erat) wrote :

(I think that one can also work around this by changing the "Visual alert" setting in Sound Preferences -> Sounds to something other than "Flash window".)

Changed in metacity (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: Confirmed → Triaged
Asheesh Laroia (paulproteus) wrote :

Since chromium-browser and metacity are packaged in Ubuntu, can we see an updated metacity package that has this (very simple) patch applied?

Mark Stosberg (markstos) wrote :

This metacity crasher has been fixed upstream by Gnome. I nominate it for release in the karmic updates channel.

Changed in metacity:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.