metacity assert failure: metacity:ERROR:core/boxes.c:1161:meta_rectangle_edge_aligns: code should not be reached

Bug #437139 reported by bbg5ne on 2009-09-26
98
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Metacity
Fix Released
Critical
metacity (Debian)
Fix Released
Unknown
metacity (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Binary package hint: metacity

I think this is a new bug

ProblemType: Crash
Architecture: i386
AssertionMessage: metacity:ERROR:core/boxes.c:1161:meta_rectangle_edge_aligns: code should not be reached
Date: Sat Sep 26 13:13:02 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/metacity
Package: metacity 1:2.28.0-0ubuntu1
ProcCmdline: /usr/bin/metacity --replace
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
Signal: 6
SourcePackage: metacity
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 g_assertion_message () from /lib/libglib-2.0.so.0
 ?? ()
Title: metacity assert failure: metacity:ERROR:core/boxes.c:1161:meta_rectangle_edge_aligns: code should not be reached
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

bbg5ne (webcreator) wrote :

StacktraceTop:__kernel_vsyscall ()
*__GI_raise (sig=6)
*__GI_abort () at abort.c:92
g_assertion_message () from /lib/libglib-2.0.so.0
meta_rectangle_edge_aligns (rect=0xa84, edge=0x0)

Changed in metacity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=603632

visibility: private → public
Changed in metacity (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
Changed in metacity:
status: Unknown → New
Changed in metacity:
importance: Unknown → Critical
Pedro Villavicencio (pedro) wrote :

latest dupe is on Metacity 2.34, there's a patch on the upstream bug that needs to be tested, so I'm marking this as a task for Precise.

Changed in metacity (Ubuntu Precise):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Canonical Desktop Team (canonical-desktop-team)
Changed in metacity:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Sebastien, the upstream bug has a reproducer and a patch, can you please try this and see whether it helps? Thanks!

Changed in metacity (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
Changed in metacity (Ubuntu Precise):
assignee: Sebastien Bacher (seb128) → nobody
Michael Terry (mterry) wrote :

I tried the upstream patch and reproduction steps. Didn't fix the problem for me. (Commented as such in upstream bug.)

tags: added: precise
Changed in metacity (Debian):
status: Unknown → New
Changed in metacity:
status: Confirmed → Fix Released
Changed in metacity (Ubuntu Precise):
status: Triaged → Invalid
Changed in metacity (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.