Ubuntu

Truncated desktop/app display in Intrepid

Reported by MMD on 2009-01-04
4
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Low
Unassigned

Bug Description

After login, desktop icons are forced into the top 2/3 of the screen. On open of any application, Firefox, Gedit, etc, the screen is maximized, but only fills 2/3 of the screen. Minimize/re-maximize has no effect.

Valid workarounds include logging out and back in, or changing the refresh rate on the screen resolution from 60 to 70 and back again. Fix only holds up until the next reboot.

System is dual-core Asus/Athlon Pentium 64, Monitor is 17" Sceptre CRT.

Specifics:

lsb_release
Description: Ubuntu 8.10
Release: 8.10

apt_cache
firefox:
  Installed: 3.0.5+nobinonly-0ubuntu0.8.10.1
  Candidate: 3.0.5+nobinonly-0ubuntu0.8.10.1
  Version table:
 *** 3.0.5+nobinonly-0ubuntu0.8.10.1 0
        500 http://us.archive.ubuntu.com intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     3.0.3+nobinonly-0ubuntu2 0
        500 http://us.archive.ubuntu.com intrepid/main Packages

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
Package: firefox-3.0 3.0.5+nobinonly-0ubuntu0.8.10.1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-9-generic x86_64

MMD (chezmmd) wrote :
Hew McLachlan (hew) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 99740, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

MMD (chezmmd) wrote :

Maybe.

The bug you reference is more than a year old. I've been running FF for long before that, and this bug popped up last week. Given that it was a holiday week, whatever update screwed things up may have been a few days around that, but this problem is definitely a December/08 creation.

Also, I've had desktop effects on normal for months, w/o any FF wackiness.

I would try and downgrade from 3.0.5, but Synaptic won't let me.

All in all, since the browser is my work life, this is a hugely unhappy situation.

Hew McLachlan (hew) wrote :

I still think this is a duplicate of bug 99740, but have unmarked it for now to avoid bug noise.

I wouldn't be so quick to blame the -security update for causing the problem, it really sounds like bug 99740 which appears on a seemingly random basis. Does the problem still occur if you disable the legacy fullscreen support workaround with ccsm, as described in bug 99740? Thanks in advance.

Changed in firefox-3.0:
status: New → Incomplete
importance: Undecided → Low
MMD (chezmmd) wrote :

Today, everthing is worse.

To answer your question, I first went ahead with another suggestion from one of the duplicates to set Desktop Effects to none. Initially that seemed to fix the problem, but I didn't reboot until this morning.

Also, yesterday, I saw that there was a Firefox update, so I installed the updates that had accumulated to yesterday. Again, no reboot until this morning. Possibly a dumb move on both parts.

Now, every single application opens up maximized, at 50% of the screen, from gedit to FF. I can only have icons on the top half of my desktop. I can resize the app, but in FF's case, once I minimize and restore, it's back to 50%.

Once I got your email, I tried the ccsm. And a reboot this time. No effect. Also, tried restoring desktop effects. No difference.

I am so ready to wipe the machine out and go back to 6, where I never had a single problem.

Let me know if there's anything I can try to resolve this.

MMD (chezmmd) wrote :

Follow-up. I decided to check a few things and stumbled on a possible hint to the problem. No matter what, if I reboot, I'm back to 50% use of the screen. But, if I change the refresh rate from 60 to 70 and back again, I can get usable apps.

I had a problem in November with the refresh rate; it had defaulted to 75 and I worked there okay for a while, but suddenly it started going garbled. So I switched it to 60, and all was fine until last week.

BTW, Monitor is a Sceptre 19" CRT.

HTH.

Hew McLachlan (hew) wrote :

This now sounds like a screen resoultion problem, which is not what you originally reported, and cannot be caused by a firefox update. Are you sure Compiz is now disabled (desktop effects = none)? What do you mean by 50% of the screen, can you only see a fraction of your desktop? Could you please take a screenshot of the issue? Thanks again.

MMD (chezmmd) wrote :

That's because when I originally filed this, FF was the only app having a display problem. Now, nearly every app has a problem, as well as the desktop itself.

FF is still the only one that still is funky after a toggle on the refresh rate. But once I resize it, it then holds up until a reboot. Remaining apps behave okay until a reboot.

The things that have happened since all this started:

1. Per the original bug (99740), I installed ccsm, chose the workarounds and disabled the legacy screen support flag.

2. On 1/6, I installed all the pending updates, since there was a FF update in there.

3. I set the desktop effects to none.

Now the original FF missing menu/decorations problem is gone, to be replaced by something just as annoying.

Screenshot of Mozilla on open provided. All my other apps behaves the same - maximized, but only showing at about 50% of the screen size.

Thanks for the help.

MMD (chezmmd) wrote :

I'm posting a screenshot of gedit on open, so you can see the decorations. I didn't realize they were blocked at the time of the FF shot.

Hew McLachlan (hew) wrote :

Thanks for the screenshots. What graphics driver are you using? If it's the nvidia proprietary driver, does changing to the nv free driver fix the issue?

MMD (chezmmd) wrote :

Checking Hardware Drivers - message is 'No proprietary drivers are in use on this system'. System suggests using the ATI/AMD FGLRX driver, but it is not activated.

hth.

MMD (chezmmd) wrote :

Stumbled on additional way to temporarily fix the display. Log off and log back on.

Problem still returns w/reboot.

Hew McLachlan (hew) wrote :

Does the problem still occur? If so, it would be helpful if you could update the bug title / description to reflect the issue you currently experience. Please try with both compiz and metacity.

Please attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Could you please also try to run without any /etc/X11/xorg.conf and let Xorg autodetect your display and video card? Please also attach the /var/log/Xorg.0.log from this attempt. Thanks in advance.

MMD (chezmmd) wrote :
description: updated
MMD (chezmmd) wrote :
MMD (chezmmd) wrote :
MMD (chezmmd) wrote :

Okay, hopefully provided most of what you needed. I didn't follow the compiz/metacity part.

I'm also attaching a new snapshot of the file browser after a boot.

thanks for the help.
Madeleine D.

Hew McLachlan (hew) wrote :

Thanks for the information.

Compiz is commonly known as desktop effects. Metacity is what is used when desktop effects are set to none. Does the same behaviour occur in both situations?

The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Jaunty Jackalope. There have been new releases of Xorg and GNOME included in Jaunty, which may already contain a fix for your issue. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

MMD (chezmmd) wrote :

Orginally, the problem happened whether desktop effects were set or not. But as of a couple updates ago, the problem has shifted somewhat; it now only occurs when effects are set to 'none'. I've run a couple days with effects set to normal to make sure of this one.

Will check the Jaunty out on a new machine I'm building.

thanks,
mmd

affects: compiz (Ubuntu) → metacity (Ubuntu)
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of Metacity is available in both Lucid and Maverick and we are wondering if this is still reproducible in any of those versions, May you please test and give us of feedback about it? Thanks in advance.

Changed in metacity (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in metacity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers