[sponsoring] Please upload metacity 2.25.89

Bug #312522 reported by Baptiste Mille-Mathias on 2008-12-30
2
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Wishlist
Unassigned

Bug Description

upstream Changelog
  * New upstream version
    - The maximisation key is a toggle.
    - "Unmaximise" is now called "restore".
    - New thread handling call for gconf
    - Add screenshot commands back which had been removed
    - move_to_corner_se keybinding fixed
    - Windows on other workspaces which attempt to present themselves are
    marked as needing attention
    - End the grab op when the user clicks the titlebar
  * patches/011_gnome_482354_attachment_104591.patch:
    - dropped, applied upstream

Related branches

I attached the new version of the package, but can't find how to delete the metacity_2.25.89-0ubuntu2* attachments.

Bryce Harrington (bryce) wrote :

    - Add screenshot commands back which had been removed
Fixes bug #305695

Changed in metacity:
importance: Undecided → Wishlist
status: New → Confirmed
C.J. Collier (cjcollier) wrote :
Download full text (3.1 KiB)

Some discussion happened on freenode's #ubuntu-desktop about this bug:

--- Day changed Wed Dec 31 2008
02:03 < Nafallo> anyone good with totem except seb, that isn't here?
02:15 < Nafallo> I have a problem with bacon ;-)
06:35 -!- jcastro_ is now known as jcastro
10:41 -!- thunderstruck is now known as gnomefreak
11:20 -!- asac_ is now known as asac
15:41 -!- fta_ is now known as fta
16:45 < cj> Nafallo: isn't benm good with totem? I don't know whether he's on I
RC anymore... I haven't seen him in a while...
16:46 < Nafallo> cj: no idea, but the forums solved it. kind of.
16:46 < cj> ah, what's the problem?
16:47 < Nafallo> cj: not entirely sure... bug 283592
16:47 < ubottu> Launchpad bug 283592 in totem "bacon_video_widget_set_fullscreen
" [Medium,Confirmed] https://launchpad.net/bugs/283592
16:50 < cj> Nafallo: sounds like a compiz interop problem, eh?
16:50 < Nafallo> yea
16:55 * cj checks out V_2_24_3 tag
16:55 < cj> I don't think I'll fix it for you, but I may be able to add some inf
o to the bug for seb when he gets back from vacation
16:56 < Nafallo> kewl :-)
16:57 < cj> do you know whether you're using gst or xine?
16:57 < Nafallo> gstreamer
16:58 < Nafallo> I saw google results for the xine one as well though
16:58 < cj> do you know how to use gdb?
16:58 < Nafallo> cj: yea, but my computer got fixed, as documented in the bug re
port.
16:59 < cj> ah, no repro any longer, eh?
16:59 < cj> have you re-started your X session since the "fix"?
16:59 < Nafallo> don't think so.
17:00 < Nafallo> no idea
17:00 < cj> gdm re-starts X when you log out or reboot
17:00 * Nafallo nods
17:00 < Nafallo> I know
17:00 < bluesmoke> Nafallo: Is this the "totem starts kind of fullscreen and kin
d of not" problem?
17:00 < cj> okay. I was confused by "no idea" :)
17:01 < Nafallo> it was reproducable up until I did the steps documented.
17:01 < cj> Iiiinteresting. Turn off compiz, start totem, stop fullscreen, unmax
imise, close totem, turn on compiz, start totem, VOILA!
17:01 < Nafallo> bluesmoke: you could say that, even if that's a non true descri
ption. it's fullscreen.
17:01 < Nafallo> cj: yea. that's the fix :-P
17:01 < Nafallo> it's like... magic
17:02 < bluesmoke> Is it fullscreen but shows the non-fullscreen GUI (and the fu
llscreen GUI too)
17:02 < cj> (past tense now)
17:02 < Nafallo> bluesmoke: ah. yea. I thought those were toggleable in usual fu
llscreen. apparently they aren't.
17:03 < bluesmoke> It's like...totam requests a window size larger than the scre
en, only gets the size of the screen allocated to it, then the wine compatibilit
y stuff says "look, a window trying to be the size of the screen, that must be W
INE running a fullscreen game" and makes it a fullscreen window
17:03 < cj> oh, wow. this is deep magic.
17:03 -!- bluesmoke is now known as Amaranth
17:04 < Nafallo> ehrm... this bug is Windows fault! :-P
17:04 < cj> sounds like the wine compat stuff needs to do a bit more process res
earch before it makes these assumptions
17:04 < Amaranth> I know Danny was really interested in finding a way to reprodu
ce this bug
17
:05 < Amaranth> cj: It's not just for WINE, it's for all legacy apps that were
 made before we had a fullscreen ...

Read more...

C.J. Collier (cjcollier) wrote :

sorry, followed the wrong link and posted to the wrong bug. Please delete my above comment.

Daniel Holbach (dholbach) wrote :

I
 - changed the version number back to 2.25.89-0ubuntu1 (0ubuntu1 and 0ubuntu2 were never uploaded)
 - added an (LP: #312522) to close this bug
 - added a (LP: #305695) to close the bug that Bryce mentioned.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.25.89-0ubuntu1

---------------
metacity (1:2.25.89-0ubuntu1) jaunty; urgency=low

  * New upstream version (LP: #312522)
    - The maximisation key is a toggle.
    - "Unmaximise" is now called "restore".
    - New thread handling call for gconf
    - Add screenshot commands back which had been removed (LP: #305695)
    - move_to_corner_se keybinding fixed
    - Windows on other workspaces which attempt to present themselves are
    marked as needing attention
    - End the grab op when the user clicks the titlebar
  * patches/011_gnome_482354_attachment_104591.patch:
    - dropped, applied upstream
  * debian/patches/013_drop_Werror.patch
    - updated patch

 -- Baptiste Mille-Mathias <email address hidden> Tue, 30 Dec 2008 21:20:24 +0100

Changed in metacity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers