gnome-screenshot ignores the screenshot hotkey

Bug #298463 reported by Christoph Korn on 2008-11-15
4
Affects Status Importance Assigned to Milestone
Metacity
Fix Released
Medium
metacity (Ubuntu)
Low
Unassigned

Bug Description

OS: Ubuntu 8.10 intrepid.

When I run gnome-keybinding-properties and delete the hotkey for taking a screenshot it is ignored by gnome-screenshot.

Pressing print still open gnome-screenshot.

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. Do you have desktop effects enabled? (Check in System -> Preferences -> Appearance -> Visual effects tab). If so, could you please try disabling it and trying again. It might be that you Compiz is still calling gnome-screenshot because desktop integration might be disabled for some reason.

Christoph Korn (c-korn) wrote :

Desktop effects are disabled.

Is there a additional compiz setting to bind gnome-screenshot on the print key?

Chris Coulson (chrisccoulson) wrote :

I can recreate this with desktop effects disabled too. Assigning to Metacity

Changed in metacity:
status: Incomplete → Confirmed
Christoph Korn (c-korn) wrote :

Is there a workaraound?

How can I prevent gnome-screenshot from getting the print key signal?

Instead the current focused application should receive the signal.

Marnanel Thurman (marnanel) wrote :

Fixed upstream in trunk. New release probably coming out tomorrow.

Changed in metacity:
status: Confirmed → Fix Committed
Changed in metacity:
status: Unknown → Fix Released
Pedro Villavicencio (pedro) wrote :

the package containing the fix is already in jaunty, marking this as fixed, thanks.

Changed in metacity:
status: Fix Committed → Fix Released
Changed in metacity:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.