metacity crashed with SIGSEGV in __libc_start_main()

Bug #266929 reported by Nikolaus.x on 2008-09-05
92
This bug affects 1 person
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: metacity

After trying to install and receiving a notice that partition resizer was unsuccessful, went back into live model of Intrepid a5 and immediately got this error report.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/metacity
Package: metacity 1:2.23.144-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: metacity --sm-disable
ProcEnviron:
 LANGUAGE=
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: metacity
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
Title: metacity crashed with SIGSEGV in __libc_start_main()
Uname: Linux 2.6.27-2-generic i686
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Related branches

Nikolaus.x (nikolaus.x) wrote :

This crash has the same stack trace characteristics as bug #258074. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

Ansus (neptunia) on 2008-10-02
Changed in metacity:
status: New → Confirmed
®om (rom1v) wrote :

I don't use metacity, but compiz...

Thomas Thurman (marnanel) wrote :

®om: sorry, I'm missing the relevance of your comment.

tdflanders (thomasdelbeke) wrote :

Hi there Thomas Thurman,

I fear that it is actually very relevant. It all has to do with PAM and authentication problems. See bug Bug #284653.

Cheers,

Thomas

Thomas Thurman (marnanel) wrote :

I'm still bewildered. Someone reports a crash in Metacity. Someone else says he doesn't use Metacity (so what?). And now you point to a crash in consolekit. I can only see the relevance of the first one. Sorry if I'm being stupid.

Hi there,

I think the problem is caused by conflicting configuration of PAM and Unix Consolekit along with faulty setting of ~/.dmrc and ~/.dbus.

This causes crashes due to permission errors in /var/run/dbus/system_bus_socket and crashes a variety of applications including (not exhaustive):

hald-volume-manager
canberra-play-gtk
jockey-gtk
console-kit-daemon
pulseaudio
compiz
compiz.real
x-session-manager
...

I will document this further shortly.

Cheers,

Thomas

----- Original Message ----
From: Thomas Thurman <email address hidden>
To: <email address hidden>
Sent: Saturday, October 18, 2008 4:44:45 PM
Subject: [Bug 266929] Re: metacity crashed with SIGSEGV in __libc_start_main()

I'm still bewildered. Someone reports a crash in Metacity. Someone
else says he doesn't use Metacity (so what?). And now you point to a
crash in consolekit. I can only see the relevance of the first one.
Sorry if I'm being stupid.

--
metacity crashed with SIGSEGV in __libc_start_main()
https://bugs.launchpad.net/bugs/266929
You received this bug notification because you are a direct subscriber
of the bug.

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Thomas Thurman (marnanel) wrote :

Then this can't be a Metacity problem. Metacity doesn't use ConsoleKit or DBus.

tdflanders (thomasdelbeke) wrote :

Hi Thomas,

That is exactly the problem in fact. If you run dpkg-reconfigure debconf -p low and select text mode and priority low, followed by dpkg-reconfigure -ap low you will get configuration questions of the type: use: 1. unix authentication 2. consolekit 3. likewise 4. ... The choices should be seperated by a space: 1 2 3 If you select everything and then change your /home folder: sudo chmod -cR 777 /home* ; sudo -cR chown -cR 1000 /home/* you will get faulty ~/.dmrc and ~/.dbus settings. Many users will do that because they cannot remove installation files from their home folder through nautilus gui (to save space for instance). If you start: $ sudo nautilus you can change the permissions, but only one by one. I suspect that is the problem. Since your different authentication methods conflict, you experience a wide variety of crashes. To get a backtrace you should start valgrind 'previously crashed process' and then gdb 2>&1 | gdb-<previously_crashed_process>
 and use gdb attach pid (check with pidof or ps -A). The problem is that most crashes are fatal, requiring reboot and which application will crash is unpredictable. I have not been able to backtrace this properly, I am currently searching the proper debug symbols: 'apt-cache search <packagename> | grep "dbg"'. Could you try this out on VirtualBox or VMWare or a dedicated testing machine, or better yet a server with many partitions? It could work, I promise.

----- Original Message ----
From: Thomas Thurman <email address hidden>
To: <email address hidden>
Sent: Saturday, October 18, 2008 5:30:16 PM
Subject: [Bug 266929] Re: metacity crashed with SIGSEGV in __libc_start_main()

Then this can't be a Metacity problem. Metacity doesn't use ConsoleKit
or DBus.

--
metacity crashed with SIGSEGV in __libc_start_main()
https://bugs.launchpad.net/bugs/266929
You received this bug notification because you are a direct subscriber
of the bug.

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Thomas Thurman (marnanel) wrote :

Please, please, please, tell me what this has to do with Metacity. I didn't see a mention of Metacity anywhere in your reply.

tdflanders (thomasdelbeke) wrote :

Hi Thomas,

Metacity is an X Window manager. All applications such as xserver-xorg Xorg gnome-session metacity compiz and such require authorization from PAM or consolekit. In fact I got this very crash twice, once with compiz loop in event ... and another time with only metacity. The crash occured for instance by just '$ x-session-manager' after I head already called '$ sudo <valgrind stuff, see wiki> compiz.

----- Original Message ----
From: Thomas Thurman <email address hidden>
To: <email address hidden>
Sent: Saturday, October 18, 2008 6:29:48 PM
Subject: [Bug 266929] Re: metacity crashed with SIGSEGV in __libc_start_main()

Please, please, please, tell me what this has to do with Metacity. I
didn't see a mention of Metacity anywhere in your reply.

--
metacity crashed with SIGSEGV in __libc_start_main()
https://bugs.launchpad.net/bugs/266929
You received this bug notification because you are a direct subscriber
of the bug.

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Thomas Thurman (marnanel) wrote :

Metacity never does any authentication with anyone, never has, never will. I'm closing this bug; I think you may wish to raise another bug against the session manager, rather than a window manager.

Thomas Thurman (marnanel) wrote :

(Okay, I won't close it, because the apport trace appears to contain a genuine Metacity crash. The comments here don't make much sense to me, though.)

Christophe Dumez (hydr0g3n) wrote :

I'm also experiencing the same problem with metacity in Intrepid release candidate.

Any suggestion to fix this problem?

Christophe Dumez (hydr0g3n) wrote :

X and gnome are running but I have no window manager. Here is the message in dmesg:

[ 622.813587] metacity[7580]: segfault at 0 ip 080abab3 sp bf9c8ff0 error 4 in metacity[8048000+7a000]

Rename .gnome and .gnome2 folders does not solve anything.

Christophe Dumez (hydr0g3n) wrote :

I installed debugging symbols and ran metacity in gdb. Here is the backtrace (message about ui.c looks strange, did I do something wrong?):

(gdb) run
Starting program: /usr/bin/metacity
[Thread debugging using libthread_db enabled]
[New Thread 0xb73509d0 (LWP 12524)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb73509d0 (LWP 12524)]
meta_ui_parse_modifier (accel=0x0, mask=0xbfaf5400) at ui/ui.c:839
839 ui/ui.c: No such file or directory.
 in ui/ui.c
(gdb) bt full
#0 meta_ui_parse_modifier (accel=0x0, mask=0xbfaf5400) at ui/ui.c:839
 gdk_mask = 0
 gdk_sym = 0
#1 0x080746b1 in mouse_button_mods_handler (pref=META_PREF_MOUSE_BUTTON_MODS,
    string_value=0x0, inform_listeners=0xbfaf5444) at core/prefs.c:1381
 mods = <value optimized out>
#2 0x0807592c in meta_prefs_init () at core/prefs.c:550
 err = (GError *) 0x0
 gconf_dir_cursor = <value optimized out>
#3 0x0807226c in main (argc=1, argv=0xbfaf5884) at core/main.c:395
 act = {__sigaction_handler = {sa_handler = 0x1, sa_sigaction = 0x1},
  sa_mask = {__val = {0 <repeats 32 times>}}, sa_flags = 0,
  sa_restorer = 0xbfaf56c4}
 empty_mask = {__val = {0 <repeats 32 times>}}
 log_domains = {0x0, 0x80b48ec "metacity", 0x80b3eab "Gtk",
  0x80b3eaf "Gdk", 0x80b3eb3 "GLib", 0x80b3eb8 "Pango",
  0x80b3ebe "GLib-GObject", 0x80b3ecb "GThread"}

Christophe Dumez (hydr0g3n) wrote :

Here is valgind output, I think it should be more useful.

Christophe Dumez (hydr0g3n) wrote :

I attached apport report (with debug symbols) there: #258074

Thomas Thurman (marnanel) wrote :

Is this actually a dupe of #258074?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.25.8-0ubuntu1

---------------
metacity (1:2.25.8-0ubuntu1) jaunty; urgency=low

  * New upstream release
    - Ignore mouse button modifier if it's missing (Thomas)
      (LP: #258054, LP: #266929)
    - Merge screen and window keybindings files; fix minor alt-tab bug
      in the process (Thomas) (LP: #217989)
  * debian/control.in:
    - Build-dep and Depend on zenity for dialogs
  * debian/rules:
    - Bump shlibs to 2.25.8

 -- Pedro Fragoso <email address hidden> Tue, 25 Nov 2008 12:17:25 +0000

Changed in metacity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers