When Escape is pressed to dismiss Log off/Switch User screen, the desktop stays dimmed

Bug #249803 reported by xrayA4T on 2008-07-18
4
Affects Status Importance Assigned to Milestone
Metacity
New
Low
gnome-session
Invalid
Undecided
Unassigned
gnome-session (Ubuntu)
Undecided
Unassigned
metacity (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I accidentally brought up the Log-off/Lock Screen/ Switch User screen that dims the desktop. I pressed Escape to dismiss it and my desktop was not returned to full brightness. The brightness applet and the Fn-Brightness+ both show that the laptop is set to full brightness. I an running on a Dell Inspiron 6000.
Description: Ubuntu 8.04.1
Release: 8.04

Sebastien Bacher (seb128) wrote :

thank you for your bug report, what videocard and videodriver do you use? do you get the issue every time? that's not likely a GNOME issue but rather an xorg or video driver one

Changed in gnome-session:
importance: Undecided → Low
status: New → Incomplete
xrayA4T (xraya4t) wrote :

Hi, I am not sure where to find the driver in 8.04. I have a intel 910M integrated based chipset. I have noticed that on my machine when I press the green icon to bring up the menu the back ground goes half dark then gets darker rather slowly on my machine. If I press esc straight away it returns fine. If I do it on the second darkening level then it stays dark. I have found if I try to turn on Visual Effects to normal which fails on my machine, it goes back to none but the screen resets to full brightness. The mouse stays bright. It looks like there is an overlay that is dimming the background that is not getting removed.

xrayA4T (xraya4t) wrote :

ok, I have found some extra info. I was unable to replicate the bug with Compiz running, so I switched it off. I was then able to replicate but was unable to switch Compiz back on. In searching for a fix a came across https://bugs.launchpad.net/ubuntu/+source/control-center/+bug/231904 and saw that the key /apps/metacity/general/compositing_manager was indeed selected. By un-checking Metacity as my compositing manager I was able to get Compiz working again. The dimming issue again went away. If I then went to System-Preferences-Appearance-Visual Effects I was able to turn off Compiz and the issue was still fixed. I then went back and re-checked Metacity as my compositing manager and the problem was back. So it looks like an issue with the Metacity compositing manager interacting with the logout manager.

Changed in gnome-session:
status: Incomplete → New
Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I reported this issue upstream, you can track the status and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=551565

Changed in metacity:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in gnome-session:
status: New → Invalid
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Changed in metacity:
status: Unknown → New
Changed in metacity:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.