gtk_window.present() doesn't work if the window is already on another desktop

Bug #213432 reported by Lionel Dricot on 2008-04-07
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Metacity
Invalid
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
metacity (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Intrepid by Lionel Dricot

Bug Description

Very fresh bug in nautilus 1:2.22.1-1ubuntu3 in Hardy. It was not present before the last upgrade so I assume this is an Ubuntu bug, not an upstream one.

To reproduce [disable compiz and use metacity window manager]:

1) Switch nautilus to spatial mode
2) Open a folder XX
3) Change desktop (ctrl+alt+arrow)
4) Try to reopen the same XX folder by clicking on its icon

What happens :

5) Nothing

What should happen :

5) The window XX already opened on the other desktop should switch to the actual desktop. (Like it always did for 4 years of spatial mode)

I don't see any reaction to this bug which seems pretty critical for spatial mode. Is anybody able to at least reproduce this bug ?

Sebastien Bacher (seb128) wrote :

the issue is due to the metacity change to not switch workspaces when open tabs in the firefox version

It appears that this bug causes a lot of problem with some applications like Avant.

In fact, my nautilus spatial is unusable, my collegua cannot use Avant navigator anymore. It seems to also be a problem with the task list applet when you choose to display the windows of all desktops. (see duplicate).

It seems that this bug is severe for all people that rely heavily on the multi-desktop feature.

Carsten Schurig (c-schurig) wrote :

I can confirm, that this bug happens to me as well using compiz. It is pretty annoying, not only for nautilus.

starNIX (ben-pregont) wrote :

I just noticed this pattern, if you are on say, desktop 2 and you have a pidgin window open, then you minimize that window and go to another desktop and choose that window from the tasklist, it doesn't take you back to
desktop 2 and "Un-minimize" that window, which was the old behavior in gutsy. It doesn't unminimize the window at all. If you rightclick the tasks panel in the taskbar, it still offers the option to "Un-Minimize"
that window. No matter how many times you try, it doesn't show you that window and keeps the windows status as minimized. Keep in mind, "Restore to native workspace" is enabled. Does anyone else see this behavior? I am using Metacity.

I just noticed that when I try to alt-tab to a window that's blinking in the window list and that is on another workspace, nothing happens, despite the fact that the window is included in the list. I assume this is another side effect of the patch?

I think that we can honnestly set this bug as "confirmed". I would add that it's a pretty annoying bug IMHO

Changed in metacity:
status: New → Confirmed
dfalk (dfalk) wrote :

Should this bug be reported elsewhere? It hasn't gotten any attention under Metacity, and since it affects compiz (I see it in compiz/intrepid), why not expand the report?

Changed in metacity:
status: Unknown → In Progress
Changed in metacity:
status: In Progress → Fix Released
Pedro Villavicencio (pedro) wrote :

the package containing the fix is already in jaunty, marking this as fixed, thanks for reporting.

Changed in metacity:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Fix Released
sovnarkom (sovnarkom) wrote :

Last jaunty. Does not work.

It doesn't affect Compiz, but it affects Metacity and Avant Window Navigator.

Changed in metacity:
status: Fix Released → Incomplete
Changed in metacity:
status: Incomplete → Confirmed

This problem also happens with mutter.

If I understand correctly, it should be Firefox that should be patched to not "expose" itself when receiving an URL.

My own application (Getting Things GNOME!) is broken and every GTK application that use "gtkwindow.present" will be.

summary: - Open a folder doesn't switch desktop in spatial mode
+ gtk_window.present() doesn't work if the window is already on another
+ desktop

Adding papercut project has it affects the usability of nearly all applications, not just nautilus spatial.

As having multiple desktop is the default, it's annoying to have some applications that doesn't "work" because, in fact, some window are already on another desktop. In the default installation of Karmic, Empathy is affected as you cannot open a conversation if this conversation is already on another desktop.

Could we raise the importance of this bug? gtk_window.present() is used in many applications and breaking all of them for the sake of Firefox is really bad for user experience.

Changed in metacity (Ubuntu):
status: Confirmed → Triaged
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- @Lionel Dricot :
Why was the papercut task opened? this bug was initially opened for nautilus spatial mode not switching desktops when reopening the window. This now works. [thought spatial mode is not the default setup]

What is the bug here now? could you update the bug description accordingly.
[a reminder: papercuts does not have a dedicated team to fix bugs,but only offers design suggestions, patches are welcome]

For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Changed in hundredpapercuts:
status: New → Incomplete

Vish > I reported the bug to papercut because every application that use the gtk.Windows.present() function is affected. That means nearly every gtk applications. I encounter that so often that I don't even remember the applications. (only exception : tomboy, that seems to work around it).

This is a small bug (fix is trivial) that affects metacity (thus the default installation).

Vish (vish) wrote :

@Lionel Dricot : Kindly update the bug description too. [with the steps to reproduce]
is Bug #388866 also a consequence of this change?

To remind again , even if the fix is trivial , someone from the community has to submit the patch...

Changed in hundredpapercuts:
status: Incomplete → New
Omer Akram (om26er) wrote :

upstream bugs marked fixed and If some one face this then please open a new upstream bug and provide us with the link.

Changed in metacity (Ubuntu):
status: Triaged → Incomplete
Changed in hundredpapercuts:
status: New → Incomplete
Vish (vish) wrote :

If no one is interested in this bug can we close it?
There is no upstream bug , and the bug in the description has now been fixed. [though the problem exists elsewhere]

Vish > there's no upstream bug because it's not an upstream bug. It's an ubuntu specific bug that was, AFAIK, introduced for Firefox.

Also, I don't see how the bug has been fixed. I still have the problem.

For me, it should remain open.

Vish (vish) wrote :

argh! I was testing with compiz as WM.

yes , when we set metacity as WM , this is an issue.

@ploum: Not sure why you think this is an Ubuntu specific change though. Is there a mention in the changelog somewhere?

description: updated
Changed in metacity (Ubuntu):
status: Incomplete → Confirmed
Vish (vish) wrote :

Lionel Dricot mentions it is not an upstream bug. Closing the upstream task , which is a bit misleading being marked as fixed.

Changed in metacity:
importance: Unknown → Undecided
status: Fix Released → New
status: New → Invalid

This bug still exists. To reproduce I went into

System -> Preferences -> Appearance -> Visual Effects -> None

Opened Nautilus and went into

Edit -> Preferences -> Behaviour -> Open folders in separate windows

I opened my home folder on desktop #1, and then opened my Music folder contained within. I moved my Music folder to desktop #2 and returned to desktop #1. I attempted to reopen my Music folder by double clicking on it in the window containing my Home folder.

What happened was that the desktop did not switch from #1 to #2, as it should have done.

Lionel, you say that other apps are affected by this. Can you please give examples, complete with steps to reproduce this behaviour?

I think it would be good to get some attention onto this bug, even if it's only long enough to diagnose the cause and record it here. That way, there will be enough information for a developer so come along and have a go at fixing it.

Changed in hundredpapercuts:
status: Incomplete → Confirmed
importance: Undecided → Low

Chris > For example, try Getting Things GNOME (apt-get install gtg). Open a task, move that task to another desktop and try to reopen that task from the main view. Nothing happens.

Other example: gwibber from the MeMenu. Open GWibber on one desktop. Switch to another. From the MeMenu, choose micro-blogging. Nothing happens.

There quite a lot of examples here and there, I could try to list them but I'm not sure it is useful.

Travis Watkins (amaranth) wrote :

This is an upstream bug is is caused by the change made to fix https://bugzilla.gnome.org/show_bug.cgi?id=482354 like you initially thought. The message there says to open a new bug if you disagree with the change so I guess the next step is to open a new upstream bug report.

This was filed against Metacity, which was a part of Gnome 2. Gnome 3 has replaced it with Mutter. Is this still an issue there or is this being caused by another package, GTK+ for example?

Changed in hundredpapercuts:
milestone: none → raring-gtk
Changed in hundredpapercuts:
milestone: raring-gtk → papercuts-s-nautilus
milestone: papercuts-s-nautilus → papercuts-s-gtk
Mörgæs (moergaes) wrote :

Closing because of comment #26 and lack of activity.
If a similar bug appears in 14.04 please open a new report.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in metacity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.