can't alt-tab to dialog

Bug #16755 reported by Noah Levitt on 2005-05-05
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Metacity
Confirmed
Medium
metacity (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

To reproduce:

 1. run gedit
 2. press ctrl+f to open the find dialog
 3. press alt-tab

Now you can't focus the find dialog no matter how many times you press alt-tab.
You have to use the mouse afaik.

Same thing with any dialog in any application, it seems.

http://bugzilla.gnome.org/show_bug.cgi?id=305259: http://bugzilla.gnome.org/show_bug.cgi?id=305259

Sebastien Bacher (seb128) wrote :

I've opened a bug upstream about this:
http://bugzilla.gnome.org/show_bug.cgi?id=303306

Noah Levitt (nlevitt) wrote :

Dude, as I said, it's not just gedit, it's lots of stuff. That's why I said it
was a metacity bug. Most often for me, it's the cookie dialog in firefox. I'll
open a website, it'll be slow to load, I'll alt-tab to something else, and when
I come back I have to use the mouse to close the cookie dialog that has popped
up. (I have cookies set to ask me every time.) Prefs dialog in gnome-terminal,
prefs dialog in rhythmbox, same thing. I think it's any window that's "transient
for" another window, but not modal. It's not a bug to have such a window in your
app, it's a bug in metacity not to be able to alt+tab to it. (I reported the bug
here because I haven't checked if it's fixed upstream.)

Sebastien Bacher (seb128) wrote :

(In reply to comment #2)
> That's why I said it was a metacity bug.

Upstream have this bug open on gedit. I'm not sure that's a window manager
issue, that works fine with other applications which use a modal dialog. That
could be a gtk bug too.
Anyway if you know what you are doing the right place to go with your bug is
upstream, not a distribution bugzilla, since the bug is an upstream one.

Anyway http://bugzilla.gnome.org/show_bug.cgi?id=303148 which is already open
upstream is on gedit for the moment so I keep the bug here to reflect that. The
package here doesn't matter since the bug will be solved upstream.

> app, it's a bug in metacity not to be able to alt+tab to it. (I reported the bug
> here because I haven't checked if it's fixed upstream.)

I'm not convinced that's not a gtk issue...

Sebastien Bacher (seb128) wrote :

thanks for the upstream bug. You should rather reassign/comment on the bug to
say to reassign than opening a new bug though

Noah Levitt (nlevitt) wrote :

Oh yeah, you're right, sometimes I forget the conventions...

Changed in gedit:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

window manager issue

Changed in gedit:
status: Unconfirmed → Unknown
assignee: seb128 → desktop-bugs
importance: Medium → Low
Changed in gedit:
status: Unknown → Confirmed
sam tygier (samtygier) wrote :

This and bug #57028 both link to the same upstream bug. it seems that they are different issues but being handeled together upstream.

This is still a problem in Gutsy, though the upstream workaround (alt-tab to the application, then alt-F6 to switch to the foregrounded modal dialog) works.

Changed in metacity:
status: Confirmed → Triaged
Martin Emrich (emme) wrote :

I just tried this in karmic, and it works now as expected: The "Find" dialog is a window on its own and can be accessed via Alt-Tab. IMHO this could be marked as Fix Released.

Martin Emrich (emme) wrote :

Forgot to mention: I am using compiz now, so It seems to be unrelated to gedit.

sam tygier (samtygier) wrote :

i still have the issue using metacity, so i dont think it is fixed.

Changed in gedit:
importance: Unknown → Medium
Alan Jenkins (aj504) on 2011-08-19
affects: gedit → metacity
sam tygier (samtygier) wrote :

Still happens with the Open dialog in gedit (the find dialog is no long a separate window). Added Compiz, because thats the window manager now.

sam tygier (samtygier) wrote :

My bad. You can use Alt+` (key above tab) to get to the dialog in compiz.

Changed in compiz:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.