Ubuntu

Cannot change the resize button

Reported by aGeorgo on 2007-11-13
12
Affects Status Importance Assigned to Milestone
metacity
Fix Released
Wishlist
metacity (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: metacity

Metacity (2.20.0-0ubuntu3) allows user to move or resize the window by holding the "Movement key" (control/alt/super) and one of mouse buttons. Button1 is mapped to move window, button2 to the window resize and button3 to display popup menu. This functionality is hardcoded and if user has only two button mouse he has to emulate the resize button by clicking left+right mouse button, which is not really easy to do. These buttons behavior should be configurable, at least for resize window button and popup menu.
I propose a boolean flag "/apps/metacity/general/mouse_button_swap_behaviour" which will swap the button2 and button3 behaviour if is set to true.

aGeorgo (ageorgo) wrote :

I am also including patch for this functionality, which I use to create my customized metacity package.

Changed in metacity:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
Bartek Celary (karaphka) wrote :

Will this patch be included in the official release? It is something that should have been done ages ago... (IMHO).

aGeorgo (ageorgo) wrote :

I am not sure, I would say... probably no. In bugzilla.gnome.org I found bug id 437910 ("Add the ability to select the mouse button for resize while pressing alt") even with a patch which obviously does something similar. This is the reason why I proposing change to Ubuntu package - they are more responsive to changes that users may find usable.

Sebastien Bacher (seb128) wrote :

Thank you for your bug, no need to open upstream bugs which area already known on bugzilla to launchpad though

Changed in metacity:
status: New → Triaged
aGeorgo (ageorgo) wrote :

Yes I agree, unfortunately I checked before my initial post only bugs in launchpad not in the upstream bugzilla.

Changed in metacity:
status: Unknown → New
Jonathan Amir (jonathan-amir) wrote :

I agree with this bug. I think this is a sore point in metacity that should have been fixed a long time ago.

Changed in metacity:
status: New → Confirmed
Changed in metacity:
status: Confirmed → In Progress
Thomas Thurman (marnanel) wrote :

Patch provided upstream.

Changed in metacity:
status: In Progress → Fix Released
Changed in metacity:
status: Triaged → Fix Committed

This should be fixed in Jaunty now. Thanks for reporting.

Changed in metacity:
status: Fix Committed → Fix Released
Changed in metacity:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.