SRU: metacity 3.18.7

Bug #1615762 reported by Dmitry Shachnev on 2016-08-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

I would like to update Xenial version of Metacity to a new upstream microrelease, 3.18.7.

We already have 3.18.5 in Xenial-updates. Upstream changelog since that is (with comments and links added by me):

Version 3.18.7
==============
- Fix titlebar repaint (https://bugzilla.gnome.org/show_bug.cgi?id=769049)
  Details of this issue are available in upstream bug report, I will only add that it happens with modesetting driver on Intel graphics.

- Fix a small memory leak in compositor

Version 3.18.6
==============
- Fix window resizing using titlebar (LP: #1596574)
  This was already cherry-picked in 1:3.18.5-0ubuntu0.1 package.

- Small HiDPI support improvements (https://bugzilla.gnome.org/show_bug.cgi?id=746420)

- Fix crash when removing a secondary monitor (https://bugzilla.gnome.org/show_bug.cgi?id=766156)
  Details of this issue are available in upstream bug report.

This package has been uploaded to ppa:ubuntu-gnome-flashback/unstable, the build logs are available from there too. A debdiff is available at http://people.ubuntu.com/~mitya57/tmp/metacity_3.18.7-0ubuntu0.1.debdiff.

Regression potential: the fixes are minimal so should not cause any regressions.

All fixes in this release are applied also in 3.20.3, which is available in Yakkety.

Changed in metacity (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in metacity (Ubuntu Xenial):
status: New → Confirmed
description: updated

Hello Dmitry, or anyone else affected,

Accepted metacity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/metacity/1:3.18.7-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in metacity (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed

Just upgraded metacity on my laptop:
- Titlebar redraw bug is fixed
- HiDPI also works better

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for metacity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:3.18.7-0ubuntu0.1

---------------
metacity (1:3.18.7-0ubuntu0.1) xenial; urgency=medium

  * New upstream bugfix release (LP: #1615762).
  * Drop titlebar_resize.diff, applied in the new release.

 -- Dmitry Shachnev <email address hidden> Wed, 24 Aug 2016 21:30:57 +0300

Changed in metacity (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers