Cannot resize window by dragging the top edge

Bug #1596574 reported by Cui Wei on 2016-06-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

[General information about the SRU]
* It includes fix for bug 1582687 which was already backported.
* It fixes bug 1509031, bug 1592953 and bug 1596574.
* Other commits are minor bugfixes, the full log can be seen here:
  https://git.gnome.org/browse/metacity/log/?h=3.18.5
* There is also a NEWS file, here:
  https://git.gnome.org/browse/metacity/tree/NEWS?h=3.18.5

[Impact]
This affects only users of Metacity with compositing mode disabled (which are usually users on old hardware or virtualized systems).

[Test Case]
* gsettings set org.gnome.metacity compositing-manager false;
* Try resizing a window by dragging its top edge.

[Regression Potential]
The fix is one-line and should not cause any regressions.

-----------------------------------------------------------------------------

Bug Version: 1:3.18.4-0ubuntu0.3

Metacity running without composite manager.

Users cannot resize window by dragging its top edge.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: metacity 1:3.18.4-0ubuntu0.3
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
Uname: Linux 4.4.0-24-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: GNOME-Flashback:Unity
Date: Mon Jun 27 23:18:31 2016
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
SourcePackage: metacity
UpgradeStatus: No upgrade log present (probably fresh install)

Cui Wei (ghostplant) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:3.18.5-0ubuntu1

---------------
metacity (1:3.18.5-0ubuntu1) yakkety; urgency=medium

  * New upstream bugfix release.
  * Drop all previous patches, applied upstream.
  * Add a patch from upstream to restore window resize using titlebar
    (titlebar_resize.diff, LP: #1596574).

 -- Dmitry Shachnev <email address hidden> Mon, 27 Jun 2016 20:47:59 +0300

Changed in metacity (Ubuntu):
status: New → Fix Released
description: updated
description: updated
Cui Wei (ghostplant) wrote :

Yes, metacity in Xenial doesn't get updated.

Hello Cui, or anyone else affected,

Accepted metacity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/metacity/1:3.18.5-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in metacity (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Dmitry Shachnev (mitya57) wrote :

Cui Wei, can you please verify that this bug is fixed in the proposed version?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:3.18.5-0ubuntu0.1

---------------
metacity (1:3.18.5-0ubuntu0.1) xenial; urgency=medium

  * New upstream bugfix release.
    - Fixes issues with windows not being destroyed after drag and drop
      (LP: #1592953).
    - Fixes issues with moving windows above top of screen (LP: #1509031).
  * Drop fix_xerror_in_free_win.diff, applied upstream.
  * Add a patch from upstream to restore window resize using titlebar
    (titlebar_resize.diff, LP: #1596574).

 -- Dmitry Shachnev <email address hidden> Tue, 28 Jun 2016 15:32:39 +0300

Changed in metacity (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers