Ubuntu

Maximize window vertically makes the window too large

Reported by Pádraig Brady on 2007-10-11
10
Affects Status Importance Assigned to Milestone
metacity
Invalid
Unknown
metacity (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: metacity

Note compiz (desktop effects) is not on (there are too many bugs to mention with that).

Bind a key to maximize vertically.
Just after boot it does work, but "after a while",
windows maximized vertically go the whole way
to the bottom of the screen, under the bottom panel.

Pádraig Brady (p-draigbrady) wrote :

Sorry, I thought I'd get prompted for version info.

This is with gutsy tribe 4 I think with no updates.
metacity version is 1:2.19.55-0ubuntu1

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Do you use a dualscreen configuration? That looks like bug #120818

Changed in metacity:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pádraig Brady (p-draigbrady) wrote :

I have a single screen.
Note maximize and toggle maximize are fine for me.
Just maximize vertically exhibits this behaviour.

Sebastien Bacher (seb128) wrote :

not confirming on a gutsy installation, to send upstream by somebody getting the bug

Changed in metacity:
status: Incomplete → New
Simon Ruggier (simon80) wrote :

I can confirm in gutsy. Using "Maximize window horizontally also results in the window being maximized both ways sometimes. This is a pretty severe regression from 2.18, both of these shortcuts are basically unusable.

Changed in metacity:
status: New → Confirmed
Changed in metacity:
status: Unknown → Invalid
Changed in metacity:
status: Invalid → New
bf12 (hanshin-cho) wrote :

same Bug in Hardy.

dpc22 (dpc22) wrote :

I can confirm this bug in Gutsy, and it seems to be worse in Heron (where the problem starts immediately after login, rather than after a day or two).

This is on three different systems (two desktops and a laptop). No dual screen is involved on any of those machines.

Workaround: Set the panel to autohide.

My guess is that Maximize window vertically starts to believe that autohide is enabled, and sizes the window accordingly.

Tomislav (hefest) wrote :

I can confirm the same behaviour.
I'm also not sure it's a duplicate, because other issues are Xinerama related and this one is not.

Changed in metacity:
status: New → Incomplete
Changed in metacity:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.