metacity no longer honors keybindings without modmask?

Bug #1459128 reported by Don Hatch on 2015-05-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Undecided
Unassigned

Bug Description

I'm extremely attached to the following two keybindings:
    $ dconf read /org/gnome/desktop/wm/keybindings/raise
    ['F1']
    $ dconf read /org/gnome/desktop/wm/keybindings/lower
    ['F2']
But they stopped working for me in metacity 2.34.13.
(That is, I hit F1/F2 expecting the window under the mouse cursor
to be raised/lowered respectively, and it doesn't happen.)

When I run `METACITY_VERBOSE=1 METACITY_USE_LOGFILE=1 metacity --replace`
and install my keybindings:
    $ dconf write /org/gnome/desktop/wm/keybindings/raise "['F1']"
    $ dconf write /org/gnome/desktop/wm/keybindings/lower "['F2']"
I notice the following appears in the log file:
    KEYBINDINGS: Will not grab keybinding F1 without modmask.
    KEYBINDINGS: Will not grab keybinding F2 without modmask.
If I then try installing similar bindings with a modmask:
    $ dconf write /org/gnome/desktop/wm/keybindings/raise "['<Shift>F1']"
    $ dconf write /org/gnome/desktop/wm/keybindings/lower "['<Shift>F2']"
no such log message occurs, and the modified keybindings work!

When I searched for that log message on the web, it led to this
recent commit and bug reference:
    https://mail.gnome.org/archives/commits-list/2015-April/msg01612.html
    https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/1440570
Note however that this bug seems to refer to VNC, which I am not using.

So is it the case that F1/F2, unmodified,
can no longer be keyboard shortcuts?
This would make me very sad, since I've used them several thousand times per
day for the last 25 years or so, and I'm not sure I can rewire my fingers
at this point.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1459128/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Don Hatch (donhatch) on 2015-05-27
affects: ubuntu → metacity (Ubuntu)

Yes, this is regression. :( Patch should be reverted, but I have not done it upstream yet.

please, please, please, revert this! I also noticed this change when going from 1:2.34.13-0ubuntu4 to 1:2.34.13-0ubuntu4.1. For me, the function keys change between workspaces. When some programs, such as an xterm, have the mouse focus, they steal the definitions of the function keys. Other programs, and the background don't.

Likewise, after many, many years of using these shortcuts (long predating ubuntu or metacity), my aged brain cannot rewire itself. For the sake of necessity, I tried converting to alt-Fn instead of Fn, but my fingers get confused most of the time, and it seriously affects my workflow.

One should definitely be able to assign the Fn keys as desired - user level preferences should always override the app defaults.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers