Alt+F2 run dialog not available any more

Bug #1299784 reported by Oliver Gerlich on 2014-03-30
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Medium
Dmitry Shachnev
Trusty
Medium
Unassigned

Bug Description

In Ubuntu 14.04 beta with Gnome Flashback session with Metacity, the Alt+F2 keyboard shortcut doesn't work anymore. Previously it could be used to open a small Run dialog.

Also, in Ubuntu 12.04 this could be configured in System Settings -> Keyboard -> Shortcuts -> System -> "Den Befehl ausführen-Dialog anzeigen" (German for "show the Execute Command dialog"). This is no longer possible; the System category doesn't show any such item any more in 14.04.

I would expect that ideally the Alt-F2 shortcut works out of the box when starting the Gnome Flashback (Metacity) session, or that it at least can be enabled/configured manually.

This is with Ubuntu 14.04 beta (x86_64), in Virtualbox, with gnome-panel 1:3.8.0-1ubuntu10.

Oliver Gerlich (ogerlich) wrote :

Found the dconf setting which makes this available again (org.gnome.desktop.wm.keybindings.panel-run-dialog). For some reason it was set to ['disabled'] on my test system - no idea why. Setting it back to its default value makes Alt+F2 show the Run dialog again.

So this bug report is now merely about making this available by default, or making it configurable in GUI. Also, might be useful as reference for others having the same problem :-)

Dmitry Shachnev (mitya57) wrote :

At least one of (gnome-control-center, unity-control-center) should provide an ability to configure that. Which one are you using?

Also, the wrong default value looks like bug 856884.

Oliver Gerlich (ogerlich) wrote :

Tried unity-control-center, gnome-control-center and gnome-control-center.real. The last one doesn't even show a Keyboard item; the other ones have the Keyboard item but in Keyboard -> Shortcuts -> System there is no item for configuring the Run Dialog shortcut.

Btw. I noticed that /usr/bin/gnome-control-center checks the $XDG_CURRENT_DESKTOP env var; but interestingly it's always set to "Unity", no matter whether I start Gnome Flashback (Metacity), Gnome Flashback (Compiz) or Unity. Is that intended?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

To get the keybinding working, see comment 1. I will make sure the control center has the setting in right place.

Changed in gnome-panel (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
affects: gnome-panel (Ubuntu) → metacity (Ubuntu)
Changed in metacity (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Changed in metacity (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:3.12.0-1ubuntu1

---------------
metacity (1:3.12.0-1ubuntu1) utopic; urgency=medium

  * Merge with Debian unstable (LP: #1347992), remaining changes:
    - 05_raise_on_click_for_click_mode.patch:
      + Force raise on click option.
    - 20_do-not-place-windows-over-the-launcher.patch:
      + Do not initially position windows over the launcher.
    - 103_struts_in_the_middle.patch:
      + Add support for struts in the middle of the work area.
    - 104_workarea_union.patch:
      + Make the workarea be the union of available work areas,
        not only one.
    - 22_fix_above_tab_switching.patch:
      + For Above_Tab, don't compare keysym (fixes group switching).
    - Use Ubuntu Desktop team Vcs fields.
  * Drop all other patches. Half of them have been applied upstream,
    others were only needed for Unity 2D and are no longer needed.
  * debian/metacity-common.links:
    - Show keybindings in Unity control center (LP: #1299784).

metacity (1:3.12.0-1) unstable; urgency=medium

  * New upstream release (closes: #751683).
    - Ported to Gtk+ 3.
    - Compositing manager is now enabled by default.
    - Adds support for Ubuntu themes (closes: #610936).
  * Drop all patches, applied upstream.
  * Build-depend on libgtk-3-dev and libcanberra-gtk3-dev.
  * Rename libmetacity-private0a to libmetacity-private-1,
    following upstream soname bump.
  * Add symbols file for libmetacity-private-1.
  * Remove duplicate Section field, add Homepage field.
  * Build with dh-autoreconf.
  * Run wrap-and-sort.
  * Update debian/copyright.
  * Bump Standards-Version to 3.9.5, no changes needed.

metacity (1:2.34.13-1) unstable; urgency=low

  * New upstream release.
  * Remove 10_leak.patch, merged upstream.
  * Port to new documentation infrastructure. Use yelp-tools instead of
    gnome-doc-utils.
  * Bump Standards-Version to 3.9.4. No further changes.

metacity (1:2.34.3-4) unstable; urgency=low

  * Cherry-pick some upstream patches.
    + 10_leak.patch: small memory leak.
    + 11_remove_thumbnails.patch: remove the code to make thumbnails of
      active windows. It is too slow. Closes: #696323.
    + 12_icons_96px.patch: use 96x96 icons by default.
 -- Dmitry Shachnev <email address hidden> Fri, 01 Aug 2014 08:55:34 +0200

Changed in metacity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers