Metacity keyboard shortcuts work intermediately

Bug #1070285 reported by david kochner on 2012-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
metacity (Ubuntu)
Undecided
Unassigned

Bug Description

Hello.
I am not sure if Metacity is indeed the culrpit here, but this doesn't happen with compiz so I assume it is.

When I configure a custom shortcut to exectute a command (for example: xterm with alt+x), Pressing alt+x doesn't always work and when it does work it normally requires quite a long press.
This is very different than the behaviour in gnome/metacity up to Ubuntu 11.04 which executed my configured application the moment I pressed the key combination.
In ubuntu 12.04 I managed to work around it by changing the default terminal to xterm and setting the "launch terminal" shortcut to alt-x, other keyboard shortcuts I had were still sluggish but at least my run terminal shortcut worked.
In ubuntu 12.10 it stays sluggish no matter what I do and in many cases it simply "misses" my alt+x keypress

The odd part is that any other shortcut I set (changing window size, etc...) works fine in a snap, only applications executions are running slow.

Basically it used to launch in a snap and now it simply doesn't.
Happens on any installation I have (about 5 different machines, one freshly installed in a VM just to see that it's not an upgrade issue).

I tried it with a new fresh user just to make sure I don't have old configurations that conflict with it and it is still sluggish.

Not a critical bug but it is a very annoying regression.

Thanks,
Dave.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: metacity 1:2.34.8-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Tue Oct 23 12:06:57 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: metacity
UpgradeStatus: Upgraded to quantal on 2012-10-22 (0 days ago)

david kochner (david-kochner) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers