ati 9200SE, DVI, vesa, KDE4 crashes on login

Bug #246557 reported by Risto H. Kurppa on 2008-07-08
4
Affects Status Importance Assigned to Milestone
meta-kde4 (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running Hardy. I have both KDE 3.5.9 and KDE 4.0.1 beta 2 (see http://kubuntu.org/announcements/kde-4.1beta2.php) installed.

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)

Connected using a DVI cable. fglrx drivers don't support this card any more so I'm using vesa driver in xorg.conf.

KDE3 works fine (though no hardware acceleration)
KDE4 lets me login, loads it's stuff but then kicks me out without warning. When KDE4 is loading, the screen is smaller than it should be (15" 4:3 monitor, some 3 cm from the right edge is black, the picture is aligned on the left) and has lines and is grayscaled.

I'll try to post xorg.log soon.

There are some other bugs for this card using DVI, see https://bugs.freedesktop.org/show_bug.cgi?id=2859 (and the monitor I have only supports DVI..)

Risto H. Kurppa (risto.kurppa) wrote :

So again I tried to login to get the logs: The KDE login screen where the icons appear when stuff is loaded is OK, nice correct size screen & resolution and everything, but when that screen disappears, is the screen size shifted and colors lost. So actually attaching xorg.log might be useless but anyway..

Risto H. Kurppa (risto.kurppa) wrote :
description: updated
Risto H. Kurppa (risto.kurppa) wrote :

I downloaded and installed latest ati drivers from https://launchpad.net/~tormodvolden/+archive, installed and tried with no success. Even the KDM is messed up, I only see big blue squares jumping around the screen.. see logs:

Risto H. Kurppa (risto.kurppa) wrote :

xorg.log for new ati driver

Risto H. Kurppa (risto.kurppa) wrote :

One log more: I added the resolution information (1024x768) in the xorg.conf and restarted KDM, using now the new ati drivers. It recognizes the resolution correctly (1024x768) but then shows '(II) RADEON(0): Output DVI-0 using initial mode 1280x800' anyway.

so I was able to start it with this setup. KDM was unreadable but I was able to type in the password and log in. KDE 3 started with correct resolution but the screen was a mess: a lot of lines running along the screen..

Jouni Mettala (jouni-mettala) wrote :

Is this related to bug 182599 or even duplicate?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers