Ubuntu

gnustep-devel missing dependencies - cannot install

Reported by Tyler Burton on 2010-05-13
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
meta-gnustep (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gnustep-devel

Cannot install gnustep-devel in *ubunutu 10.04 because it claims to need gorm.app but that package is not in the repo.

The error occurs in KPackageKit as well as when using the command line.

When running "apt-get install gnustep-devel" it generates the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
  gnustep-devel: Depends: gorm.app but it is not installable
E: Broken packages

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnustep-devel (not installed)
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed May 12 22:11:48 2010
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427)
ProcEnviron:
 LANGUAGE=
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: meta-gnustep

Ricardo Bánffy (rbanffy) wrote :

amd64 flag must be removed. Happened with me on a 32-bit machine.

Ricardo Bánffy (rbanffy) wrote :
Download full text (15.3 KiB)

Going a little deeper, I tried to compile it from source with no success. Here's what I got. I hope it helps.

ricardo@adams:~/apagueme_gorm$ apt-get source gorm.app
Reading package lists... Done
Building dependency tree
Reading state information... Done
Need to get 669kB of source archives.
Get: 1 http://us.archive.ubuntu.com/ubuntu/ lucid/universe gorm.app 1.2.8-1 (dsc) [1,158B]
Get: 2 http://us.archive.ubuntu.com/ubuntu/ lucid/universe gorm.app 1.2.8-1 (tar) [663kB]
Get: 3 http://us.archive.ubuntu.com/ubuntu/ lucid/universe gorm.app 1.2.8-1 (diff) [5,007B]
Fetched 669kB in 6s (101kB/s)
gpgv: Signature made Fri 15 May 2009 11:17:13 PM BRT using DSA key ID 124B61FA
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./gorm.app_1.2.8-1.dsc
dpkg-source: info: extracting gorm.app in gorm.app-1.2.8
dpkg-source: info: unpacking gorm.app_1.2.8.orig.tar.gz
dpkg-source: info: applying gorm.app_1.2.8-1.diff.gz
dpkg-source: info: upstream files that have been modified:
 gorm.app-1.2.8/Documentation/Gorm.texi
ricardo@adams:~/apagueme_gorm$ cd gorm.app-1.2.8/
ricardo@adams:~/apagueme_gorm/gorm.app-1.2.8$ dpkg-buildpackage -b -uc
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package gorm.app
dpkg-buildpackage: source version 1.2.8-1
dpkg-buildpackage: source changed by Gürkan Sengün <email address hidden>
dpkg-buildpackage: host architecture i386
 fakeroot debian/rules clean
dh_testdir
dh_testroot
rm -f build-stamp
gs_make -C Documentation clean distclean
This is gnustep-make 2.2.0. Type 'make print-gnustep-make-help' for help.
make[1]: Entering directory `/home/ricardo/apagueme_gorm/gorm.app-1.2.8/Documentation'
rm -rf ./*~ ./obj
Making clean for doc Gorm...
Making clean for textdoc README...
Making clean for textdoc NEWS...
Making clean for textdoc INSTALL...
Making clean for textdoc ANNOUNCE...
rm -f *.bak *.cl *.fns *.pr *.log
rm -f version.texi
rm -rf InterfaceBuilder
rm -rf GormCore
rm -rf GormPrefs
rm -rf GormObjCHeaderParser
Making distclean for doc Gorm...
make[2]: Nothing to be done for `internal-doc-distclean'.
Making distclean for textdoc README...
make[2]: Nothing to be done for `internal-textdoc-distclean'.
Making distclean for textdoc NEWS...
make[2]: Nothing to be done for `internal-textdoc-distclean'.
Making distclean for textdoc INSTALL...
make[2]: Nothing to be done for `internal-textdoc-distclean'.
Making distclean for textdoc ANNOUNCE...
make[2]: Nothing to be done for `internal-textdoc-distclean'.
make[1]: Leaving directory `/home/ricardo/apagueme_gorm/gorm.app-1.2.8/Documentation'
gs_make clean distclean
This is gnustep-make 2.2.0. Type 'make print-gnustep-make-help' for help.
make[1]: Entering directory `/home/ricardo/apagueme_gorm/gorm.app-1.2.8'
rm -rf ./*~ ./obj
Making clean in GormObjCHeaderParser...
rm -r...

chengyan (chengyan-cy) wrote :

1. goto http://www.archive.ubuntu.com/ubuntu/pool/universe/g/gorm.app/
2. download
 gorm.app_1.2.10-1_amd64.deb
or
 gorm.app_1.2.10-1_i386.deb
3. install the package which you downloaded
4. retry install gnustep-devel package

Tyler Burton (tylerburtonca) wrote :

Yes that will work but it's not a fix, simply a work-around.

Philip Muškovac (yofel) wrote :

gnustep-devel is installable again in maverick as gorm.app is back. I'll ask around to see what happened to it in lucid.

Changed in meta-gnustep (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Philip Muškovac (yofel) wrote :

Fixed the build failure in lucid and filed bug 616498 for a SRU which should make it installable in lucid agian.

Tyler Burton (tylerburtonca) wrote :

Awesome, I'm glad to hear that the fix is also making its way back to lucid.

Philip Muškovac (yofel) wrote :

with gorm.app available in lucid-updates you can install gnustep-devel in lucid again. Gorm sadly doesn't work though thanks to bug 535044. That nees to be looked at by someone else.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers