maximize/minimize/close buttons are on wrong side of titlebar

Bug #533556 reported by jerkface on 2010-03-06
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
meta-gnome2 (Ubuntu)
Undecided
Unassigned

Bug Description

1) $ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

2) About Gnome Version 2.29.91

3) When I open a window, I expect these buttons to appear at the top-right corner of the window.

4) When I open a window, the buttons appear on the top-left corner.

Mitch Towner (kermiac) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 532633, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

As stated in bug 532633: Please see https://wiki.ubuntu.com/Brand#New%20GtkThemes. This is design decision. Also see this changelog http://changelogs.ubuntu.com/changelogs/pool/main/l/light-themes/light-themes_0.1.5.4/changelog

Changed in meta-gnome2 (Ubuntu):
status: New → Invalid

I think this is an active choice by the ubuntu developers.

It might be a bug because:
  1. It's not the existing behavior, and I'm not sure that a left alignment is an improvement for most ubuntu users (it may be and improvement for readers of left to right languages though, assuming they have not used windows, gnome or kde previously.).

 2. The most used button [x] is not on a corner and is thus less accessible. Many users will double click on the title bar to maximize, so it probably doesnt deserve the corner position.

 3. The concave look is terrible with windows that don't have a maximize button. For an example open gnome-calculator.

summary: - maximize/minimize/close buttons are on wrong side of titlebar
+ [Master] maximize/minimize/close buttons are on wrong side of titlebar
Changed in meta-gnome2 (Ubuntu):
status: Invalid → Confirmed

Workaround:

gconf-editor
select apps > metacity > general.
edit the button_layout key.

set the value to menu:maximize,minimize,close

Mitch Towner (kermiac) wrote :

As stated above. This *IS* a design decision. There is no point keeping many different bug reports open for this issue. Please continue any discussion in bug 532633 or on the relevant mailing list.

summary: - [Master] maximize/minimize/close buttons are on wrong side of titlebar
+ maximize/minimize/close buttons are on wrong side of titlebar
Yann (lostec) wrote :

This is a STUPID design decision... that will lead to errors/loss of ergonomy/productivity... and hence can be nammed a "bug".

But if you know any other way that lanchpad to attract ubuntu design team attention for the big mistake they are making, please let us know...

Maybe reading ubuntu forums around the world sreaming about this issue would be useful!

First Ubuntu LTS (6.06) was a very good version... 8.04 still have bugs 2 years after (Intel wifi, pulse audio, acpi/pm-utils...) and have been Canonical's Vista...

Now 10.04 playing with 20 years of users habits!

Wow... if you want to loose any credibility in 6 months, go ahead: I don't know any sysadmin wanting this kind of change to hear users screaming and trigger loss of productivity...

Even home users that almost always have to keep windows habits at their office don't want this at home.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers