Ubuntu

[Patch upstream] Dual Monitor wallpaper is not scaling across both monitors, same background is repeated on both monitors instead

Reported by George Standish on 2010-02-13
386
This bug affects 73 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Confirmed
Low
gnome-control-center (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Paul Kishimoto
meta-gnome2 (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Paul Kishimoto

Bug Description

On all other Ubuntu/Gnome versions you can use a wallpaper sized for dual-monitor and it will span across both monitors, currently the same wallpaper is being repeated twice, once on each monitor.

Appears to be https://bugzilla.gnome.org/show_bug.cgi?id=603551 regarding scaling wallpaper across dual monitors

If Nautilus' wallpaper manager is replaced by Compiz's, the wallpaper scales correctly.

ProblemType: Bug
Architecture: amd64
Date: Sat Feb 13 14:45:06 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
NonfreeKernelModules: nvidia
Package: gnome (not installed)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
SourcePackage: meta-gnome2
Uname: Linux 2.6.32-13-generic x86_64

Anton Kraus (done) wrote :

There is upstream discussion about a patch that brings back this functionality at https://bugzilla.gnome.org/show_bug.cgi?id=609809

Said patch is attached to the first post there.

Using the following command will restore old wallpaper behaviour, until the next time you open Appearance Preferences / Background:

gconftool-2 --set "/desktop/gnome/background/picture_options" --type string "spanned"

Anton Kraus (done) wrote :

The gconf-workaround is no longer needed. Lucid's gnome-appearance-properties has caught up and now allows a "span" option.
So the bug is fixed :)

Changed in meta-gnome2 (Ubuntu):
status: New → Fix Released
Omer Mano (mermerico-gmail) wrote :

This bug is not fixed because the original behavior was not restored. The span feature puts the image in the middle of the two monitors, but does not stretch across both monitors.

Changed in meta-gnome2 (Ubuntu):
status: Fix Released → In Progress
Xsoldier2000 (xsoldier2000) wrote :

Have to agree with Omer, the wallpaper does not stretch across both monitors, just sets the wallpaper in the middle of both monitors with a selected backgound color at the edge of the wallpaper.

Tried all options, Span, Stretch, Zoom....

Paul Kishimoto (khaeru) wrote :
Paul Kishimoto (khaeru) wrote :

The above "Screenshot.png" shows the result when this image (from the *excellent* sxc.hu) is applied with the "Span" setting.

The image is 3264 × 2448.
The monitors are 1024 × 1280 (left) and 1280 × 1024 (right).
The desktop is 2304 (=1280 + 1024) × 1280.

Observed:
"Scale" — The entire image fits on each *monitor*. On the left, scaled to 1024 px wide. On the right, scaled to 1280 px wide.
"Zoom" — The image fills each *monitor*. On the left, scaled to 1280 px high. On the right, scaled to 1024 px high.
  (i.e. "Scale" shrinks a large image *more* than "Zoom")
"Span" (shown) — The entire image fits on the *desktop*; scaled to 1028 px high and centred across both *monitors*. Analogous to "Scale".

Expected:
"Span" — The image fills the entire *desktop*; scaled to 2304 px wide and centred across both *monitors*. Analogous to "Zoom".

As far as I can tell, there is no way to accomplish the latter. This is a regression.

Paul Kishimoto (khaeru) on 2010-04-11
Changed in meta-gnome2 (Ubuntu):
status: In Progress → Confirmed
Grant Tremblay (granttremblay) wrote :

Agreed with Paul, Omer, and others.

The bug is not fixed as the original/correct behavior has not been restored.

The "span" option should work as the name implies, and fill the entire desktop, scaling as appropriate.

Brian Parma (bj0) wrote :

An alternative is to make a 'span' checkbox that switches between treating each monitor separately or as one monitor, that way you can have any combination you want (span+zoom, span+stretch, etc). I personally liked to use the 'zoom' feature before with the image spanning both monitors.

Steve Withers (truthseekernz) wrote :

Looks like some people with laptops who occasionally connect a second screen decided the behaviour of centering the image on EACH screen was the way to go. I have two permanently-connected monitors and I want to be able to scale / span the one image across both of them.

I could do this in Karmic easily and simply. I can't do it all in Lucid Lynx. Given I have two large screens i spend a lot of time looking at, this regression / "fix" is very much in my face.

Steve Withers (truthseekernz) wrote :

Reading some of the other comments, I went into the Change Desktop Background dialog / window. I tried the various options for each image there. I found that when I set a 2560x1024 image to "Span", then the one image DOES span across BOTH screens. But all images I have used were previously set to "Stretch", which now sees them repeated on each screen, not stretched across both.

So I can get one image to span both screens provided I go through the list of images (I have several dozen 2560x1024 wallpapers) and reset EACH one to "Span" from "Stretch".

So this now works, but the setting has been altered from Stretch to Span and the effect was to - apparently - break it.

Paul Kishimoto (khaeru) wrote :

Steve, do you have two 1280 × 1024 monitors arranged side-by-side? If so, then you are lucky that your particular images happen to fill your particular desktop *without needing any scaling*.

If you use GIMP or another program to scale one of those images (double the dimensions to 5120 × 2048; or halve them to 1280 × 512) and try to set the resulting file as your wallpaper, you will see the problem we are discussing.

Ioky (iokxp) wrote :

I think the "span" option is pretty pointless. unless you have the exact resolution wallpaper as both of your screen you have. Or else you will just have a random image in the middle of two monitors. forget about the ideal solution, which is be able to set wallpaper in any variant. But at least for me. Span should be "Span and Stretch" to fit across both of the monitor. I mean a silly work around is use GIMP to resize the wallpaper you want to put into the exact total screen solutions. Just like the patch trying to do. but I have no idea how to patch at the moment.

I am new here, but will it be fix?

Telescope_Nerd (srb2242) wrote :

Confirm I am missing the span+zoom option also, is there a workaround? my dual-screen desktop looked much nicer in 9.10.

schuelaw (schuelaw) wrote :

Mostly just want to confirm this problem. I have two monitors of different sizes and in 8.10 the background just stretched across both screens and filled them up completely--no hassles. I've tried all of the various options and can't replicate this behavior in 10.04. I even regenerated the fractal so that the image had the same dimesions as the combined screens and used "span". It actually <em>shrank</em> the image the centered it--part of it on one screen part of it on the other, but lots of uncovered space around the image.

schuelaw (schuelaw) wrote :

Sorry, by 8.10 above I meant 8.04LTS.

Boynas (garyflores) wrote :

I am a laptop user, and I went through the "trouble" of using gimp to create a long landscape wallpaper to fit both of the monitors with the correct exact resolution. Since I also use my laptop without the docking station, I used to have it "style: Tile" so, when I use just one monitor it would display only the left side, and when i have two monitors, this second would display the extension of the wallpaper.
Well, "Style: Tile" now tiles it from the center to the edges instead of from the top to bottom and left to right.
And there is no way to reproduce that behavior for people that use both setups.

Changed in gnome-control-center:
status: Unknown → New
Coz (cosimo321) wrote :

Hey guys,
 Well I also reported this as one of several "MAJOR" bugs in lucid and maverick.
All of the wallpaper options simply mirror the image on dual monitors and "span" of course, as mentioned many times here, simply places the image between the two monitors..
  This is not the most serious bug in lucid/maverick.. but certainly one of the most annoying of them.
This can be remedied under xorg.conf under Section Screen by adding Option "NoTwinViewXineramaInfo" "true" ...
However. that only reproduces an old nvidia bug that has since been solved...great for watching full screen dual monitor videos but bad for daily work environment, and of course I don't know if this works with ati or intel video !
   As I mentioned,,, this is one of sever major bugs on lucid/maverick... and all of those bugs combined prevent me from reinstalling lucid as a serious work environment and I cannot ask my clients to upgrade to Lucid because of these bugs.
   This is, along with the other bugs... this one being the most serious https://bugs.launchpad.net/ubuntu/+bug/581904 ,
is a big step backwards for ubuntu and most certainly for LTS!!!

coz

SabreWolfy (sabrewolfy) wrote :

Yeah, I'm missing the "span and zoom" functionality which was present previously. It was really nice to be able to use a background wallpaper of more-or-less the right dimensions for a dual monitor and GNOME would zoom it across both monitors. The SPAN functionality as it stands now does not fix this. If the resolution of the image is slightly smaller, for example, then black areas appear to the left and right of the image.

What a pity this functionality is gone. I remember being very impressed with GNOME when I selected a dual monitor wallpaper for the first time and it "magically" fitted full-screen across both my monitors. I despair when these regression-type bugs creep in. Too often they take years to fix.

Stephen Goykovich (sgoykovi) wrote :

i know it may seem petty, but this is a major reason for me not updating my ubuntu installation. I'm surprised that this still hasn't been fixed yet!

Logan Smyth (loganfsmyth) wrote :

Just want to add my 2 cents. When I found and read the first few comments talking about Span, I immediately assumed it was a checkbox and was very confused when it wasn't. I think that is probably the best course of action, since it allowed for the best of both worlds. I definitely hope we get a fix for this so I can properly zoom + span.

Gerry (gerry-spm+lnchpad) wrote :

Surely the person that made this regression would have known the effect it would have?? I can't understand why this decision was made, but even after it was made I don't see how the change was then approved.

Coz's comments mirror my own feelings of this regression. I'm now wondering how the importance of this issue could still be "Undecided" when it's clearly quite a bad and annoying regression that should not (as least as far as I can see) have not been made in the first place.

AutoStatic (autostatic) wrote :

After installing Lucid I run into this issue too. And to my surprise the whole 'Fill screen' option in the Appearance Settings - Background window is gone and it's not present in gconf-editor either. And apparently this was dropped in Gnome 2.28. Just like the menu icons that were dropped along the way too. And GUADEC was right around the corner this year... ;)

Scott Carpenter (scottc) wrote :

Just wanted to note that George Standish's workaround in comment #2 worked well for me.

Changed in gnome-control-center:
importance: Unknown → Medium
jcuhoh (jerrycrabb) wrote :

Has anyone found an acceptable workaround for this issue? The workaround in comment #2 DID NOT work for me, simply centered the image between the monitors.

On Sun, Oct 17, 2010 at 3:15 PM, jcuhoh <email address hidden> wrote:

> Has anyone found an acceptable workaround for this issue? The workaround
> in comment #2 DID NOT work for me, simply centered the image between the
> monitors.
>
> --
> Dual Monitor wallpaper is not scaling across both monitors, same background
> is repeated on both monitors instead
> https://bugs.launchpad.net/bugs/521492
> You received this bug notification because you are a direct subscriber
> of the bug.
>

hey guy,
 Well apparently no one is going to fix this.
What I do is determine the resolution of both monitors... example..my total
is 2560x1024, so I either google for images at the resolution or
edit/create one in gimp.
  This is more than a pain in the rear and several steps backwards for
linux ...but no one is addressing this and ,,by the way ,,, it is worse on
KDE.

coz

Taneli (taneli-vahakangas) wrote :

I made a python script (with PIL) that fixes the situation for me
by tiling several images into one (according to what xrandr tells
about the screen sizes), I can put it up somehwere, if people are
interested ... ? It needs a little cleaning up first, though.

Cheers,

 Taneli

On Mon, Oct 18, 2010 at 01:17:08AM -0000, Coz wrote:
> On Sun, Oct 17, 2010 at 3:15 PM, jcuhoh <email address hidden>
> wrote:
>
> > Has anyone found an acceptable workaround for this issue? The workaround
> > in comment #2 DID NOT work for me, simply centered the image between the
> > monitors.
> >
> > --
> > Dual Monitor wallpaper is not scaling across both monitors, same background
> > is repeated on both monitors instead
> > https://bugs.launchpad.net/bugs/521492
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> hey guy,
> Well apparently no one is going to fix this.
> What I do is determine the resolution of both monitors... example..my total
> is 2560x1024, so I either google for images at the resolution or
> edit/create one in gimp.
> This is more than a pain in the rear and several steps backwards for
> linux ...but no one is addressing this and ,,by the way ,,, it is worse on
> KDE.
>
> coz
>
> --
> Dual Monitor wallpaper is not scaling across both monitors, same background is repeated on both monitors instead
> https://bugs.launchpad.net/bugs/521492
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (520856).
>
> Status in GNOME Control Center: New
> Status in “meta-gnome2” package in Ubuntu: Confirmed
>
> Bug description:
> On all other Ubuntu/Gnome versions you can use a wallpaper sized for dual-monitor and it will span across both monitors, currently the same wallpaper is being repeated twice, once on each monitor.
>
> Appears to be https://bugzilla.gnome.org/show_bug.cgi?id=603551 regarding scaling wallpaper across dual monitors
>
> If Nautilus' wallpaper manager is replaced by Compiz's, the wallpaper scales correctly.
>
> ProblemType: Bug
> Architecture: amd64
> Date: Sat Feb 13 14:45:06 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
> NonfreeKernelModules: nvidia
> Package: gnome (not installed)
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
> SourcePackage: meta-gnome2
> Uname: Linux 2.6.32-13-generic x86_64
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/521492/+subscribe

My display configuration(virtual desktop) consists of two monitors. From left to right:
* 1600x1200, rotated left (hence 1200x1600 really) (secondary monitor)
* 1920x1200 (main monitor)

The virtual desktop thus measures 3120x1600 (with a dent taken out of it in the lower right hand corner). The wallpaper used for these tests measures 2560x1600 px.

The Help is not synchronised with the UI; it describes "Centered/Fill Screen/Scaled/Zoom/Tiled" but the Appearance: Preferences: Background Style drop-down lists "Tile/Zoom/Center/Scale/Stretch/Span". Note how Span is missing and how Stretch <=> Fill Screen.

Tile: Instead of two images side-by-side (left full width, right ~one-fifth width), the tiling uses the central part of the image (1920x1200) and tiles that. Note how the main monitor's size was used instead of the whole desktop's.

Zoom: Does not zoom to cover the entire virtual desktop, but instead zooms within each display separately.

Center: Does not center with respect to the entire virtual desktop, but instead centers within each display separately.

Scale: Does not scale with respect to the entire virtual desktop, but instead scales within each display separately.

Stretch: Does not stretch over the entire virtual desktop, but instead stretches within each display separately.

Span: Not specified, but the expectation is an aspect-ratio-preserving scaling that covers the entire virtual desktop. In actuality, it only stretches until the vertical size is achieved (1600 px here), leaving two ugly bands on either side.

Michele Mattioni (mattions) wrote :

Hello,

This problem is still present.
I'm wondering if anyone is working on it.
this is a regression, as people already noted everything was working in gnome 2.28.0, not anymore in 2.30.0

It's really annoying bug.

Florent Viard (fviard) wrote :

Hi,
This is a random guess from looking at the source code, but is there someone here with a double monitor able to recompile gnome desktop to try the following fix:
In libgnome-desktop/gnome-bg.c around line 833
{ in function static GdkPixbuf * get_scaled_pixbuf (...) , around line 833 }
----
 switch (placement) {
 case G_DESKTOP_BACKGROUND_STYLE_SPANNED:
- new = pixbuf_scale_to_fit (pixbuf, width, height);
+ new = pixbuf_scale_to_min (pixbuf, width, height);
  break;
 case G_DESKTOP_BACKGROUND_STYLE_ZOOM:
  new = pixbuf_scale_to_min (pixbuf, width, height);
  break;

 case G_DESKTOP_BACKGROUND_STYLE_STRETCHED:
  new = gdk_pixbuf_scale_simple (pixbuf, width, height,
            GDK_INTERP_BILINEAR);
  break;
----

Mark Drago (markdrago-gmail) wrote :

Florent,
I didn't rebuild or anything, but it looks like that diff will just make 'span' work exactly like 'zoom.'

Florent Viard (fviard) wrote :

No, because there is the following piece of code before, so my guess is that my fix proposal will give a : "SPAN + ZOOM" effect.

----
if (is_root && (bg->placement != G_DESKTOP_BACKGROUND_STYLE_SPANNED)) {
  draw_color_each_monitor (bg, dest, screen);
  if (bg->placement != G_DESKTOP_BACKGROUND_STYLE_NONE) {
   draw_each_monitor (bg, dest, screen);
  }
 } else {
  draw_color (bg, dest, screen);
  if (bg->placement != G_DESKTOP_BACKGROUND_STYLE_NONE) {
   draw_once (bg, dest, screen);
  }
 }
----

On Thu, Dec 23, 2010 at 12:38 PM, Florent Viard <email address hidden> wrote:

> No, because there is the following piece of code before, so my guess is
> that my fix proposal will give a : "SPAN + ZOOM" effect.
>
> ----
> if (is_root && (bg->placement != G_DESKTOP_BACKGROUND_STYLE_SPANNED)) {
> draw_color_each_monitor (bg, dest, screen);
> if (bg->placement != G_DESKTOP_BACKGROUND_STYLE_NONE) {
> draw_each_monitor (bg, dest, screen);
> }
> } else {
> draw_color (bg, dest, screen);
> if (bg->placement != G_DESKTOP_BACKGROUND_STYLE_NONE) {
> draw_once (bg, dest, screen);
> }
> }
> ----
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/521492
>
> Title:
> Dual Monitor wallpaper is not scaling across both monitors, same
> background is repeated on both monitors instead
>

Hey guys,
 well there should not be a span + zoom effect....
Span means to "stretch" the wallpaper ,, regardless of the images
resolution... to the exact resolution of the dual monitor setup!
 so if a 1024x1024 image is being used on dual monitors at 2560x1024...
"Span" will resize the image to 2560x1024.
i am not sure why this has been a confusing issue..
It worked fine before lucid , and since then it is completely broken.
I believe that whomever changed this was coding on a laptop and simply
removed what they thought was useless code !

coz

Florent, your solution worked perfectly.

I am using the latest Debian unstable (not Ubuntu).

I just added the line "deb-src http://http.us.debian.org/debian/ unstable main" to my '/etc/apt/sources.list' file.

Then I did 'apt-get source libgnome-desktop-2-17'.
Then 'cd gnome-desktop-2.30.2'.
Then 'vim libgnome-desktop/gnome-bg.c' to make the one-line change that you recommend.
Then 'apt-get build-dep gnome-desktop'.
Then "dch -l local 'fix span'".
Then 'debuild -us -uc'.
Then 'dpkg -i ../*.deb'.

Yeah, I did everything as root, and this is not recommended.

But it worked. Now 'Span' has the right effect.

Any Ubuntu user with root access should be able to do a similar thing, with sources and package names adjusted appropriately for Ubuntu.

Thanks.

Michele Mattioni (mattions) wrote :

As Thomas said I confirm the patch Florent propose @ https://bugs.launchpad.net/ubuntu/+source/meta-gnome2/+bug/521492/comments/30 works on an Ubuntu Lucid Lynx 10.04

I follow the steps detailed by Thomas here: https://bugs.launchpad.net/ubuntu/+source/meta-gnome2/+bug/521492/comments/34

I guess this has to go upstream.

Thomas (tevaughan) wrote :

Florent, I submitted a bug report to the Debian maintainers of gnome-desktop. We'll see if anything comes of it. I supplied your patch.

Florent Viard (fviard) wrote :

Michele and Thomas, thanks for having tried my solution and submitted it upstream.

Jeremy Nickurak (nickurak) wrote :

I'm in a dual-monitor setup, with different resolutions on each. Right now, I'm having trouble just creating a background that can work correctly without scaling on both. My layout

<-- 1680 -> <- 900 ->
| ^ ^ |
| | | |
| 1050 1440 |
| | | |
|-----------V | |
                    V----------

(excuse the bad ascii art :) )

It seems to me in this configuration, I should be able to create a background that's 2580x1440, and have it just sit correctly there. Do any of the configurations/patches available here allow this as a functional workaround for this issue?

Jeremy Nickurak (nickurak) wrote :

Hmm. Span does seem to work in this case at least. I definitely would have expected Tile to work correctly as well, but it doesn't. Anyways, here's a datapoint which should probably be considered.

(For the record, that horrendous ascii-art was supposed to reflect a 1680x1050 monitor and a 900x1440 monitor (portrait mode))

Changed in gnome-control-center:
importance: Medium → Low
status: New → Confirmed
Paul Kishimoto (khaeru) wrote :

I added this to the gnome-control-center package in Ubuntu, which corresponds better to the upstream bug than "meta-gnome2".

This bug still appears in Ubuntu 11.10 with gnome-control-center 1:3.2.0-0ubuntu6.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2011-12-21
summary: - Dual Monitor wallpaper is not scaling across both monitors, same
- background is repeated on both monitors instead
+ [Patch upstream] Dual Monitor wallpaper is not scaling across both
+ monitors, same background is repeated on both monitors instead
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Bryce Harrington (bryce) wrote :

Agreed; we can close out the meta-gnome2 task.

Changed in meta-gnome2 (Ubuntu):
status: Confirmed → Invalid
farge (sonicmaker) wrote :

Can confirm that this bug still appears in Ubuntu 12.04.

Have noticed that using Advanced Settings (gnome-tweak-tool) to set "Have file manager handle the desktop" to Off reverts control of the desktop background to Compiz, so if you have a background set in CompizConfig Settings Manager's Wallpaper plugin it displays in the correct manner, i.e. tiled from the top left corner across both screens. However, doing so also disables icons and the right-click menu on the desktop. Given this, is it possible that it's an issue with Nautilus?

dardata (dardata) wrote :

Im on 12.04 and this is still an issue as well! Two years old, i guess its pointless to even comment.

dardata (dardata) wrote :

Im an idiot!
I have 2 1920x1080 monitors and was downloading wallpaper of 3840x2160, but realized i didnt have to double the vertical resolution. After downloading the closes resolution to 3840x1080 then wallpaper spans appropriately.

joris (joris-dobbelaer-gmail) wrote :

This still not works correct in Ubuntu 12.10

This doesn't seem to work for me in 12.10.

Daniel Wojtucki (dros) wrote :

This Bug is still available in Ubuntu 12.10 64-bit (GNOME 3.6.0)!

But:
Thanks a lot to Florent and Thomas for the very helpful solution. The solution in den Comments #32 and #34 works perfect for me.
I have fix the problem in libgnome-desktop-3-4_3.6.0.1 -> libgnome-desktop/gnome-bg.c -> line 881.
The lib from the ubuntu repository.

I'm here to say that on ubuntu 12.10, gnome shell 3.6.2 this still not works. Kind of a pitty..

Tv (tv42) wrote :

It seems gconftool-2 from comment #2 is being deprecated. Here's how to fix this in 13.10:

dconf write /org/gnome/desktop/background/picture-options "'spanned'"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.