Clicking on window does not change focus

Bug #330894 reported by mohrtutchy on 2009-02-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
meta-gnome2 (Ubuntu)
Low
Unassigned

Bug Description

The focus of a window does not always change when I click on it. It happens appearently random and i had no luck in reproducing it.
For instance, if firefox is open and a gnome-terminal is open, clicking on the gnome-terminal will bring it to the top of the z-order, but focus will not change to it and all keyboard actions will be sent to firefox instead of the terminal. I can change focus using alt-tab or using the window list applet. If i click on the title bar, the window makes a small movement and get focus but the title bar isn't highlighted. A further problem is that I cannot alt-drag windows. Turning off compiz doesn't resolve, the only way is to restart X.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Also, please answer these questions:
* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?
* Are you using compiz? does it happens without it?

This will greatly aid us in tracking down your problem and resolving this bug.

Changed in meta-gnome2:
importance: Undecided → Low
status: New → Incomplete
mohrtutchy (mohr-tutchy) wrote :

Thanks to you Pedro, I know it's very hard to be so kind when people report weird and not reproducible bugs. ;)
Here are the answers:
* No, I'm still looking for the way to do it
* It seems it happens when I have lot of windows opened, especially gvim, gnome-terminal, nautilus and mplayer but this could be not related.
* Yes, I'm using compiz, when it happens, if I run
$ metacity --replace
the problem remains. I also tried to clean gconf running
$ gconftool-2 --shutdown
$ gconftool-2 --recursive-unset /
but no luck.

Thanks again

mohrtutchy (mohr-tutchy) wrote :

I'm still unable to reproduce the bug but i noticed that turning off "snapoff maximized windows" on move window plugin in ccsm seems to solve.

jose (jose-cybergalvez) wrote :

I'm having the same issue, it does not work until I log out and then back in.
I have nvidia 180 driver, and ubuntu 8.10. Basically clicking a window does not raise it or change its focus
Thanks

Lizzzzard (lisadaske-web) wrote :

I'm having the same issue here.
Switching "Visual Effects" off and on again seems to help for a while, but eventually it comes back. I have Ubuntu 8.10 and I'm using the nvidia 177 driver.
This just started in the last few days, I will watch it and try to reproduce.

Thanks for watching a seemingly "random" bug ;-)

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Is this reproducible with Ubuntu 9.10 the Karmic Koala? Please test and provide us of feedback about it, Thanks in advance..

mohrtutchy (mohr-tutchy) wrote :

@ Pedro:
I'm under karmic since october and i never experienced this problem :)

Launchpad Janitor (janitor) wrote :

[Expired for meta-gnome2 (Ubuntu) because there has been no activity for 60 days.]

Changed in meta-gnome2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers