slow to match contact name on messaging-app startup

Bug #1489512 reported by Bill Filler on 2015-08-27
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
address-book-service (Ubuntu)
High
Renato Araujo Oliveira Filho
messaging-app (Ubuntu)
High
Tiago Salem Herrmann

Bug Description

when Messages view loads for the first time, there is a delay (1-3 seconds) where the phone numbers are shown in the view and then after some time the contact matching occurs and the contact name fills in.

This should be faster, also immediate really. We need to optimize how this lookup is done so it can happen more instantly.

Related branches

Bill Filler (bfiller) on 2015-08-27
Changed in canonical-devices-system-image:
milestone: none → ww40-2015
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
Changed in messaging-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in address-book-service (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in messaging-app (Ubuntu):
assignee: Renato Araujo Oliveira Filho (renatofilho) → Tiago Salem Herrmann (tiagosh)
Changed in address-book-service (Ubuntu):
importance: Undecided → High
Changed in messaging-app (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-service (Ubuntu):
status: New → Confirmed
Changed in messaging-app (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
tags: added: hotfix6
tags: added: hotfix
removed: hotfix6
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Michał Sawicz (saviq) on 2015-09-24
Changed in address-book-service (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-service - 0.1.1+15.10.20151015.1-0ubuntu1

---------------
address-book-service (0.1.1+15.10.20151015.1-0ubuntu1) wily; urgency=medium

  [ Renato Araujo Oliveira Filho ]
  * Disable the EDS source instead of remove it. Do a syncevolution sync
    before continue with upgrader. Does not remove old sources with
    disabled sync.
  * Fixed crash while removing online accounts. Only update google
    accounts. (LP: #1502899)
  * Fixed package build with translations.
  * Implemented 'maxCountHint' support for queries. (LP: #1489512)

 -- Bill Filler <email address hidden> Thu, 15 Oct 2015 20:45:13 +0000

Changed in address-book-service (Ubuntu):
status: In Progress → Fix Released
Tomas Öqvist (tomoqv) wrote :

As of rc-proposed r157 this works perfect on Bq Aquaris 4.5. Contact names are there as soon as the app opens. Well done!

themeles (themeles) wrote :

For me the bug still remains after installing all available updates.

Tiago Salem Herrmann (tiagosh) wrote :

@themeles What image version are you using? This is only present on rc-proposed channel yet.

themeles (themeles) wrote :

@tiagosh it's 20151015-214614. I don't have the rc channel running, so I guess I have to wait.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

is the addressbook change enough to consider that bug resolved? (or asked differently should the messaging-app part be closed as well now)

Pat McGowan (pat-mcgowan) wrote :

yes it should

Changed in messaging-app (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers