slow to load a thread

Bug #1488988 reported by Bill Filler on 2015-08-26
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
history-service (Ubuntu)
High
Gustavo Pichorim Boiko
messaging-app (Ubuntu)
High
Tiago Salem Herrmann

Bug Description

On latest rc-proposed and ota-6 the time to load a message thread has increased. It sometimes takes a very long time to open the thread view, longer in some cases then others.

We should profile what is happening, possibly the contact lookup is taking a long time.

In theory, we should load the view immediately and async fill in any information that we need.

Related branches

Bill Filler (bfiller) on 2015-08-26
Changed in canonical-devices-system-image:
milestone: none → ww40-2015
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
Changed in messaging-app (Ubuntu):
assignee: nobody → Tiago Salem Herrmann (tiagosh)
importance: Undecided → High
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in history-service (Ubuntu):
importance: Undecided → High
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in history-service (Ubuntu):
status: New → Confirmed
tags: added: hotfix6
Bill Filler (bfiller) on 2015-09-10
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in history-service (Ubuntu):
status: Confirmed → In Progress
Changed in messaging-app (Ubuntu):
status: Confirmed → In Progress
tags: added: hotfix
removed: hotfix6
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (13.5 KiB)

This bug was fixed in the package history-service - 0.1+15.10.20151020.1-0ubuntu1

---------------
history-service (0.1+15.10.20151020.1-0ubuntu1) wily; urgency=medium

  [ Gustavo Pichorim Boiko ]
  * Make it possible to use the custom functions defined by the sqlite
    plugin in the schema files themselves.
  * Move the classes from historyprivate static library to
    libhistoryservice itself and just keep their header files private.
  * Optimize the thread matching by avoiding some phone number
    formatting and validating. (LP: #1488988)
  * Request contact information for all known participants on history-
    daemon initialization, and use this cached information on the
    models.
  * Store threads' timestamps in UTC in the cache, and convert only when
    returning to the client, so that it has the most up-to-date local
    time.

  [ Tiago Salem Herrmann ]
  * Initial cache implementation for grouped conversations.
  * Set max count hint Don't use fallback to tel to avoid queries to the
    address-book-service with null filters

history-service (0.1+15.10.20150828.1-0ubuntu1) wily; urgency=medium

  [ Gustavo Pichorim Boiko ]
  * Do not override the build type. Also remove a block of unused code
    from debian/rules.
  * Fix flags.
  * Prevent the history-daemon from crashing in the event of an ended
    call not having any remote member. (LP: #1458990)

  [ Tiago Salem Herrmann ]
  * Correctly set mCanFetchMore in the HistoryGroupedThreadsModel.
  * Generate eventId when there is none Set status to "Accepted" if the
    channel does not support delivery reports
  * Manually add self id to participants list if needed. (LP: #1486187)

history-service (0.1+15.10.20150819.2-0ubuntu1) wily; urgency=medium

  [ Gustavo Pichorim Boiko ]
  * Fix tests on vivid.

  [ Tiago Salem Herrmann ]
  * Wait telepathy to be ready before querying address-book-service.
    (LP: #1485005)

history-service (0.1+15.10.20150810-0ubuntu1) wily; urgency=medium

  [ Tiago Salem Herrmann ]
  * Use libphonenumber for phone number validation, normalization and
    comparison. (LP: #1471545, #1473028)

history-service (0.1+15.10.20150701-0ubuntu2~gcc5.1) wily; urgency=medium

  * No-change test rebuild for g++5 ABI transition

history-service (0.1+15.10.20150701-0ubuntu1) wily; urgency=medium

  [ Tiago Salem Herrmann ]
  * Update to telepathy-qt 0.9.6.1.

history-service (0.1+15.04.20150428.1-0ubuntu1) vivid; urgency=medium

  [ Gustavo Pichorim Boiko ]
  * Fix a crash that was happening when matching new contacts. Also add
    a unit test to make sure it doesn't happen again. (LP: #1449662)

history-service (0.1+15.04.20150409-0ubuntu1) vivid; urgency=medium

  [ Gustavo Pichorim Boiko ]
  * Change the tests to use the same infrastructure as the one used in
    telephony-service, and add some tests for the contact matching
    changes.
  * Improve contact matching by accepting other addressable fields than
    just phone numbers.

history-service (0.1+15.04.20150210-0ubuntu1) vivid; urgency=medium

  [ Tiago Salem Herrmann ]
  * Add support for writing events from qml. Iterate over attachments
    when qdbus_cast fails. (LP: #1417353)

history-service (0.1+...

Changed in history-service (Ubuntu):
status: In Progress → Fix Released
Tomas Öqvist (tomoqv) wrote :

This issue is much, much, much better since rc-proposed r157. The messaging app could now be considered to be in a workable state again. Thanks for fixing this!

Changed in messaging-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers