add support for future LLVM versions

Bug #1821368 reported by Timo Aaltonen on 2019-03-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
meson (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Timo Aaltonen

Bug Description

[Impact]
Meson hardcodes a list of llvm-config-N binaries to search for, and the version in bionic has no support for specifying which one to use (added in 0.49). So, in order to be able to support Mesa backports from 19.04..20.04 to 18.04, we need to add the new binary names in meson. It's assumed that LLVM will follow the current naming scheme and release schedule, so these names should be added:

llvm-config-8 (from 19.04)
llvm-config-9 (will be from 19.10)
llvm-config-10 (will be 20.04)

[Test case]
Test that Mesa backports build in bionic.

[Regression potential]
None really, they just add new binary strings to search for.

[Other information]
The devel series is expected to follow meson upstream and get these names from there.
Also, Mesa deprecated autotools in 19.0, and might drop support for it before 20.04, so we can't just revert the packaging change to use meson.

Timo Aaltonen (tjaalton) on 2019-03-22
Changed in meson (Ubuntu):
status: New → Invalid
Changed in meson (Ubuntu Bionic):
assignee: nobody → Timo Aaltonen (tjaalton)

Hello Timo, or anyone else affected,

Accepted meson into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/meson/0.45.1-2ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in meson (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

mesa backport in proposed has built, so the meson update works as intended

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package meson - 0.45.1-2ubuntu0.18.04.1

---------------
meson (0.45.1-2ubuntu0.18.04.1) bionic; urgency=medium

  * add-new-llvm-configs.diff: Add support for future llvm backports.
    (LP: #1821368)

 -- Timo Aaltonen <email address hidden> Wed, 10 Apr 2019 09:35:26 +0300

Changed in meson (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for meson has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers