Ubuntu

gnome-session-check-accelerated-helper crashed with SIGSEGV in QueryVersion()

Reported by epek on 2012-03-29
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
High
Bryce Harrington
Precise
High
Bryce Harrington
Quantal
High
Bryce Harrington

Bug Description

after login, update from 11.10

#0 QueryVersion (minor=0x62e770, major=0x62e76c, dpy=0x623010, opcode=<optimized out>) at glxext.c:296
        c = 0x624410
        reply = 0x0

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-session-bin 3.2.1-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Thu Mar 29 16:27:01 2012
ExecutablePath: /usr/lib/gnome-session/gnome-session-check-accelerated-helper
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: /usr/lib/gnome-session/gnome-session-check-accelerated-helper
ProcEnviron:
 LANG=de_AT.UTF-8
 SHELL=/bin/false
 PATH=(custom, no user)
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-session
Title: gnome-session-check-accelerated-helper crashed with SIGSEGV in glXChooseVisual()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

epek (epek) wrote :
Changed in gnome-session (Ubuntu):
importance: Undecided → Medium
summary: gnome-session-check-accelerated-helper crashed with SIGSEGV in
- glXChooseVisual()
+ QueryVersion()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
visibility: private → public
affects: gnome-session (Ubuntu) → mesa (Ubuntu)
Bryce Harrington (bryce) on 2012-06-13
description: updated
Bryce Harrington (bryce) wrote :

Looks like a simple nullptr deref issue.

Are you able to reproduce this bug reliably?

Changed in mesa (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
importance: Medium → High
status: Confirmed → In Progress
Bryce Harrington (bryce) wrote :

This should fix the null ptr deref.

Bryce Harrington (bryce) on 2012-06-13
Changed in mesa (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in mesa (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 8.0.3-0ubuntu1

---------------
mesa (8.0.3-0ubuntu1) quantal; urgency=low

  * New upstream stable release.
    + Fixes crash in intel_miptree_release()
      (LP: #952896)
    + Fixes slow WebGL in firefox
      (LP: #988343)

  [ Robert Hooker ]
  * Drop 118_fix_rendering_from_textures.patch and
    117_intel_fix_hiz_null_dereference.patch, both included upstream.
  * Refresh patches.

  [ Bryce Harrington ]
  * Add 117_nullptr_check_in_query_version.patch: Fix null pointer
    deref in QueryVersion() during login.
    (LP: #968284)
  * Add 118_glsl_initialize_samplers.patch: Initialize samplers to 0, as
    required by the spec. Fixes rendering corruption in MapsGL labels.
    Cherrypick from mesa master.
    (LP: #981883)
 -- Bryce Harrington <email address hidden> Mon, 18 Jun 2012 19:02:09 -0700

Changed in mesa (Ubuntu Quantal):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) on 2012-07-19
Changed in mesa (Ubuntu Precise):
status: Triaged → Fix Committed
assignee: nobody → Bryce Harrington (bryce)

Hello epek, or anyone else affected,

Accepted mesa into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/8.0.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello epek, or anyone else affected,

Accepted mesa into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa/8.0.4-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Bartosz Kosiorek (gang65) wrote :

After install mesa from proposed, the problem was gone.

Verification done.

tags: added: verification-done
removed: amd64 apport-crash verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 8.0.4-0ubuntu0.1

---------------
mesa (8.0.4-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream stable release. (LP: #1019444)
    + Fixes crash in intel_miptree_release()
      (LP: #952896)
    + Fixes slow WebGL in firefox
      (LP: #988343)

  [ Robert Hooker ]
  * Drop 118_fix_rendering_from_textures.patch and
    117_intel_fix_hiz_null_dereference.patch, both included upstream.
  * Refresh patches.

  [ Bryce Harrington ]
  * Add 117_nullptr_check_in_query_version.patch: Fix null pointer
    deref in QueryVersion() during login.
    (LP: #968284)
  * Add 118_glsl_initialize_samplers.patch: Initialize samplers to 0, as
    required by the spec. Fixes rendering corruption in MapsGL labels.
    Cherrypick from mesa master.
    (LP: #981883)
 -- Bryce Harrington <email address hidden> Fri, 07 Sep 2012 13:59:12 -0700

Changed in mesa (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers