New version of libgl1-mesa-glx freeze Scilab graphics

Bug #877491 reported by Sylvestre Ledru on 2011-10-18
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Mesa
Confirmed
High
mesa (Ubuntu)
Critical
Unassigned

Bug Description

Hello

The new version of libgl1-mesa-glx introduced in 11.10 is now freezing Scilab.
Installing the package libgl1-mesa-swx11 (which will remove libgl1-mesa-glx will fix the issue).

This has been reported on the Scilab bug tracker.
http://bugzilla.scilab.org/show_bug.cgi?id=10106

Thanks
S

In Ubuntu 11.10 when I plot any graphics the scilab freeze and I cant't close it.

-->[a,b]=getdebuginfo()
 b =

!Compilation date: Aug 19 2011 !
! !
!Compilation time: 20:38:09 !
! !
!XML version: 2.7.8 !
! !
!Compiler Architecture: X86 !
 a =

!Total memory: 2505532 !
! !
!Used memory: 2154816 !
! !
!Free memory: 350716 !
! !
!Shared memory: 0 !
! !
!Buffers memory: 119996 !
! !
!Cached memory: 1114036 !
! !
!Used -/+ buffers/cache: 920784 !
! !
!Free -/+ buffers/cache: 1584748 !
! !
!Total swap: 975868 !
! !
!Used swap: 0 !
! !
!Free swap: 975868 !
! !
!SCI: /usr/share/scilab/ !
! !
!SCIHOME: /home/lucas/.Scilab/scilab-5.3.3 !

system_setproperty("jogl.gljpanel.nohw","");

=> does it change anything ?

No, The problem remain.

*** Bug 10112 has been marked as a duplicate of this bug. ***

Could you do the following:
apt-get install scilab-full-bin-dbg scilab-minimal-bin-dbg gdb

scilab-adv-cli -debug -e plot3d
in gdb, type
handle SIGSEGV nostop print
run

and once it reached the real freeze, type "bt" and please provide the full stack trace.

Sylvestre, I ran according to your comment #5,
however during the real freeze I had to type Ctrl-C before being able to type "bt".

Program received signal SIGINT, Interrupt.
pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
162 ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S: No such file or directory.
 in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
(gdb) bt
#0 pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1 0x00007fffdc1e3c9b in os::PlatformEvent::park() ()
   from /usr/lib/jvm/java-6-openjdk//jre/lib/amd64/server/libjvm.so
#2 0x00007fffdc1d64a5 in ObjectMonitor::wait(long, bool, Thread*) ()
   from /usr/lib/jvm/java-6-openjdk//jre/lib/amd64/server/libjvm.so
#3 0x00007fffdc2aa27b in ObjectSynchronizer::wait(Handle, long, Thread*) ()
   from /usr/lib/jvm/java-6-openjdk//jre/lib/amd64/server/libjvm.so
#4 0x00007fffdc07b5e8 in JVM_MonitorWait ()
   from /usr/lib/jvm/java-6-openjdk//jre/lib/amd64/server/libjvm.so
#5 0x00007fffd7b1ad68 in ?? ()
#6 0x00000000fbd65598 in ?? ()
#7 0x0000000000000011 in ?? ()
#8 0x0000000000000000 in ?? ()

ok, thanks

Two others questions:
* still in gdb, could you copy/paste the result of "info threads"
* what is the result of dpkg -l|grep openjdk

Download full text (3.4 KiB)

(In reply to comment #7)

$ dpkg -l |grep openjdk

ii openjdk-6-jdk 6b23~pre10-0ubuntu5 OpenJDK Development Kit (JDK)
ii openjdk-6-jre 6b23~pre10-0ubuntu5 OpenJDK Java runtime, using Hotspot JIT
ii openjdk-6-jre-headless 6b23~pre10-0ubuntu5 OpenJDK Java runtime, using Hotspot JIT (headless)
ii openjdk-6-jre-lib 6b23~pre10-0ubuntu5 OpenJDK Java runtime (architecture independent libraries)

(gdb) info threads
  Id Target Id Frame
  19 Thread 0x7fffc9f35700 (LWP 3309) "scilab-bin" 0x00007fffebfbd773 in __GI___poll (
    fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>)
    at ../sysdeps/unix/sysv/linux/poll.c:87
  18 Thread 0x7fffca736700 (LWP 3308) "scilab-bin" pthread_cond_timedwait@@GLIBC_2.3.2
    () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
  17 Thread 0x7fffd589f700 (LWP 3307) "scilab-bin" 0x00007fffec72d09e in __pthread_mutex_lock (mutex=0x7ffff7ffd948) at pthread_mutex_lock.c:84
  16 Thread 0x7fffd579e700 (LWP 3306) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  13 Thread 0x7fffd59a0700 (LWP 3301) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  12 Thread 0x7fffd5f78700 (LWP 3300) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  11 Thread 0x7fffd6c69700 (LWP 3299) "scilab-bin" pthread_cond_timedwait@@GLIBC_2.3.2
    () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
  10 Thread 0x7fffd6d6a700 (LWP 3298) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  9 Thread 0x7fffd6e6b700 (LWP 3297) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  8 Thread 0x7fffd6f6c700 (LWP 3296) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  7 Thread 0x7fffd706d700 (LWP 3295) "scilab-bin" sem_wait ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/sem_wait.S:86
  6 Thread 0x7fffd716e700 (LWP 3294) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  5 Thread 0x7fffd726f700 (LWP 3293) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  4 Thread 0x7fffd7370700 (LWP 3292) "scilab-bin" pthread_cond_timedwait@@GLIBC_2.3.2
---Type <return> to continue, or q <return> to quit---
    () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
  3 Thread 0x7fffd795f700 (LWP 3291) "scilab-bin" pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
  2 Thread 0x7fffd7a60700 (LWP 3290) "s...

Read more...

There is a work-around (or solution?) in the Scilab newsgroup:

http://www.equalis.com/forums/posts.asp?topic=321201&

However, I don't want to be stuck with Unity 2D by having to remove lib-mesa-glx and others.

Installing libgl1-mesa-swx11 or removing libgl1-mesa-glx fix the issue.

I reported a bug against the mesa package:
https://bugs.launchpad.net/ubuntu/+bug/877491

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

I heard doing this work-around will break Unity, making the computer start on Unity 2D, is that true?

(In reply to comment #10)
> Installing libgl1-mesa-swx11 or removing libgl1-mesa-glx fix the issue.
>
> I reported a bug against the mesa package:
> https://bugs.launchpad.net/ubuntu/+bug/877491

Probably. I haven't tried yet (I am installing a clean image to test that).

Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 877491

affects: ubuntu → mesa (Ubuntu)
Changed in mesa (Ubuntu):
status: Confirmed → Incomplete
Changed in mesa:
importance: Unknown → High
status: Unknown → Confirmed
Ricardo Fabbri (rfabbri) wrote :

walter-garcia: I have done that command. It gave me trouble the first couple of times I ran it (saying I was not the reporter or subscriber, or that the bug must be duplicate), but a third time it went on to send my info. I hope my private information is useful to Ubuntu, if it was any other OS I would never have done this ;)

@rfabbri: your reports didn't get attached to this bug report, because as you said you are not the original reporter. I was sending my request to the original reporter.

Hello Sylvestre, This bug has been fixed?

See the workaround of the comment #10
I will ping ubuntu people about the mesa issue...

Sylvestre Ledru (sylvestre) wrote :

Ricardo, could you upload manually your information ?

Ricardo Fabbri (rfabbri) wrote :

@sylvestre, I cannot send my information anymore since I borrowed my laptop to a friend of mine. I am using an old computer now which runs Gentoo. It will take me weeks until I get my Ubuntu laptop back.

hi, I have this problem too with gnome-shell. Any news to keep the nice 3d environment?
Thank you

AFAIK, Ubuntu people haven't fixed this issue yet...

delva, could you do what has been requested here ?
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/877491/comments/2

it would be great if you could

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistUpgraded: Log time: 2011-12-01 11:06:28.934780
DistroCodename: oneiric
DistroRelease: Ubuntu 11.10
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-13-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-13-generic, x86_64: installed
 virtualbox, 4.1.2, 2.6.38-13-generic, x86_64: installed
 virtualbox, 4.1.2, 3.0.0-13-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0410]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Dell Inc. Latitude E4310
NonfreeKernelModules: wl
Package: mesa (not installed)
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=ed2c0c30-169b-4505-ba72-ca06f78dbf2e ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Tags: oneiric ubuntu regression-update needs-reassignment
Uname: Linux 3.0.0-13-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-12-01 (10 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/10/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 012JJ4
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd08/10/2010:svnDellInc.:pnLatitudeE4310:pvr0001:rvnDellInc.:rn012JJ4:rvrA01:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E4310
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

tags: added: apport-collected needs-reassignment oneiric regression-update ubuntu

apport information

delva (pacdelva) wrote : BootLog.gz

apport information

apport information

Hi, I'm not sure waht to do with the command apport-collect 877491... It tells me I'm not the writer of the bug. Then I sent a report but I'm not sure it worked.

Bryce Harrington (bryce) on 2012-02-04
Changed in mesa (Ubuntu):
status: Incomplete → Confirmed
oliford (oliford) wrote :

This appears to be only in mesa somewhere in 7.10.2 < ver < 8.0.1.
I put some notes on https://bugs.launchpad.net/bugs/876195 by mistake. Should that one be marked a duplicate of this or vice versa?

Xerxes Rånby (xranby) wrote :

I belive this bug are a duplicate of #965798 and got fixed in precise
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/965798

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.