compiz crashed with SIGSEGV in free()

Bug #864446 reported by Andrea Cimitan
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Undecided
Unassigned
mesa (Ubuntu)
Medium
Unassigned
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

First of all I tried revealing the launcher with the mouse, then I tried closing the maximized window that was opened and compiz crashed

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Sun Oct 2 05:28:24 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
ProcCmdline: compiz
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb6d71656: cmp 0xc(%eax),%ecx
 PC (0xb6d71656) ok
 source "0xc(%eax)" (0xffd2dbeb) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 free () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /usr/lib/i386-linux-gnu/libdrm_intel.so.1
 ?? () from /usr/lib/i386-linux-gnu/libdrm_intel.so.1
 drm_intel_bo_unreference () from /usr/lib/i386-linux-gnu/libdrm_intel.so.1
Title: compiz crashed with SIGSEGV in free()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:26967): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:26967): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

Related branches

Revision history for this message
Andrea Cimitan (cimi) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 _int_free (av=0xb0f00010, p=0xb0f9fec0) at malloc.c:4973
 __GI___libc_free (mem=0xb0f9fec8) at malloc.c:3738
 drm_intel_gem_bo_unreference_final (bo=0xa8a5f50, time=1084) at ../../intel/intel_bufmgr_gem.c:946
 drm_intel_gem_bo_unreference (bo=0xa8a5f50) at ../../intel/intel_bufmgr_gem.c:995
 drm_intel_gem_bo_unreference (bo=0xa8a5f50) at ../../intel/intel_bufmgr_gem.c:982

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
affects: nux (Ubuntu) → mesa (Ubuntu)
Jay Taoko (jaytaoko)
Changed in nux:
status: New → Fix Committed
Changed in unity:
status: New → Fix Committed
Didier Roche (didrocks)
Changed in nux (Ubuntu):
status: New → Fix Committed
Revision history for this message
Bryce Harrington (bryce) wrote :

Hey cimi,

Hi, thanks for reporting this issue during the development period of
Ubuntu.

I notice there's not been further comments to the bug report since the
release came out, would you mind updating us on the status of it in the
release?

Are you still able to reproduce the issue? If not, do you think the bug
report can be closed, or do you think we should continue tracking it?

Changed in mesa (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Bryce Harrington (bryce) wrote :

I'm going to go ahead and close out the mesa task. Since I notice the unity/nux tasks are marked fix committed so presumably they found and fixed an error there. If there is indeed some work to be done in mesa, please elaborate and reopen the mesa task and we can investigate further.

Changed in mesa (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Tim Penhey (thumper) wrote : Re: [Bug 864446] Re: compiz crashed with SIGSEGV in free()

On Tue 15 Nov 2011 15:06:07 NZDT, Bryce Harrington wrote:
> I'm going to go ahead and close out the mesa task. Since I notice the
> unity/nux tasks are marked fix committed so presumably they found and
> fixed an error there. If there is indeed some work to be done in mesa,
> please elaborate and reopen the mesa task and we can investigate
> further.

I believe that the unity and nux tasks were marked fix released as they
found a work around.

It is my understanding that there is still an underlying bug in mesa.
I'm attempting to get a simple example showing the issue.

Gord Allott (gordallott)
Changed in unity:
milestone: none → 5.0.0
Didier Roche (didrocks)
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.0.0-0ubuntu1

---------------
nux (2.0.0-0ubuntu1) precise; urgency=low

  [ Aurélien Gâteau ]
  * New upstream release:
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #881106)
    - compiz crashed with SIGSEGV in
      nux::WindowCompositor::FindKeyFocusAreaFrom() (LP: #860852)
    - compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
      (LP: #848952)
    - compiz crashed with SIGILL in typeinfo for std::ostream() (LP: #849881)
    - compiz crashed with SIGSEGV in nux::WindowThread::IsInsideLayoutCycle()
      (LP: #864686)
    - Select quicklist items with just one right click (LP: #688830)
    - OnMouseDoubleClick in InputArea isn't working (LP: #708020)
    - Menubar - horizontal scroll over a menu opens it (LP: #775872)
    - Clicking on a dash category header should not give it keyboard focus
      (LP: #905921)
    - Horizontal scroll on maximize/restore window control restores window.
      (LP: #809717)
    - Horizontally scrolling while highlighting an item in the dash or on an
      indicator will open the item. (LP: #837004)
    - compiz crashed with SIGSEGV in free() (LP: #864446)
    - Mouse wheel doesn't works if the mouse pointer is inside dash scrollbar.
      (LP: #888819)
  * debian/rules, debian/control:
    - add nuxabiversion capability as upstream is breaking a lot the ABI
      wasn't bumping the soname. Create a virtual package similar to what
      we already do in compiz to ensure we dep on the right version.
      Remove the makeshlibs override then as not needed anymore.
    - bump to nux 2.0 with new libnux-2.0-0, libnux-2.0-common, libnux-2.0-dev
      packages. Make the necessary changes in .install files as well
    - don't ship anymore the -doc package.
  * debian/nux-tools.install:
    - move the apport file there instead of the -common package to enable
      co-instability
 -- Didier Roche <email address hidden> Fri, 13 Jan 2012 09:04:48 +0100

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers