Ubuntu

[MASTER] X uses software rendering with nouveau

Reported by LGB [Gábor Lénárt] on 2011-04-13
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Wishlist
Chris Halse Rogers

Bug Description

Binary package hint: xserver-xorg-video-nouveau

In natty, X uses software rendering, as I can tell it by issuing 'glxinfo' command, also Xorg.0.log states this. That log file is about trying to load nouveau_dri.so but I have no such an object in my system, and I have no idea where I can get it from. Another (maybe unrelated!) problem, that during the boot process, my monitor switches off till gdm comes, also if I try to switch to text based console (alt-ctrl-f1, for example).

[ 29.099] (II) AIGLX: Trying DRI driver /usr/lib/dri/nouveau_dri.so
[ 29.133] (II) AIGLX: dlopen of /usr/lib/dri/nouveau_dri.so failed (/usr/lib/
dri/nouveau_dri.so: cannot open shared object file: No such file or directory)
[ 29.133] (II) AIGLX: Trying DRI driver /usr/lib/dri-alternates/nouveau_dri.s
o
[ 29.158] (II) AIGLX: dlopen of /usr/lib/dri-alternates/nouveau_dri.so failed
 (/usr/lib/dri-alternates/nouveau_dri.so: cannot open shared object file: No suc
h file or directory)
[ 29.158] (II) AIGLX: Trying DRI driver /usr/lib32/dri/nouveau_dri.so
[ 29.158] (II) AIGLX: dlopen of /usr/lib32/dri/nouveau_dri.so failed (/usr/li
b32/dri/nouveau_dri.so: cannot open shared object file: No such file or director
y)
[ 29.158] (II) AIGLX: Trying DRI driver /usr/lib32/dri-alternates/nouveau_dri
.so
[ 29.158] (II) AIGLX: dlopen of /usr/lib32/dri-alternates/nouveau_dri.so fail
ed (/usr/lib32/dri-alternates/nouveau_dri.so: cannot open shared object file: No
 such file or directory)
[ 29.158] (II) AIGLX: reverting to software rendering
[ 29.158] (II) AIGLX: Screen 0 is not DRI capable
[ 29.158] (II) AIGLX: Trying DRI driver /usr/lib/dri/swrast_dri.so
[ 29.609] (II) AIGLX: Loaded and initialized swrast

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Apr 13 10:21:34 2011
DistUpgraded: Log time: 2010-10-20 23:32:50.594007
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.0.4, 2.6.38-8-generic, i686: installed
 vboxhost, 4.0.4, 2.6.35-28-generic, i686: installed
 vboxhost, 4.0.4, 2.6.35-27-generic, i686: installed
EcryptfsInUse: Yes
GraphicsCard:
 nVidia Corporation NV44 [GeForce 6200 LE] [10de:0163] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:826d]
Lsusb:
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 1267:0213 Logic3 / SpectraVideo plc
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Hewlett-Packard HP Compaq dx2200 MT
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=UUID=24e2665f-aaa4-440b-8cb4-c37742bd51e8 ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: Upgraded to natty on 2010-10-20 (174 days ago)
dmi.bios.date: 08/14/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: MS7254 1.05
dmi.board.name: 0A48
dmi.board.vendor: MSI
dmi.chassis.asset.tag: HUB6520N19
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrMS72541.05:bd08/14/2006:svnHewlett-Packard:pnHPCompaqdx2200MT:pvr:rvnMSI:rn0A48:rvr:cvnMSI:ct3:cvr:
dmi.product.name: HP Compaq dx2200 MT
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Related branches

LGB [Gábor Lénárt] (lgb) wrote :
LGB [Gábor Lénárt] (lgb) wrote :

Sorry, about the text console: no video signal (according to my LCD monitor's opinion) during the boot, and if I switch to text console from X (like with CTRL-ALT-F1) I still see the X session however screen is not updated, till I switch back and of course mouse etc does not work either. Meanwhile I can log in "blindly" and even start an mp3 with mpg123 by using the console even if I only see the screen of X frozen (till I switch back). But as I've mentioned, maybe it's not related to this bug which is about having software rendering only.

I've just checked it out:

lgb@vega:$ ls -la /usr/lib/dri/*nou*
-rw-r--r-- 1 root root 220068 2011-04-11 08:15 /usr/lib/dri/nouveau_vieux_dri.so

Should I try symlink this to nouveau_dri.so? Since it seems X wants that, but I have onlyt this "vieux" (whatever it is ...) file only which seems to be at least similar (in file name at least) to what X would like to dlopen().

LGB [Gábor Lénárt] (lgb) wrote :

After some google'ing I've installed package libgl1-mesa-dri-experimental now I have hw rendering, but still I am wondering if it's normal since it means that nvidia owners can't use their desktops normally with natty unless installing nvidia's binary driver (I guess), is this the normal behaviour or is it really a bug? Also I still have the "no signal" monitor feedback on boot and no text concoles problems.

LGB [Gábor Lénárt] (lgb) wrote :

If it counts, I am using DVI cable between the video card and the monitor. And by the way, I have another just upgraded machine also with nvidia card and DVI: that time I tried to use nvidia's binary driver. The result: I have signal, but just very odd bar-code like screen can be seen instead of boot logo and also when I try to use text based console instead of X.

Timo Aaltonen (tjaalton) wrote :

we won't install the dri driver until it's supported upstream, and has no known grave bugs.

affects: xserver-xorg-video-nouveau (Ubuntu) → mesa (Ubuntu)
Changed in mesa (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
summary: - [natty] X uses software rendering with nouveau
+ [MASTER] X uses software rendering with nouveau
LGB [Gábor Lénárt] (lgb) wrote :

@Timo: ahaa, thanks. I am just curious what is the "official" recommendation for natty (now and when natty is released as stable) users with nvidia card: since nvidia's binary only driver is not installed by default (if I am correct) and also it seems to be unstable (X crashes sometimes with it (bug 765136).

LGB [Gábor Lénárt] (lgb) wrote :

Also I have no usable text console neither with nouveau, nor nvidia's binary driver as I've commented that bug report I've mentioned in my previous comment here.

Bryce Harrington (bryce) on 2011-05-03
tags: added: oneiric
Bryce Harrington (bryce) wrote :

[I've marked this bug for inclusion in our oneiric bug queue. While technically this bug has not been re-confirmed against oneiric, I feel it is worth continued development attention. We will need to ask that it be re-confirmed once oneiric is further along, perhaps once we get closer to alpha.]

Bryce Harrington (bryce) wrote :

At UDS we will discuss whether to enable 3D by default for nouveau in oneiric.

Changed in mesa (Ubuntu):
status: Confirmed → Triaged
status: Triaged → In Progress
Bryce Harrington (bryce) on 2011-05-20
Changed in mesa (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Launchpad Janitor (janitor) wrote :
Download full text (4.5 KiB)

This bug was fixed in the package mesa - 7.10.3-0ubuntu1

---------------
mesa (7.10.3-0ubuntu1) oneiric; urgency=low

  * New upstream 7.10.3 bugfix release.
   - Fixes infinite loop in GLSL compiler (LP: #788730)
  * Merge with Debian unstable. Remaining Ubuntu changes:
   - debian/control
      + Drop lesstif-dev from Build-Depends; it's in Universe.
      + Comment out GLw libs since it depends on lesstif-dev.
      + Drop i686 swx11 libgl package.
      + Add libdrm-dev to mesa-common-dev Depends.
    - debian/rules
      + Use --disable-glw for swx11 targets too.
      + Don't enable motif for swx11 targets.
      + Use lzma compression for binary debs to save CD space.
      + Drop unloved mach64 driver.
      + Install both r300/r300g and r600/r600g
      + Use --enable-shared-dricore to claw back CD space.
    - debian/patches
      + 100_no_abi_tag.patch
      + 101_ubuntu_hidden_glname.patch
      + 103_savage-expose_fbmodes_with_nonzero_alpha.patch
    - rules, libgl1-mesa-{glx,dev,swx11,swx11-dev}.install.in,
      libgl1-mesa-{glx,swx11}.{postinst,prerm}, libgl1-mesa-dev.links.in:
      Install libGL.so* in /usr/lib/mesa to allow things to work with
      alternatives.
    - debian/not-installed:
      + Drop i686 files; we don't build 686-optimised packages in the first
        place.
    - debian/gbp.conf
      + Point at Ubuntu branch to make git-buildpackage less narky.
    - debian/patches/105_use_shared_libdricore.patch, debian/rules:
      + Link DRI drivers against shared dricore routines to save CD space.
    - debian/patches/109_fix_length_of_glxgetfbconfigssgix.patch:
      Fix "BadLength (poly request too large or internal Xlib length"
      when using non-C, non-en locales. (LP 714280)
    - debian/patches/108_fix_leaks_dri2_screen_creation.patch: Cherrypick
      to fix some leaks in DRI2 screen creation failure paths.
    - 114_intel_dri_renderer_string.diff: Re-add "GEM" to the dri renderer
      string of the intel driver. (LP 753370)
    - 113_fix_tls.diff: Fix crashes in unrelated code due to TLS usage.
  * debian/rules:
  * debian/libgl1-mesa-dri-experimental.install.in:
    - Ship i915g in the experimental package. We're already building it,
      and it's apparently now comparable to i915c.
  * debian/control:
  * debian/libgl1-mesa-dri-experimental.install.in:
  * debian/libgl1-mesa-dri.install.linux.in:
    - Move nouveau gallium driver from -dri-experimental to -dri. Upstream
      is no longer adamant that bugs should be ignored. Try installing it by
      default to get a better Unity experience OOTB. (LP: #759562)
  * debian/libgl1-mesa-dri-experimental.install.in:
  * debian/libgl1-mesa-dri.install.linux.in:
    - Move r300/r600 classic drivers to -experimental. They're not supported.
      Shave another ~1MB off the CD!
  * debian/control:
    - Add new bison and flex build-depends.
  * debian/patches/115_llvm_dynamic_linking.diff
    - Dynamically link DRI drivers to libllvm. Saves ~6MiB per DRI driver.
  * debian/rules:
  * debian/patches/116_use_shared_galliumcore.diff:
  * debian/libgl1-mesa-dri.install.in:
    - Link gallium DRI drivers against shared gallium routines to save CD
      sp...

Read more...

Changed in mesa (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers